locked
Microsoft Visual C++ Runtime Library error question

    Question

  • Everytime i try to play a game on my computer, the Microsoft Visual C++ Runtime Library error pops up, i installed the game fable on my computer and my computer has more then the requirements needed to play it, but after i install it and try to play the error pops up and i can't play it. this has happened for several games.. what can i do to stop it?
    Wednesday, April 04, 2007 2:13 AM

Answers

  • Hello

     

    Re: Microsoft Visual C++ Runtime Library error question

     

    There are issues with the software you are installing, please contact the manufacturer’s support services.

     

    Thanks

    Damien

    Friday, April 06, 2007 11:28 PM
  • This thread has drifted far from the original question to become a miscelany of gossip, tips, tribal knowledge and rumor about how to resolve various game (etc) incompatibilities.

     

    As Damien Watkins replied originally, this error indicates that the program you're trying to use was built with Visual C++, but you need to work with the vendor of the program to resolve the error - the Visual C++ product team doesn't know why your game doesn't work, and neither do the members of the Visual C++ programming community.

     

    Based on this, I'm locking this thread to prevent further posts - if you see this error, contact the appropriate support organization within the vendor of the program you're trying to use (and yes, that vendor might be Microsoft).

    Wednesday, November 28, 2007 12:30 AM

All replies

  • Hello

     

    Re: Microsoft Visual C++ Runtime Library error question

     

    There are issues with the software you are installing, please contact the manufacturer’s support services.

     

    Thanks

    Damien

    Friday, April 06, 2007 11:28 PM
  • Actually Damien, I have the same problems with microsoft visual c++ error messages. It's not up to the manufacturer of the game or software, so don't pawn it off on them, because my games work with windows xp. Since i've had windows vista, i've had nothing but trouble and it seems like microsoft always wants to blame everyone else instead of just fixing the operating system they've created. There must be an easier fix to the problem.

     

    Thanks,

    Josh

    Friday, April 13, 2007 6:57 AM
  • I have the same problem playing Hidden & Dangerous 2. I can't believe that so many people have this problem with different applications for the fault to lie with the software developers. It must be something that Microsoft can solve itself.

     

    I'm starting to wish that I didn't upgrade to Vista now.

     

    Please fix this!!!!!!!!

     

    Geek UK

    Friday, April 13, 2007 8:50 PM
  • I'm getting the error with my Internet Provider (FiOS). I'm using XP SP2. Every time I try and run a Help/Support function with Verizon FiOS, I get the error and Explorer shuts down. It seems unlikley that every manufacturer is at fault here. And to tell you the truth I don't care who is at fault -  I JUST WANT IT FIXED. And trying to contact a human is just impossible. Let's hear it for the wonderful customer service we receive from the biggest stinking company on the frigging planet.
    Friday, April 20, 2007 3:03 AM
  • I have the same problem with Lock on simulation game.........I runing vista home premium.It is possible to resolve the problem?????????????//
    Sunday, April 29, 2007 7:55 PM
  • I don't know if this has been dealt with yet, but i'm having the same problem. Although the error is occuring with Internet Explorer, not with a game or a product by another manufacturer. What can be down about this? How can I fix this error?

    My laptop is less than 6 weeks old and i'm trying to connect broadband and I can't even open Internet Explorer for long enough to load one simple page. And no, it's not a problem with the page - it's not even a page on the net - it's simply a direct link to my modem (through the ethernet cable) and IE crashes before I can even finish configuring my modem to allow me to access the internet.

    What's the problem here?

    Oh, I'm on Vista too. Maybe that's the problem.
    Thursday, May 03, 2007 12:09 AM
  • Anonymous Australia,

    I have been dealing with this for over a week.  I tried EVERYTHING and i finally got it fixed today.  Try doing this:

    - Start computer in safe mode with networking capability (HOLD F8 while computer is starting up)

    -Go to you internet explorer

    -Go to Tools

    _Mananage Add-Ons

    -Disable ALL of the add ons (You have to toggle between the two options in the drop down box)

    -Once ALL are disabled, delete your cookies (Tools - Internet Options)

     

    This worked for me.  Good luck!!

    Monday, May 07, 2007 2:30 PM
  • I've just been trying to find a solution for this on microsoft.support and nothing worked.

    I've got about 25 machines with the same problem, they all started showing C++ errors last week.

    The only new software installed was Windows Automatic Updates! Cheers!!

     

    Thanks for that solution it seems to be working so far

    Thursday, May 10, 2007 11:39 AM
  • Does this fix apply when using Vista?  I get this Microsoft Visual C++ Runtime Library Error every time I try to open Quattro Pro 10 and my OS is Vista.
    Tuesday, May 15, 2007 1:16 AM
  • I too am having the same problem with Hidden and Dangerous 2, I have a brand new Dell system with Windows Ultimate. It lauched before I installed the 1.12 patch.

     

    Geek UK,

    Any developments on this?  I have been sipping on this game since 2003, like a a rare whiskey......I sure hope my new pc will let me finish this game.

     

     

    _________________________________

     

     

    I was also having the exact same error issue this weekend with Republic Commando on my mothers PC (win xp) that was also a new Dell last fall.

    Wednesday, May 16, 2007 12:01 AM
  • HI!

    I have the problem, that when I want to install Microsoft Visual c++ 2005 Redistributable, it always come up with the same error message:

    Command line optionts syntax error. Type Command /? for Help.

    What can I do with it? Thanks for the help
    Wednesday, May 16, 2007 10:27 AM
  • I have found the resolution.... I just got off the phone with Illusion.......

     

    Go to the .exe Hidden and Dangerous 2 Icon and right click and choose properties.....then select the compatibility tab and in the compatability mode click "Run this program in compatability mode" select "Windows XP Service Pack 2"

     

    After that then right click on the icon again and "Run as Administrator"

     

    The guy at Illusion said he hopes the service pack this fall will fix it.....

     

    Hope this helps...

     

    Chuck

     

    Saturday, May 19, 2007 6:56 PM
  • Thanks for the response Chuck, however I don't have a "Compatibility Tab" on the  properties of the icon! It is there for other shortcuts, just not this one!

     

    Any ideas why this is the case?

     

    Taa,

    Geek_UK

    Monday, May 21, 2007 8:28 PM
  • OK,

    I have now resolved this. Hidden & Dangerous finally works!!!!!!!!!!!!!!!!!!!!!!

    Thanks Chuck, your solution works.

    For others, if you don't have the compatibility tab on your properties of the icon, then you can run the Program Compatibility Wizard (control panel, Programs, er..run program in older software...or something like that - I'm not on a vista machine right now so not sure!)

    Set it up to run in windows xp sp2 mode, and run as administrator (just as Chuck has mentioned). But in order to set the 'run as admin' setting using the wizard, you need to be logged on as admin (note that if you have the compatibility tab, you don't need to manually log on as admin).

    Hope that helps anyone!

    G_UK

    Wednesday, May 23, 2007 11:55 AM
  • For everyone who has an active interest in this thread, you are looking in completely the wrong place. This is a forum for developers who use C++ and specifically Visual Studio to program with, and has nothing to do with people getting exceptions.

     

    There is a lot of software out there and it's very difficult for Microsoft to restructure an OS the way they did with Vista and still guarantee 100% compatibility with everything from XP. There is also always the possibility that bad code that worked on XP is being picked up in Vista as, "bad code."

     

    If you really think it is Microsoft's fault, talk to their service desk, or log a complaint, but it really has nothing to do with the point of this forum. Sorry.

    Wednesday, May 23, 2007 12:06 PM
  • Great to hear....I didnt have the tab on mine either at first....Then something I am not sure happened and then it appeared.....your description is probably the better of the two....I have only had my system for about 2 weeks now and I am loving it so far.....Its good to get past some of these learning curves with Vista...

     

    Wednesday, May 23, 2007 11:16 PM
  • I had the same problem trying to run a video editing program called PowerDirector from Cyberlink. I have been working with their technical support to no avail. I used Windows explorer to look at the .exe file. Right clicking brought up the menu as described. Worked great! I am running Windows Vista on an HP laptop with an Intel Core2 duo processor.  Thanks.
    Tuesday, May 29, 2007 4:34 AM
  • Damien,

     

    I believe this problem is more widespread than you think. It may fall back on the manufacturer but it appears to be a Vista issue. I was working with the Cyberlink to install their video editing software (PowerDirector 6.0). I was not having any succss until I found this thread and followed the steps outlined by Chuck H. I am now able to run the software, although with a few extra steps to start it. This is the version of their software that is Vista compatible.

     

    Bob

    Tuesday, May 29, 2007 4:46 PM
  • Im Having a Problem With my Lexmark Z640 Printer when i try to print something it just comes up with this c++ error library message and i need to print something off before mid-day saturday please help me!!! HELP!!!!
    Wednesday, May 30, 2007 7:30 PM
  • The way I fixed this problem was to see what file I was getting the runtime error for. (it tells you in the error message...mine was for RoxWatchTray.exe) I did the following steps to fix my problem...

    ~Start ~click
    ~you want to open: msconfig.exe ~click ok
    ~this opens the System Configuration Utility
    ~you want to click the Startup tab
    ~then look for the name of the file that is giving you the error.
    ~uncheck the box
    ~restart you PC..

    That's how I fixed my problem, Hope it helps other...
    Saturday, June 02, 2007 6:04 AM
  • Hi I have the same prob with one of microsofts games called Rallisport challenge. The box pops up when I try to play the game and thats it, it completely crashes. There must be a fix for this I hav4e all the drivers to play it and hardware. This is on xp home sp2 though ????????

    thanks, jake
    Monday, July 09, 2007 5:09 PM
  • I have the same problem
    Tech support number is 1 888 553-1555
    not easy to find but it is there.

    Tech had me a do a reset which didn't help then he told me told me if the reset didn' work it is a microsoft problem

    I have also gotten a message to call 1 800 pls-help and they will assist in re-installing the globecom connection manager

    So far only a busy signal

    Hope things get better for you soon

    BT
    Saturday, August 25, 2007 11:52 AM
  • fios help 1 888 553-1555
    I have same problem. I'm using IE7 and 6
    with 6 I get the call 1 800 pls-help that is busy
    tech had me reset and whan that didn't work he said it is a microsoft problem.
    Saturday, August 25, 2007 12:01 PM
  • I have bought a laptop and Power director software and am having the same problems - I keep getting the runtime error. I've followed the instructions outlined by Chuck and still nothing. Pls can you assist as I am keen to get going.

     

    Redries

     

    Monday, August 27, 2007 8:36 AM
  • I use a 3D Art programme called DAZ Studio and I was often Getting the dreaded Visual C error message particularly with certain props.  Vista does seem to have a few issues of compatibility with some Graphics drivers even though my Graphics card is supposedly 'Vista Ready'.  I recently got a new Beta update for the card which helped a little but on installing a slightly updated version of the programme I was back to the start.  After reinstalling the Graphics drivers in the hope it might overwrite whatever the problem was - no luck.  I read your article and tried it and although I still expect Vista issues, so far so good
     
    Thank you Chuck
    Thursday, August 30, 2007 1:50 PM
  • I had the same problem with Internet Explorer in Vista Home Premium. As soon as I opened the browser I got the c++ runtime exception. I "fixed" it by removing and deactivating all addons. Control panel -> Internet -> Programs -> Addons
    There were about 20 addons listed there. I removed all I could and deactivated the rest. So I do not know yet which addon it was that caused the exception.
    Thursday, August 30, 2007 9:24 PM
  • I have windows xp and it just started when i downloaded a game for my grandson it was fish tycoon and i have tried everything that has been sugested but i am open for sugestion

    Tuesday, September 18, 2007 10:04 PM
  • Swedash thanks your solution is working so far.

    Thursday, September 27, 2007 9:55 PM
  • I get the same thing, only i'm trying to play Simcity 3000 on a Pentium 4 Dell with 49 GB's of free space. I just installed Microsoft XP Pro Edition and now SC3K won't run. Please try and help me as I can't stand any longer without my preciousssssssssssssssssssssssssssssssssssssssss SC3K!
    Friday, September 28, 2007 7:57 PM
  • Thanks so much Chuck!! It works!!!!

    Thursday, November 01, 2007 5:49 PM
  • right im not sure if im dping this right but anyway right im trying to load oblivion on to my laptop it has all the things i need for it the thing is i tried what chuck said it worked the first time when i tried to do it again it just came up with that  microsoft visual c++ thing pls cn sum1 help

     

    Sunday, November 04, 2007 9:12 AM
  • i have the same thing but mine is totally different. because it will pop up when i restart my computer and it's doing it to my roxio disc tray

     

    i need some help here!!!!

     

    Thursday, November 08, 2007 2:39 AM
  •  

    I hate Vista and I hate my ISP. Nothing works on this brand new PC! I cant' even chat for this stupid error message.
    Tuesday, November 20, 2007 12:39 AM
  • I had this same problem when I tried to run Wings Over Vietnam.  I had run the program with Vista (on my new quad core machine) without problems (no compatibility mode selected).  Then I went to run it today, a week later, and it wouldn't run.  Instead I got the C++ runtime error.  I uninstalled and re-installed, but to no avail.  I changed the 'compatability' mode, experimenting with the optional settings, but the program still wouldn't work.

    I went through the "programs and features" menu in the control panel window, formely known as "Add or Remove Programs" in XP, and disabled ALL windows features.  (I went back and re-enabled the standard games later.) 

    I wasn't doing this with the intent of solving the problem, so I don't know exactly what actually fixed the problem.   In the process I removed several non-essential processes that came pre-installed on the computer (standard retailer installation package).  One was an imaging indexing process, a couple HP specific programs, and I forgot what else.  These were non-critical programs!

    Then on a whim, I re-installed WOV, and it worked!  Oh, and I am NOT running in "Compatibility Mode"--just straight up Vista Home...  And I run "Basic Windows" setting to optimize my system's performance (system now runs on 1/2 the memory that Vista would otherwise hog)

    (I did remove "Yahoo! toolbar" in this process, but did not remove 'all' add-ons for IE.)

    Maybe someone with this problem could systematically run through these changes to see what specific process is interfering with these programs?  It might be that annoying yahoo toolbar....if other people solved it just by clearing the add-ons...




    Friday, November 23, 2007 1:23 AM
  • Im having this problem with my football manager 08 game and so far it seems to of baffled Soprts Interactive because they keep trying to pass off my problem as a different one they have fixed. Does anyone have any idea in how I could fix this problem so I can start playing my game? Please....

    Sunday, November 25, 2007 4:46 PM
  • Actually I have a question for Damien... I have been using Microsoft Picture It! Publishing for 5 years... all of a sudden I started getting Microsoft Visual Runtime errors and it shuts down PIP. No "software" incompatibility issues - it's all Microsoft.......What solutions are there so that I may use this program again?

     

    Tuesday, November 27, 2007 10:24 PM
  • This thread has drifted far from the original question to become a miscelany of gossip, tips, tribal knowledge and rumor about how to resolve various game (etc) incompatibilities.

     

    As Damien Watkins replied originally, this error indicates that the program you're trying to use was built with Visual C++, but you need to work with the vendor of the program to resolve the error - the Visual C++ product team doesn't know why your game doesn't work, and neither do the members of the Visual C++ programming community.

     

    Based on this, I'm locking this thread to prevent further posts - if you see this error, contact the appropriate support organization within the vendor of the program you're trying to use (and yes, that vendor might be Microsoft).

    Wednesday, November 28, 2007 12:30 AM