none
The request for security token could not be satisfied because authentication failed.

    Question

  • Hi,

    I am not able to run http://localhost/group5/service.svc.

    I get the following configuration error.

     

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: There is no binding named 'helloBinding' at system.serviceModel/bindings/wsHttpBinding. Invalid value for bindingConfiguration.

    Source Error:

    Line 5:        <service 
    Line 6:            name="ProgrammingIndigo.HelloService">
    Line 7:          <endpoint
    Line 8:              address="" 
    Line 9:              bindingConfiguration="helloBinding" binding="wsHttpBinding" 


    Source File: C:\group5\web.config    Line: 7

    Here is my web.config file.

    <?xml version="1.0" encoding="utf-8" ?>

    <configuration>

    <system.serviceModel>

    <services>

    <service

    name="ProgrammingIndigo.HelloService">

    <endpoint

    address=""

    bindingConfiguration="helloBinding" binding="wsHttpBinding"

    contract="ProgrammingIndigo.HelloService" />

    </service>

    </services>

    </system.serviceModel>

    <system.web>

    <compilation debug="true" />

    </system.web>

    </configuration>

     

    Could you please help me out in figuring out what the problem is i have searched and tried but not able to find a solution.

    Thank you,

    Sree

     

    Wednesday, June 28, 2006 6:32 AM

All replies

  • Hi

    Custom binding configuration binding can be used to tweak the default settings of the binding you use (such as disabling security).

    Seems in your code you have no binding configuration section, yet your binding is set to look for one.

    Remove this code:

     bindingConfiguration="helloBinding"

    Wednesday, June 28, 2006 11:22 AM
  • Thank you Adiavn. It could have helped but i forgot to add this

    <bindings>

    <wsHttpBinding>

    <binding name="helloBinding">

    <reliableSession enabled="true"/>

    </binding>

    </wsHttpBinding>

    </bindings>

    After adding this to the config file i was able to run it with no problem on the localhost.

    I am now trying to run this on a another system which is on the same network(it would be great if i could on another network but has of now the same networkis fine :-)  ).

    I am able to generate the proxy class and out.config files with no problem. When run the client.aspx i get an

    error on the client side The request for security token could not be satisfied because authentication failed.

    What do i have to do now to able to run this.

    Here is my web.config file on the server/service side. (I am hosting the server on the IIS, do i need to make any changes in that)

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
    <system.serviceModel>
    <services>
    <service
    name="ProgrammingIndigo.HelloService">
    <endpoint
    address=""
    bindingConfiguration="helloBinding" binding="wsHttpBinding"
    contract="ProgrammingIndigo.IHello" />
    </service>
    </services>
    <bindings>
    <wsHttpBinding>
    <binding name="helloBinding">
    <reliableSession enabled="true"/>
    </binding>
    </wsHttpBinding>
    </bindings>
    </system.serviceModel>
    <system.web>
    <compilation debug="true" />
    </system.web>
    </configuration>

    And my client side web.config which is auto generated using the svcutil.

    <?xml version="1.0"?>
    <configuration>
     <system.serviceModel>
      <bindings>
       <wsHttpBinding>
        <binding name="WSHttpBinding_IHello" bypassProxyOnLocal="false" transactionFlow="false" hostNameComparisonMode="StrongWildcard" maxBufferPoolSize="524288" maxReceivedMessageSize="65536" messageEncoding="Text" textEncoding="utf-8" useDefaultWebProxy="true">
         <readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384" maxBytesPerRead="4096" maxNameTableCharCount="16384"/>
         <reliableSession ordered="true" inactivityTimeout="00:10:00" enabled="true"/>
         <security mode="Message">
          <transport clientCredentialType="None" proxyCredentialType="None" realm=""/>
          <message clientCredentialType="Windows" negotiateServiceCredential="true" algorithmSuite="Default" establishSecurityContext="true"/>
         </security>
        </binding>
       </wsHttpBinding>
      </bindings>
      <client>
       <endpoint address="
    http://sree/group5/service.svc" binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_IHello" contract="IHello" name="WSHttpBinding_IHello"/>
      </client>
     </system.serviceModel>
     <system.web>
      <compilation debug="true"/></system.web></configuration>

    Please let me know what changes i need to make.

    Thank you


     

     

     

    Wednesday, June 28, 2006 12:03 PM