locked
VS 11 Beta, Dark theme show white background for text editor

Answers

  • Hi Trout.Z,

    Thank you for reporting this issue. When in the Dark theme the "Use Default" button in the dialog will always set the default Fonts and Colors to the Light theme color in Beta. We just fixed this internally so "Use Defaults" will behave as you expect it to in both themes. Meanwhile if you ever get back into this state (dark theme with white editor colors), you can:

    1. Go to Tools | Import and Export Settings…
    2. Import selected environement settings
    3. Click “Next”.
    4. Save your current settings if you wish, then click “Next”.
    5. Scroll to the bottom of the list and find: "Dark Fonts and Colors" (under Recent Files)
    6. Select that settings file and then "Next" and "Finish."

    Please let me know if this does not resolve your issue.

    Thanks,
    Cathy Sullivan
    Program Manager, Visual Studio Pro Experience Team
    http://blogs.msdn.com/b/visualstudio

    • Proposed as answer by Harold Short Tuesday, March 13, 2012 5:29 PM
    • Marked as answer by Trout.Z Friday, April 06, 2012 2:12 AM
    Friday, March 09, 2012 5:59 AM
  • I try very hard to find that "C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\FontsAndColorsThemes\1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings" is used for dark theme, then did some experiments.


    Let me summarize: 


    1 reset settings in Tools ,  WillNotWork
    2 start /resetsettings ,  WNW
    3 delete CurrentSettings.vssettings, WNW
    4 delete FontsAndColorsBackup_1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings, WNW
    5 remove the 2 backup entries below, WNW
    [HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\11.0\Profile\BrowseFiles]
    "%vsspv_visualstudio_dir%\\settings\\CurrentSettings.vssettings"=dword:00000001
    "%vsspv_visualstudio_dir%\\settings\\FontsAndColorsBackup_de3dbbcd-f642-433c-8353-8f1df4370aba.vssettings"=dword:00000001
    "%vsspv_vs_install_directory%\\Common7\\IDE\\FontsAndColorsThemes\\1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings"=dword:00000001
    "%vsspv_visualstudio_dir%\\settings\\FontsAndColorsBackup_1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings"=dword:00000001


    6 Edit CurrentSettings.vssettings, copy&paste the the "Environment_FontsAndColors" Category from within 1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings.   Then it finally works!!!






    Help this is useful.

    I am a passionate game programmer.

    • Marked as answer by Trout.Z Thursday, March 08, 2012 3:03 AM
    Thursday, March 08, 2012 3:02 AM
  • Ray: You can point the import at C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\FontsAndColorsThemes\1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings to pick up the settings.
    • Marked as answer by Trout.Z Friday, April 06, 2012 2:12 AM
    Tuesday, April 03, 2012 2:18 PM

All replies

  • It happened to me also, and i read somewhere that happened to many people.

    MAJOR BUG!!!!

    I solved it by goin to  Options: Fonts and Colors: Use defaults and restarting Visual Studio, cheers.

    Wednesday, March 07, 2012 6:16 PM
  • That doesn't work for me as I tried before posting, and tried again after your suggestion.

    There is one thing to notice that, when I select Text Editor, the listbox of "Display items" is empty, and change text size will do nothing either.


    I am a passionate game programmer.

    Thursday, March 08, 2012 2:30 AM
  • I try very hard to find that "C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\FontsAndColorsThemes\1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings" is used for dark theme, then did some experiments.


    Let me summarize: 


    1 reset settings in Tools ,  WillNotWork
    2 start /resetsettings ,  WNW
    3 delete CurrentSettings.vssettings, WNW
    4 delete FontsAndColorsBackup_1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings, WNW
    5 remove the 2 backup entries below, WNW
    [HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\11.0\Profile\BrowseFiles]
    "%vsspv_visualstudio_dir%\\settings\\CurrentSettings.vssettings"=dword:00000001
    "%vsspv_visualstudio_dir%\\settings\\FontsAndColorsBackup_de3dbbcd-f642-433c-8353-8f1df4370aba.vssettings"=dword:00000001
    "%vsspv_vs_install_directory%\\Common7\\IDE\\FontsAndColorsThemes\\1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings"=dword:00000001
    "%vsspv_visualstudio_dir%\\settings\\FontsAndColorsBackup_1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings"=dword:00000001


    6 Edit CurrentSettings.vssettings, copy&paste the the "Environment_FontsAndColors" Category from within 1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings.   Then it finally works!!!






    Help this is useful.

    I am a passionate game programmer.

    • Marked as answer by Trout.Z Thursday, March 08, 2012 3:03 AM
    Thursday, March 08, 2012 3:02 AM
  • Hi Trout.Z,

    Thank you for reporting this issue. When in the Dark theme the "Use Default" button in the dialog will always set the default Fonts and Colors to the Light theme color in Beta. We just fixed this internally so "Use Defaults" will behave as you expect it to in both themes. Meanwhile if you ever get back into this state (dark theme with white editor colors), you can:

    1. Go to Tools | Import and Export Settings…
    2. Import selected environement settings
    3. Click “Next”.
    4. Save your current settings if you wish, then click “Next”.
    5. Scroll to the bottom of the list and find: "Dark Fonts and Colors" (under Recent Files)
    6. Select that settings file and then "Next" and "Finish."

    Please let me know if this does not resolve your issue.

    Thanks,
    Cathy Sullivan
    Program Manager, Visual Studio Pro Experience Team
    http://blogs.msdn.com/b/visualstudio

    • Proposed as answer by Harold Short Tuesday, March 13, 2012 5:29 PM
    • Marked as answer by Trout.Z Friday, April 06, 2012 2:12 AM
    Friday, March 09, 2012 5:59 AM
  • Thanks, and frankly to say, I've never used the "import" feature, and always use "reset".  Your solution is good than mine.


    I am a passionate game programmer.

    Friday, March 09, 2012 4:43 PM
  • Cathy,

    I've experienced the same problem on several computers.  What if "Dark Fonts and Colors" doesn't appear in your Recent Files list?

    Thanks,

    Ray

    Wednesday, March 28, 2012 1:38 PM
  • Ray: You can point the import at C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\FontsAndColorsThemes\1ded0138-47ce-435e-84ef-9ec1f439b749.vssettings to pick up the settings.
    • Marked as answer by Trout.Z Friday, April 06, 2012 2:12 AM
    Tuesday, April 03, 2012 2:18 PM
  • Hi Ray,


    Please try the following steps if you don't see the Dark Fonts and Colors settings in the Recent Files list:

    Note: If you have editor customizations that you would like to save before resolving this issue, follow the below steps under "Editor customization save steps."

    1. Ensure you only have a single instance of Visual Studio open.

    2. On your machine, browse to:

    C:\Users\<your user account>\Documents\Visual Studio 11\Settings

    3. Switch to the Light theme if not already using it.

    4. Delete all .vssettings files in the above Settings location that begin with: FontsAndColorsBackup_

    5. Perform a settings reset:

         1. Go to Tools -> Import and Export Settings…

         2. Select “Reset all settings”.  Click “Next”.

         3. Select “No, just reset settings, overwriting my current settings”.  Click “Next”.

         4. Select your desired settings profile.  Click “Finish”.

    Editor customization steps:

    1. Go to Tools -> Import and Export Settings…

    2. Select “Export selected environment settings”.  Click “Next”.

    3. Select the settings you would like to export.  Click “Next”.

    4. Chose the settings file name and the location you'd like to export the settings file to.  Click “Finish”.

    Also note, this has been fixed in the next release of Visual Studio 11.

    Thanks,
    Cathy Sullivan
    Program Manager, Visual Studio Pro Experience Team
    http://blogs.msdn.com/b/visualstudio

    Tuesday, May 08, 2012 9:12 PM