none
"Unable to connect visual studio's localhost webserver" Help

    Question

  • I have this error when i try to execute my aplication web

    "Unable to connect visual studio's localhost webserver"

    My S.O is XP SP2 and Visual Studio 2005.

    Can somebody help me?

    *Sorry bad english
    Wednesday, January 30, 2008 8:27 PM

Answers

  •  Jackson Davis - MSFT wrote:
    It's probably just not in your path. If you cd to the root and execute "dir /s iisreset.exe" does it find it?

     



    This time i put my cd XP, installed IIS.

    So, I used again aspnet_regiis –i ,after this i used iisreset, then the services was stopped and was restarted again! I'm back to Visual Studio and..... show me the same message before...

    "Unable to connect visual studio's localhost webserver"

    =/ other hints please...
    Wednesday, January 30, 2008 11:28 PM
  •  Jackson Davis - MSFT wrote:

    Are you running the 64-bit version of windows xp? If so, try the steps at this article:

     

    http://support.microsoft.com/kb/920719

     

    Jackson

     



    I  tried this line

    cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 1
    %windir%\microsoft.net\framework\v2.0.50727\aspnet_regiis.exe – i

    but running this in prompt results in:

    The path requested could not be found.
    ErrNumber: -2147024893 (0x80070003)
    Error Trying To Get the Object: W3SVC/AppPools

    I searched about this problem in many sites, and unfortunately didnt'n search someone who solved it with precision.

    I read in some place about firewall! my windows firewall was disabled! Comodo firewall was disabled too! but same disabled I discovered that the Comodo Firewall running a process that couldn't closed by task manager! so, i uninstaled it and finally my aplication ran. My problem was solved.

    Thanks a lot! sorry bad english.
    Friday, February 01, 2008 1:10 AM

All replies

  • Try running this at the command prompt:

     

    C:\>cd WINDOWS\Microsoft.NET\Framework\v2.0.50727

    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis –i 
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>iisreset

     

    HTH

    Jackson

     

    Wednesday, January 30, 2008 8:35 PM
  •  Jackson Davis - MSFT wrote:

    Try running this at the command prompt:

    C:\>cd WINDOWS\Microsoft.NET\Framework\v2.0.50727

    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis –i 
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>iisreset


    HTH

    Jackson



    when i wrote at prompt command

    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis –i

    I had the message "Start Instaling ASP.NET"

    Finished Instaling ASP.NET

    But when i wrote "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>iisreset"

    I Had the message "iisreset is not recognized as a intern command" (I translate this line because my XP is Brasilian)

    please help me, I'm with this problem there is many days...

    iisreset.... is it correct this command?



    Wednesday, January 30, 2008 8:52 PM
  • It's probably just not in your path. If you cd to the root and execute "dir /s iisreset.exe" does it find it?

     

    Wednesday, January 30, 2008 9:42 PM
  •  Jackson Davis - MSFT wrote:
    It's probably just not in your path. If you cd to the root and execute "dir /s iisreset.exe" does it find it?

     



    This time i put my cd XP, installed IIS.

    So, I used again aspnet_regiis –i ,after this i used iisreset, then the services was stopped and was restarted again! I'm back to Visual Studio and..... show me the same message before...

    "Unable to connect visual studio's localhost webserver"

    =/ other hints please...
    Wednesday, January 30, 2008 11:28 PM
  • does anybody has another solution? =/

    Thursday, January 31, 2008 3:37 PM
  • Are you running the 64-bit version of windows xp? If so, try the steps at this article:

     

    http://support.microsoft.com/kb/920719

     

    Jackson

     

    Thursday, January 31, 2008 8:58 PM
  •  Jackson Davis - MSFT wrote:

    Are you running the 64-bit version of windows xp? If so, try the steps at this article:

     

    http://support.microsoft.com/kb/920719

     

    Jackson

     



    I  tried this line

    cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 1
    %windir%\microsoft.net\framework\v2.0.50727\aspnet_regiis.exe – i

    but running this in prompt results in:

    The path requested could not be found.
    ErrNumber: -2147024893 (0x80070003)
    Error Trying To Get the Object: W3SVC/AppPools

    I searched about this problem in many sites, and unfortunately didnt'n search someone who solved it with precision.

    I read in some place about firewall! my windows firewall was disabled! Comodo firewall was disabled too! but same disabled I discovered that the Comodo Firewall running a process that couldn't closed by task manager! so, i uninstaled it and finally my aplication ran. My problem was solved.

    Thanks a lot! sorry bad english.
    Friday, February 01, 2008 1:10 AM
  • Great, I'm glad you got your problem solved. I'll have to remember to recommend disabling third party firewalls in the future.

     

    Jackson

    Friday, February 01, 2008 1:13 AM
  •  

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Administrator.SYS12>cd/

    C:\Documents and Settings\Administrator.SYS12>cd\

    C:\>cd windows

    C:\WINDOWS>cd microsoft
    The system cannot find the path specified.

    C:\WINDOWS>cd microsoft.net

    C:\WINDOWS\Microsoft.NET>cd framework

    C:\WINDOWS\Microsoft.NET\Framework>cd v2.0.50727

    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis -i
    Start installing ASP.NET (2.0.50727).
    ................................
    Finished installing ASP.NET (2.0.50727).

    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>iisreset

    Attempting stop...
    Internet services successfully stopped
    Attempting start...
    Internet services successfully restarted

    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>


    Above text which u r viewing is all happened in my system
    but still i have the same prblm
    my prblm is not solved
    pls help me
    even after uninstalling third party wall also i have this prblm
    give a solution
    Tuesday, August 05, 2008 6:56 AM
  • i got the solution for "unable to connect to local host webserver in visual studios 2005"

    i just uninstalled firewall which is in my system
    now it is connecting to localhost

    than q



    Tuesday, August 05, 2008 9:27 AM
  • Unable to Connect to the ASP.Net WebServer on Localhost

    This Link will fix your problem…..

    http://softwares-u-need.blogspot.com/search/label/asp.net

    The above link Is MY BLOG

    Just do what it says….Please mail me if any questions…
    CHECK DOWNLOAD LINK WILL IN filefactory.com/

    Vibin
    Friday, January 22, 2010 2:32 PM
  • Kill the process inetinfo.exe and then try to run your application again.
    Tuesday, June 28, 2011 10:18 AM