none
File system to TFS2010 migration reports "not a TFS2010 server"

    Question

  • On my workstation I have VS2010 Ultimate and TFS Integration Tools (2.0.31118) installed. I am trying to perform a one-way migration from the local file system to the TFS2010 server.

    Very quickly after pressing "Start", this exception is thrown:

    [7/02/2011 5:50:26 PM] TfsIntegrationService.exe Warning: 0 : : The target server http://tfs2010:8080/ is not a TFS2010 server
    [7/02/2011 5:50:26 PM] TfsIntegrationService.exe Information: 0 : : Microsoft.TeamFoundation.Migration.Toolkit.MigrationException: The target server http://tfs2010:8080/ is not a TFS2010 server
    [7/02/2011 5:50:26 PM]    at Microsoft.TeamFoundation.Migration.Tfs2010VCAdapter.TfsVCAnalysisProvider.initializeTfsClient()
    [7/02/2011 5:50:26 PM]    at Microsoft.TeamFoundation.Migration.Tfs2010VCAdapter.TfsVCAnalysisProvider.InitializeClient()
    [7/02/2011 5:50:26 PM]    at Microsoft.TeamFoundation.Migration.Toolkit.AnalysisEngine.Initialize(Int32 sessionRunId, ISessionOrchestrator sessionOrchestrator)
    [7/02/2011 5:50:26 PM]    at Microsoft.TeamFoundation.Migration.Toolkit.SessionWorker.Initialize(Int32 sessionRunId)
    [7/02/2011 5:50:26 PM]    at Microsoft.TeamFoundation.Migration.Toolkit.SyncOrchestrator.InitializePipelines()
    [7/02/2011 5:50:26 PM]    at Microsoft.TeamFoundation.Migration.Toolkit.WCFServices.MigrationService.StartSessionGroup(Guid sessionGroupUniqueId)

    As far I can tell, tfs2010:8080 *is* a TFS2010 server. I can check in files from VS's source control explorer.

    I would be grateful for any ideas. Thanks!

     

    Monday, February 07, 2011 6:53 AM

Answers

  • OK, put this down to a lack of understanding. When I touched the semaphore file, the migration worked.
    • Marked as answer by gmellor Tuesday, February 08, 2011 3:51 AM
    Tuesday, February 08, 2011 3:51 AM

All replies

  • Sounds like it doesn't like the URL. Things to check:


    Robert MacLean - www.sadev.co.za
    Monday, February 07, 2011 12:47 PM
  • Sounds like it doesn't like the URL. Things to check:


    Robert MacLean - www.sadev.co.za


    Thanks for the suggestions Robert. Turns out I was wrong and it is actually a TFS 2008 server! So I tried with a new configuration (file system > TFS 2008) and encountered another error:

    [8/02/2011 11:07:38 AM] TfsIntegrationService.exe Information: 0 : VersionControl: Session worker thread [VersionControl] started
    [8/02/2011 11:07:38 AM] TfsIntegrationService.exe Warning: 0 : VersionControl: Skipping this synchronization pass because AnalysisAddin of type 'SemaphoreFileAnalysisAddin.SemaphoreFileAnalysisAddin' returned false for ProceedToAnalysis()

    Any idea why the SemaphoreFileAnalysisAddin might have decided that "ProceedToAnalysis" should return false? Some more logging would have been helpful!

    Thanks

    Tuesday, February 08, 2011 12:13 AM
  • OK, put this down to a lack of understanding. When I touched the semaphore file, the migration worked.
    • Marked as answer by gmellor Tuesday, February 08, 2011 3:51 AM
    Tuesday, February 08, 2011 3:51 AM