none
Beware of bug in AVG 2011 Client on Servers with TFS

    General discussion

  • After 2 days of not being able to create new projects and/or checking more than one file into TFS we were able to find the source of the problem.

    We had upgraded our AVG server client to AVG 2011 (1191).  This knocked out TFS for most of the functionality we normally use.

    The strange thing is that check-in and check-out of existing files worked just fine.

    After uninstalling AVG - all went back to normal!

    We contacted AVG and they sent us a generic - how tro install AVG client on a server?  so much for reading our email :-)

    So if you are experiencing the same problem with the latest version and build of AVG - just uninstall AVG.

    Hope this will help someone else!
    ------------------------ Gary P.
    • Changed type Gary P_ Tuesday, January 11, 2011 6:24 PM Solution provided
    Thursday, January 06, 2011 5:42 PM

All replies

  • Hi Gary,

    Thanks for your sharing!

    Best Regards,


    Cathy Kong [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, January 07, 2011 9:14 AM
  • Okay - i have a fix for those of you with the same problem (besides removing AVG all together).

    We determined that the following steps needed to be taken:

    -    Uninstall AVG on the server containing Team Foundation Server
    -    Re-Install AVG without the following components:
    -    AVG Firewall
    -    AVG Personal E-mail Scanner
    -    AVG Online Shield
    -    AVG LinkScanner

    No changes needed to be made to AVG on any of the clients.

    This should do it!

    Gary


    ------------------------ Gary P.
    Friday, January 07, 2011 7:01 PM