none
Why Does <location allowOverride="false"> Disable Debugging?

    Question

  • Very simple, why does adding <location allowOverride="false"> to web.config disable development (localhost) debugging?

    Marc
    Tuesday, September 08, 2009 12:12 PM

All replies

  • Hi Marc,

    allowOverride specifies whether configuration settings can be overridden by configuration settings that are in Web.config files that are in child directories. When set it to false, it means that the web.config in subdirectories doesn't affect the application anymore.

    Is there any subdirectory web.config file in your application? Would you mind letting me know what the settings inside those file?


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, September 09, 2009 5:46 AM
    Moderator
  • Hongye,

    In the solution there is only one active web.config file.

    I had only added the parameter because I wanted a stablized environnment over the SDLC of the solution if others would be generated; there were several parameters added that I didn't want overriden; so I removed the parameter to overcome the debugging issue for the time being because there weren't others.  

    I understood the purpose, but don't understand why it impacts local debug unless the a special web.config is being generated for that purpose that isn't apparent and there is an conflict. The question is being asked to determine if it's a system defect.

    Marc
    Wednesday, September 09, 2009 10:31 AM
  • Hi Alaskan,

    I did a test on silverlight application in VS 2008. But failed to reproduce the debug issue by specifying <location allowOverride="false">.

    I created a new project with silverlight application project and web project.
    When I starts web project with debug, I can see IE process was loaded into debugger in the Debug / Windows / Processes window.
    The debug type is silverlight, which can be set in the Project Properties / Web page / Debuggers / Silverlight.
    In the Modules window, I can see the silverlight application and its symbol is loaded correctly.

    Since you have no other web.config files in subdirectories, I can't imagine what will affect after setting <location allowOverride="false">.
    Is it possible for you to create a simplified repro project to send it to me? My email is hongyes@microsoft.com.

    Thanks.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, September 10, 2009 7:26 AM
    Moderator
  • I am experiencing the same issue as Alaskan.  Is there a workaround/fix for this?

    Thursday, September 30, 2010 11:56 AM