none
How to registry asp.net 3.5 on IIS 5.1

    Question

  •  

    How to registry asp.net 3.5 on IIS 5.1? Or asp.net 3.5 is can not registry on Windows XP?

     

    I installed .net 3.5 on my server.But just .net 2.0 was registried on IIS and can not run the .net 3.5 base for web application.

     

    How can I fix this problem?

    Thursday, February 21, 2008 1:11 PM

Answers

  • If your server is Windows 2000 you cannot run .NET 3.5 because it is not supported but you can run .NET 3.5 in Windows XP by adding the references in the link I posted to your web.config.  If you are using VS2008 then VS2008 will add the references for you.  So check you web.config if the references in the link I posted are not there then add it.  That what developers do modify and use code as needed.  I hope this is clear.

    Friday, February 22, 2008 1:37 PM
    Moderator

All replies

  • If your server is Windows 2000 then you need Windows 2003 or XP to run your application, you know XP is a desktop operating system for development not deployment.  All you need to do is covered in the thread below.

     

    http://forums.iis.net/p/1133618/1860351.aspx

    Thursday, February 21, 2008 8:10 PM
    Moderator
  •  

    Do you mean .net 3.5 is not bear to registry in IIS? It's just registry .net 2.0 base to run 3.5 assemble component?

    But why i can not run .net 3.5 component on my IIS?(I installed .net 3.5 & 2.0)

    Friday, February 22, 2008 11:05 AM
  • If your server is Windows 2000 you cannot run .NET 3.5 because it is not supported but you can run .NET 3.5 in Windows XP by adding the references in the link I posted to your web.config.  If you are using VS2008 then VS2008 will add the references for you.  So check you web.config if the references in the link I posted are not there then add it.  That what developers do modify and use code as needed.  I hope this is clear.

    Friday, February 22, 2008 1:37 PM
    Moderator