none
Visual Basic 2012 to Visual Basic 2010

    Question

  • I am using the Microsoft Visual Basic 2012 Ultimate and my school has VB 2010 Professional. I was wondering is there anyway I can make my projects that I made in 2012 to run in 2010? 
    Monday, January 28, 2013 10:02 PM

Answers

  • You should not have to do anything special to get your VB solutions created in VS 2012 to open in VS 2010, as long as you target .NET Framework 4.0 or earlier. (I tested this here)

    VS 2010 cannot "see" or use .NET 4.5, so VS 2012 projects that target .NET 4.5 cannot be opened in VS 2010.

    Monday, January 28, 2013 10:12 PM
  • With your VB solution open in Visual Studio 2012,

    Project->(your project name) Properties...

    In the Application tab of the properties dialog, you'll see the Target Framework drop down list. Change the .NET Framework version there.

    Note 1: If your solution has multiple projects, the target framework must be changed in EACH project.

    Note 2: Once the change(s) are made, you MUST close the solution in VS, then reopen and rebuild it.

    • Marked as answer by Chubonga Friday, February 01, 2013 6:31 PM
    Thursday, January 31, 2013 10:57 PM

All replies

  • You should not have to do anything special to get your VB solutions created in VS 2012 to open in VS 2010, as long as you target .NET Framework 4.0 or earlier. (I tested this here)

    VS 2010 cannot "see" or use .NET 4.5, so VS 2012 projects that target .NET 4.5 cannot be opened in VS 2010.

    Monday, January 28, 2013 10:12 PM
  • Hi Chubonga,

    If possible, please install VS2010 SP1. I think you could get the detailed message from this MSDN document “Visual Studio 2012 Compatibility”, it shared us the more detailed information about which kind of apps(created in VS2012) we could open in VS2010 and others.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, January 30, 2013 7:32 AM
  • Hi, the solution of the project cannot be opened with an older version, but the project file yes. It worked for 2010 and 2011 (beta release candidate) so why it cannot work? :)
    Wednesday, January 30, 2013 12:59 PM
  • Hello, 3rr3.

    Please explain your situation more fully. I have no problems opening VS 2012 solutions in VS 2010 as long as the solutions do not use features/technologies unique to VS 2012/.NET 4.5.

    What project type is causing issues for you, and what .NET Framework version does it target?

    Wednesday, January 30, 2013 1:06 PM
  • When I tried (some times ago) to open a solution created with VS 2011 RC in VS 2010 it gave an error. I avoided that error simply opening the project file with 2010.
    Wednesday, January 30, 2013 5:09 PM
  • Have you tried with VS 2012 RTM? The RC and RTM releases are inherently incompatible, so your experience using VS 2012 RTM should be different as I told the OP:

    "You should not have to do anything special to get your VB solutions created in VS 2012 to open in VS 2010, as long as you target .NET Framework 4.0 or earlier. (I tested this here)"

    Wednesday, January 30, 2013 5:42 PM
  • I used the 2011 RC (that VS launched with the Developer Preview).
    Thursday, January 31, 2013 9:44 AM
  • As I said before. Try it with the RTM VS 2012.
    Thursday, January 31, 2013 2:41 PM
  • so is there a setting that i could change my .NET framework to 4.0 instead of 4.5 then?

    Thursday, January 31, 2013 10:45 PM
  • With your VB solution open in Visual Studio 2012,

    Project->(your project name) Properties...

    In the Application tab of the properties dialog, you'll see the Target Framework drop down list. Change the .NET Framework version there.

    Note 1: If your solution has multiple projects, the target framework must be changed in EACH project.

    Note 2: Once the change(s) are made, you MUST close the solution in VS, then reopen and rebuild it.

    • Marked as answer by Chubonga Friday, February 01, 2013 6:31 PM
    Thursday, January 31, 2013 10:57 PM
  • That works! Thanks for your help!

    Friday, February 01, 2013 6:31 PM