none
Missing msvcr100d.dll

    Question

  • Hi,

    I recently upgraded from Windows XP to Windows 7.

    I'm happy that i've changed to Windows 7, but the problem is that msvcr100d.dll is missing when i try to run an Warcraft .exe file, this had never happened to me on Windows XP. I also have been trying to search around the forums, but nothing helped or i couldn't understand.

    Is there a way to download msvcr100d.dll?

    Thanks,
    Phoenicks.

     

    *I'm not sure if this is in the correct forum category.

     

     

    Friday, April 08, 2011 4:12 AM

Answers

All replies

  • Hello,

    try installing Visual C++ 2010 Redistributable which install all dll you need.

    After that the error may show again. So download this file(I've just uploaded it).


    Nicolò Zilio
    Personal blog: http://nicolozilio.wordpress.com/(With technical articles)
    Personal Web site: http://nicolozilio.altervista.org/
    Friday, April 08, 2011 5:09 AM
  • Thanks for getting back to me.

    When i installed the file this popped up;

     

    Please resolve the following:

    This setup program requires an IA64 platform. It cannot be installed on this platform

     

    Does the IA64 mean a 64-bit, because i'm on 32-bit.

    Thanks,

    Phoenicks

    Friday, April 08, 2011 5:13 AM
  • Oh, sorry... I've post the IA64 link...

    This is the correct link: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=C32F406A-F8FC-4164-B6EB-5328B8578F03


    Nicolò Zilio
    Personal blog: http://nicolozilio.wordpress.com/(With technical articles)
    Personal Web site: http://nicolozilio.altervista.org/
    • Marked as answer by Phoenicks Friday, April 08, 2011 12:01 PM
    Friday, April 08, 2011 11:37 AM
  • Thanks for the other link!

    Before i mark as answer, what do i do with the other link you gave to me, do i have to uninstall or anything?

     

    Thanks,
    Phoenicks

    Friday, April 08, 2011 11:43 AM
  • Before i mark as answer, what do i do with the other link you gave to me, do i have to uninstall or anything?
    There is nothing for uninstall since you can not install the VC2010 IA64 redistributalbe at a x86 target.
    Friday, April 08, 2011 11:54 AM
  • Interesting, nobody mentioned that msvcr100d.dll is the debug version of the library, and any programs that depend on it are most likely big and slow because they are not optimised. Also redistributing the debug versions of the runtime in any form is against the eula.

    A released application shouldn't depend on the debug version of the CRT, if you do have this situation then they have done something very stupid. So you should contact the people who releasd it, let them know and get them to give you the proper release version of the application.


    Any samples given are not meant to have error checking or show best practices. They are meant to just illustrate a point. I may also give inefficient code or introduce some problems to discourage copy/paste coding. This is because the major point of my posts is to aid in the learning process.
    Visit my (not very good) blog at
    http://ccprogramming.wordpress.com/
    Friday, April 08, 2011 1:55 PM
  • Interesting, nobody mentioned that msvcr100d.dll is the debug version of the library, and any programs that depend on it are most likely big and slow because they are not optimised. Also redistributing the debug versions of the runtime in any form is against the eula.

    I'm not 100% sure, but I have the VC2010 redist installed on a XP system with no VC2010 installed, and I have a msvcr100d.dll in the windows system directory. Therefore I guess this DLL is in the redist package.

    I agree with you that distributing debug versions is strange....

    Sunday, April 10, 2011 5:34 PM
  • On a fresh install of Windows 7, with only the VC10 redist installed there is no msvcr100d.dll installed. I also looked inside the installer package and there is no sign of it. So it isn't in the redist itself.
    Any samples given are not meant to have error checking or show best practices. They are meant to just illustrate a point. I may also give inefficient code or introduce some problems to discourage copy/paste coding. This is because the major point of my posts is to aid in the learning process.
    Visit my (not very good) blog at
    http://ccprogramming.wordpress.com/
    Sunday, April 10, 2011 9:36 PM
  • I install Visual C++ 2010 Redistributable but this can't help, the problem is still there.

    I have Microsoft Windows 7 professional. When I am starting Windows it gives the same messege(ok only). But after that I am working. No problem is there. This problem started about a month ago. I need a solution now. Can anyone help me about it.

    Thanks

    Asis Panja

    panjaasis@hotmail.com

    Kolkata, West Bengal, India

    Wednesday, April 02, 2014 8:13 AM
  • At all the msvcr100d.dll is the debug version of the VC2010 runtime library. The release version msvcr100.dll is in the VC2010 redistributable package. The msvcr100d.dll is not in the VC2010 redist.

    The debug version of the DLL is not for redistribution. you should contact the manufacturer of the software that causes this problem. I'm pretty sure you installed a programm and this particular probramm is a debug build.


    Best regards

    Bordon

    Note: Posted code pieces may not have a good programming style and may not perfect. It is also possible that they do not work in all situations. Code pieces are only indended to explain something particualar.

    Wednesday, April 02, 2014 8:58 AM