none
Debug File (*.pdb) is not generating

    Question

  • Hello,

    I just upgrade my VS 2003 project (windows application) to VS 2005 (.NET 2.0) Framework, Upgradation works perfect for me, with few changes in code. I does all that and when I compile my application all works fine.

     

    However, when I try to debug the application Debug doesn't start as PDB files are not generated. Initially it says that I need to disable "Warn if not User code for launch" to enable debugging. I found a thread in this forum and follow its step to do that, also I change the Configuration to "Debug" for my main application and two class library project in my solution. In Advance option I have "Full" Debug General Information enable.

     

    Not sure what goes wrong..

    Can anyone please help..

    Sunday, September 16, 2007 3:25 AM

Answers

  •  

    Vikasumit,

     

    The dialog you see is informing you that a component is being built with no symbols or with optimizations enabled. Check every project's properties in the solution and make sure you are generating "full" debug info and optimization are disabled. Both these are on the Build pane with the former under the Advanced button. The debugging experience is going to be better as well when you have optimizations disabled and full debug info being generated.

    Hope that helps.

     

    Azeem Khan

    VS Debugger.

     

    Monday, September 17, 2007 9:52 PM

All replies

  •  

    This is a project setting - moving to C#.  If you are using VB, please move the thread appropriately,

     

    John

    Sunday, September 16, 2007 4:38 PM
  •  

    Vikasumit,

     

    The dialog you see is informing you that a component is being built with no symbols or with optimizations enabled. Check every project's properties in the solution and make sure you are generating "full" debug info and optimization are disabled. Both these are on the Build pane with the former under the Advanced button. The debugging experience is going to be better as well when you have optimizations disabled and full debug info being generated.

    Hope that helps.

     

    Azeem Khan

    VS Debugger.

     

    Monday, September 17, 2007 9:52 PM
  •  

    how do I move it to other forurm? , I am using VB
    Tuesday, September 18, 2007 3:50 PM
  • I have already ensure that its "Full" debug, and optimization is disabled as well Sad

    Tuesday, September 18, 2007 3:52 PM
  • Well I just refollow your advice and check the settings, and to my surprise I found it too be "none" rather than full.

    So problem solved...

     

    BUT...

     

    i close developer studio, reopen it and settings are again "none"

     

    Though I guess some file is cached, and might solved.. just in case anyone have something to say..

     

    Thanks and sorry Azeem for my previous post...

     

    Tuesday, September 18, 2007 4:00 PM
  • Sumit,

     

    The setting is a project setting and should be saved when you do a File -> Exit. You can try to do a File -> Save All before exiting and see if that helps. If not ask on an appropriate forum i.e. VB if this is a VB project.

     

    Azeem Khan

    VS Debugger.

    Tuesday, September 18, 2007 8:29 PM
  • I have had a similar problem. I configured all the relevant project settings but alas the problem still persists, but only for one project.

    The project is fairly big and has recently been migrated from 1.1 to 2.0 and now 3.0. Somewhere during the process the Project files have been modified and no amount of setting Project Configuration files has helped resolve my issue. However an interesting observation.

    If I build the solution in the IDE it does not generate the PDB file for one of the projects. If I build the project (NOTE: Not the solution) through the command line utility MSBUILD I get the rogue pdb file being generated. Come forth silent rogue!
    MCTS. Web, Win, Distributed
    • Proposed as answer by Beehive2 Wednesday, March 13, 2013 2:22 PM
    Thursday, May 07, 2009 3:55 PM
  • MSBUILD was the right thing to do! I had compiled the XmlNotePad solution with (some?) PDB files created, but some breakpoints being ignored. Executing the MSBUILD command inside the XmlNotepad\XmlDiff\src\ directory made my day. Thanks to Jonathan Sawyer for your valuable hint!

    Developer @ HF Instruments GmbH

    Wednesday, March 13, 2013 2:38 PM