none
VS Express 2013 for Web - Unable to connect to the configured development web server - suspect WebDev.WebServer.EXE is missing

    Question

  • TL;DR - is there a way to restore the file C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\WebDev.WebServer.EXE ?

    -----

    When I try to run any project (Ctrl + F5) in Visual Studio Express 3013 for Web I get an "Unable to connect to the configured development web server" error.

    (Just recently a new error appeared when I used Ctrl+F5: "mscorlib: the wait completed due to an abandoned mutex." an IIS error. Not sure if it's related?)

    I've tried just about every fix I could figure out, including repairing and re-installing both .NET 4.5 and Visual Studio Express 3013 for Web, and the NetFxRepairTool.exe.

    The problem I think I have is that WebDev.WebServer.EXE is not where it should be.

    Not here: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\WebDev.WebServer.EXE or anywhere under the Framework folder.

    I'm running Windows 7 Home Premium SP1 and appear to meet the system requirements. 

    Topic: "Windows7 (64 bit)/VS 2010 (64 bit) - Unable to connect to the ASP.Net Development Web Server" - cannot complete this fix since WebDev.WebServer.EXE is not on the recommended path (also since the VS interface seems to have changed). This is the only indication I have that the file is missing.

    My hosts file is fine, and internet connection sharing is off.

    Windows Firewall doesn't seem to be the problem.

    I did have VS 2008 express installed, I hear there's problems with uninstalling it? Would that interfere with installing a new version of VS?

    Is WebDev.WebServer.EXE located somewhere else in for .Net 4.0 / 4.5.1, or is that affected by the version of Visual Studio?

    Is there a way to restore WebDev.WebServer.EXE?

    I'd really appreciate some help. Do I have to do a fresh install of everything? Because I would rather not.

    Saturday, February 01, 2014 1:26 AM

Answers

All replies