none
System.Security.SecurityException: Requested registry access is not allowed.

    Question

  • Hi all, I know this is a pretty common problem and there are lots of hits on google for the problem but I have spent the last few days goin through all these hits and nothing seems to work, the server is new and it is running Windows Server 2003, IIS 6 and .Net Framework 1.1 any help, advise or anything would really be appreciated.

    Thanks in advance

    Tim
    Tuesday, July 17, 2007 1:50 PM

Answers

  • Hi, Create an application pool on IIS for your application and set the Identity of that new app pool to "Local System". Then you must change the pool of your web application to the new one you created.. So you will make your application running with local system credentials and you will be able to access to the registry.
    Wednesday, November 14, 2007 1:24 PM
  • Just to expand on "nynz" answer, here is the solution completely spelled out:

    1. Open up the IIS Manager 
    2. Expand your computer in the connections section on the left
    3. Open up Application Pools
    4. Select the Application pool you are using for your application that is experiencing this problem
    5. Right click on your application pool and select "Advanced Settings..."
    6. Scroll down to the "Process Model" section
    7. Locate "Identity" (first in that section) and click on the "..." that appears to the far right of the value for the "Identity" item, it currently may say "ApplicationPoolIdentity"
    8. After clicking on the "..." click on the drop box under the "Built-in account" radio button
    9. Select "LocalSystem"
    10. Click OK
    11. Click OK
    12. Let the app pool restart (may not be necessary, but just in case)
    13. Restart your app (may not be necessary, but just in case)

    Hopefully this works for you. It worked for me.

    Thank you nynz for your solution.

    Wednesday, December 08, 2010 5:24 PM

All replies

  • Hi, Create an application pool on IIS for your application and set the Identity of that new app pool to "Local System". Then you must change the pool of your web application to the new one you created.. So you will make your application running with local system credentials and you will be able to access to the registry.
    Wednesday, November 14, 2007 1:24 PM
  • Just to expand on "nynz" answer, here is the solution completely spelled out:

    1. Open up the IIS Manager 
    2. Expand your computer in the connections section on the left
    3. Open up Application Pools
    4. Select the Application pool you are using for your application that is experiencing this problem
    5. Right click on your application pool and select "Advanced Settings..."
    6. Scroll down to the "Process Model" section
    7. Locate "Identity" (first in that section) and click on the "..." that appears to the far right of the value for the "Identity" item, it currently may say "ApplicationPoolIdentity"
    8. After clicking on the "..." click on the drop box under the "Built-in account" radio button
    9. Select "LocalSystem"
    10. Click OK
    11. Click OK
    12. Let the app pool restart (may not be necessary, but just in case)
    13. Restart your app (may not be necessary, but just in case)

    Hopefully this works for you. It worked for me.

    Thank you nynz for your solution.

    Wednesday, December 08, 2010 5:24 PM
  • In some cases, system shows this error because it is unable to find the data source.

    try to find the data source of the grid and check whether it is functional or not.

     

    I got similar problem, after diagnosing it for hours, I found that the SP which I was calling to get the data was not present in the database.

    As soon as I executed that SP my program worked like a charm.

     

    Hope it helps :)

    Monday, July 11, 2011 2:30 PM