none
VS2012 missing SQL Server Explorer

    Question

  • I have installed VS 2012 Ultimate RC. I can't find SQL Server Explorer in the view Menu - Am I missing something in order to do that ?

    /PAul S


    Paul S

    Friday, July 13, 2012 1:44 PM

Answers

  • Hi

    I also tried that without luck. So now I have uninstalled VS and installed it again and now it works - and SQL Server Data Tools also works!

    My ony suggestion as to why it works is that originally I installed VS 2012 first and then SQL Server 2012. So now when VS is installed after SQL Server it works.

    Thanks for your assistence, Vicky


    Paul S

    Wednesday, July 18, 2012 8:28 AM

All replies

  • Are you referring to SQL Server Object Explorer?

    It's there in my installation. What settings did you choose when VS 2012 ran first?

    I'm on General Development settings.

    Friday, July 13, 2012 2:02 PM
  • I started out with the C# settings - now I have also tried the General settings without luck. I have then installed Sql Server 2012. It has a SQL Ser Data Tools - a VS Shell. When  I run this I can create a new project for an existing DB but it only creates an empty solution - no import of database objects??

    My impression was that Data Tools shipped with VS 2012 after seeing it on TechEd 2012.


    Paul S

    Sunday, July 15, 2012 10:30 AM
  • Hello Paul,

    Please try to use the shortcut (Ctrl+Alt+S) to get the Server Explorer. If you still can't get it, please repair your VS2012 Ultimate to see if it helps you.

    In addition, we are no longer support to create database projects in VS2012, instead we can create SSDT projects. And when you open a .dbproj created in VS2010, it will be upgraded to .sqlproj automatically when you open it in VS2012.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Monday, July 16, 2012 2:18 AM
    Moderator
  • Hi

    I get the Server Explorer by using the shortcut - also tried to do a repair but still I don't get the SQL Server object explorer.

    As I said earlier I also tried the SQL Server Data Tools but it does not import database meta data.

    /Paul S


    Paul S

    Tuesday, July 17, 2012 8:50 PM
  • Hi Paul,

    For your current scenario, I think maybe you customized the VS settings so that the Server Explorer does not show in the View Menu. Please try to restore VS to the default settings by running the Devenv.exe /ResetSettings command.

    I hope it can help you. Please post back if you still get this issue.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, July 18, 2012 6:01 AM
    Moderator
  • Hi

    I also tried that without luck. So now I have uninstalled VS and installed it again and now it works - and SQL Server Data Tools also works!

    My ony suggestion as to why it works is that originally I installed VS 2012 first and then SQL Server 2012. So now when VS is installed after SQL Server it works.

    Thanks for your assistence, Vicky


    Paul S

    Wednesday, July 18, 2012 8:28 AM