none
VS2010 -- setup files failed verification.

    Question

  • I've been trying to install VS2010. Some of the initial components were installed, but when it trys to install Visaul Studios 2010 Profession, it fails. The error log shows that the vs_setup.msi file was not verified. I download a .img file from Dreamspark, and have tried mounting it on a virtual drive and burning it onto a disc, and I keep getting the same error. Any ideas?

    Tuesday, April 13, 2010 5:12 AM

Answers

  • Hi Vxsery,

    Thank you for your post.

    Some clarification with you:
    What's your OS?

    Firstly, please try some download manager software to download VS2010 again to eliminate some possible cause of corrupted installer media.

    Then please help me to extract the IMG image, to your local computer, by using the 3rd-party tools and directly run the installation from the extracted file on the harddrive/harddisk.

    If it doesn't work, could you please follow the following steps to collect the log files?

    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install VS2010
      (For Vista or later OS, the installer must be run with administrator privileges - Right-click the installer >> "Run as Administrator")
    - Collect the logs from "%temp%" folder
       Collect tool: http://www.microsoft.com/downloads/details.aspx?FamilyID=e0da314f-6216-4a18-bc6b-7d29cf83af20&displaylang=en
    - Send vslogs.cab file to me (v-yicche@microsoft.com)
      Note: Please attach the link of this post in the mail.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Tuesday, April 20, 2010 1:58 AM
    Wednesday, April 14, 2010 11:41 AM
  • Hello

    I solved the installing Prerequisites problem removing SilverLight3 and Installing SilverLight 4 RC.

    Then I install VS2010 from websetup.

    I don't know why, just work

    • Marked as answer by YiChun Chen Tuesday, April 20, 2010 2:03 AM
    Wednesday, April 14, 2010 8:58 PM
  • My problem was resolved after I downloaded a new iso file. It has been proven that the old iso was corrupted after copying from USB key.

     

    Thanks anyway

    Chester.

    • Marked as answer by YiChun Chen Tuesday, April 20, 2010 2:03 AM
    Wednesday, April 14, 2010 9:07 PM
  • I got the same error message but I found that if I used the web installer, that it insalled without any errors. I hope this helps because it sure saved me a lot of time in troubleshooting.

    Robert

     

    • Marked as answer by YiChun Chen Tuesday, April 20, 2010 2:03 AM
    Thursday, April 15, 2010 4:18 AM

All replies

  • I have the same problem,need assistance
    Tuesday, April 13, 2010 1:02 PM
  • Me too, same problem

    I downloaded it from dreamspark and didn't work in windows 7 ultimate 64bits ¬¬

    Tuesday, April 13, 2010 6:42 PM
  • I am getting the same problem in windows 7 64 bit: I downloaded the release from MSDN and its not RC but still saud its RC?????

    [04/12/10,15:24:01] Microsoft Visual Studio 2010 Ultimate RC - ENU: [2] UpdateFileFetcherFromMsi: Warning: Missing fwlink entry for cabinet: #QFE.cab
    [04/12/10,19:00:16] VC 9.0 Runtime (x86): [2] CMsiComponent::Install() expects the setup file for VC 9.0 Runtime (x86), but the file failed verification.
    [04/12/10,19:00:16] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467259.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates VC 9.0 Runtime (x86) is not installed.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates VC 10.0 Runtime (x86) was not attempted to be installed.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates VC 10.0 Runtime (x64) was not attempted to be installed.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates Microsoft .NET Framework 4 was not attempted to be installed.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 64bit Prerequisites (x64) was not attempted to be installed.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates Microsoft Visual F# 2.0 Runtime was not attempted to be installed.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates TFS Object Model (x64) was not attempted to be installed.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates .NET Framework 4 Multi-Targeting Pack was not attempted to be installed.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Ultimate - ENU was not attempted to be installed.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 - Visual Studio 2010 Tools was not attempted to be installed.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 was not attempted to be installed.
    [04/12/10,19:00:16] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Tools for Office Runtime (x64) was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft Office Developer Tools (x64) was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Dotfuscator Software Services - Community Edition was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Crystal Reports templates for Visual Studio 2010 was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 SP2 (x86) ENU was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 SP2 (x64) ENU was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Visual Studio 2010 Tools for SQL Server Compact 3.5 SP2 ENU was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Runtime v1.0 (x64) ENU was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft Sync Services for ADO.NET v2.0 (x64) ENU was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Services v1.0 (x64) ENU was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework SDK v1.0 (x64) ENU was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates VC 10.0 Designtime (x64) was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Performance Collection Tools (x64) was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 IntelliTrace (x64) was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft SQL Publishing Wizard 1.4 was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft SQL Server System CLR Types was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft SQL Server System CLR Types (x64) was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Management Objects was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Management Objects (x64) was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Framework was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Project was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Transact-SQL Language Service was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft SharePoint Developer Tools was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 ADO.NET Entity Framework Tools was not attempted to be installed.
    [04/12/10,19:00:17] VS70pgui: [2] DepCheck indicates Microsoft Help Viewer 1.0 x64 was not attempted to be installed.
    [04/12/10,19:01:25] VC 9.0 Runtime (x86): [2] CMsiComponent::Install() expects the setup file for VC 9.0 Runtime (x86), but the file failed verification.
    [04/12/10,19:01:25] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467259.

    Tuesday, April 13, 2010 7:30 PM
  • Hi Vxsery,

    Thank you for your post.

    Some clarification with you:
    What's your OS?

    Firstly, please try some download manager software to download VS2010 again to eliminate some possible cause of corrupted installer media.

    Then please help me to extract the IMG image, to your local computer, by using the 3rd-party tools and directly run the installation from the extracted file on the harddrive/harddisk.

    If it doesn't work, could you please follow the following steps to collect the log files?

    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install VS2010
      (For Vista or later OS, the installer must be run with administrator privileges - Right-click the installer >> "Run as Administrator")
    - Collect the logs from "%temp%" folder
       Collect tool: http://www.microsoft.com/downloads/details.aspx?FamilyID=e0da314f-6216-4a18-bc6b-7d29cf83af20&displaylang=en
    - Send vslogs.cab file to me (v-yicche@microsoft.com)
      Note: Please attach the link of this post in the mail.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Tuesday, April 20, 2010 1:58 AM
    Wednesday, April 14, 2010 11:41 AM
  • I have the similar problem. While I was installing Microsoft Visual Studio 2010 Ultimate on windows xp sp3 I got the errors:

    [04/14/10,09:51:11] Microsoft Visual Studio 2010 Ultimate - ENU: [2] CRootComponent::Install(): Cannot install; setup files failed verification.
    [04/14/10,09:51:11] Microsoft Visual Studio 2010 Ultimate - ENU: [2] ERROR_INSTALL_PACKAGE_INVALID returned in CRootComponent::Install; the following file is invalid: e:\vs_setup.msi

    When I tried to go to my msdn account to download another one, click Visual Studio 2010, I got this:

    "Your search did not match any products."

    Can you help me out? 

    Another question, Can I install Microsoft Visual Studio 2010 Ultimate to two machince?

    Chester

    Wednesday, April 14, 2010 4:48 PM
  • Since You are trying to install VS 2010 RTM or RC on Windows 7 64 bit edition , please try the following :

    1. Manually Install the prerequisites.When You already have them installed ,It fails...so rollback and try.

    2. Try installing on Virtual Machine (Preferably Win xp as it requires lesser memory and runs good)

    3 Shift/Downgrade to 32 bit OS

    • Proposed as answer by udayonze Wednesday, April 14, 2010 7:35 PM
    Wednesday, April 14, 2010 7:35 PM
  • Try refreshing your browser...use inprivate Browsing.I had the same problem "Your search did not match any products."

    After a refresh , everythingwas fine.

    • Proposed as answer by udayonze Wednesday, April 14, 2010 7:50 PM
    Wednesday, April 14, 2010 7:48 PM
  • Hello

    I solved the installing Prerequisites problem removing SilverLight3 and Installing SilverLight 4 RC.

    Then I install VS2010 from websetup.

    I don't know why, just work

    • Marked as answer by YiChun Chen Tuesday, April 20, 2010 2:03 AM
    Wednesday, April 14, 2010 8:58 PM
  • My problem was resolved after I downloaded a new iso file. It has been proven that the old iso was corrupted after copying from USB key.

     

    Thanks anyway

    Chester.

    • Marked as answer by YiChun Chen Tuesday, April 20, 2010 2:03 AM
    Wednesday, April 14, 2010 9:07 PM
  • I got the same error message but I found that if I used the web installer, that it insalled without any errors. I hope this helps because it sure saved me a lot of time in troubleshooting.

    Robert

     

    • Marked as answer by YiChun Chen Tuesday, April 20, 2010 2:03 AM
    Thursday, April 15, 2010 4:18 AM
  • Hi all,

    Thank you for your post.

    Could you please help me to open a new thread in this forum so that we can focus on your own scenario and issue? This will also benefit other community members.

    Thank you for your help.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, April 15, 2010 4:25 AM
  • Now,I solved this problem.When I installed the trial edition,it was failed,then I downloaded the MSDN edition and installed it,it was succeed!
    Wednesday, April 21, 2010 12:26 PM
  • I've been trying to install VS2010. Some of the initial components were installed, but when it trys to install Visaul Studios 2010 Profession, it fails. The error log shows that the vs_setup.msi file was not verified. I download a .img file from Dreamspark, and have tried mounting it on a virtual drive and burning it onto a disc, and I keep getting the same error. Any ideas?


    Try using the web Installer...I had a similar issue on my Win7 x64 and now after using the web installer (though it took long time)

    Finally it was sucessful

    • Proposed as answer by udayonze Thursday, April 22, 2010 5:31 PM
    Thursday, April 22, 2010 5:31 PM
  • hello ,i have the same problem , just only install VS2010 from websetup? it will take me a long time.  it's terrible for the aera internet access speed is slow. Find the reason is best.

     May be Win7 + vs2008 + vs2010 cause this?

    i guess..

    Friday, September 03, 2010 9:13 AM
  • Hello:

    When I install Visual Studio 2010 professional it installs some of the products but when it comes to install Visual Studio 2010 Professorial it says that the file vs_setup.msi is invalid here is the log file:

    [02/03/11,12:56:03] Microsoft Visual Studio 2010 Professional - ENU: [2] CRootComponent::Install(): Cannot install; setup files failed verification.
    [02/03/11,12:56:03] Microsoft Visual Studio 2010 Professional - ENU: [2] ERROR_INSTALL_PACKAGE_INVALID returned in CRootComponent::Install; the following file is invalid: f:\stuff\downloads\vs2010\vs_setup.msi
    [02/03/11,12:56:06] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Professional - ENU is not installed.
    [02/03/11,12:56:06] VS70pgui: [2] DepCheck indicates Microsoft Web Deployment Tool (x64) was not attempted to be installed.
    [02/03/11,12:56:06] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 - Visual Studio 2010 Tools was not attempted to be installed.
    [02/03/11,12:56:07] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 was not attempted to be installed.
    [02/03/11,12:56:07] VS70pgui: [2] DepCheck indicates Microsoft Silverlight 3 SDK was not attempted to be installed.
    [02/03/11,12:56:07] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Tools for Office Runtime (x64) was not attempted to be installed.
    [02/03/11,12:56:07] VS70pgui: [2] DepCheck indicates Microsoft Office Developer Tools (x64) was not attempted to be installed.
    [02/03/11,12:56:07] VS70pgui: [2] DepCheck indicates Dotfuscator Software Services - Community Edition was not attempted to be installed.
    [02/03/11,12:56:07] VS70pgui: [2] DepCheck indicates Crystal Reports templates for Visual Studio 2010 was not attempted to be installed.
    [02/03/11,12:56:08] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 SP2 (x86) ENU was not attempted to be installed.
    [02/03/11,12:56:08] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 SP2 (x64) ENU was not attempted to be installed.
    [02/03/11,12:56:08] VS70pgui: [2] DepCheck indicates Visual Studio 2010 Tools for SQL Server Compact 3.5 SP2 ENU was not attempted to be installed.
    [02/03/11,12:56:08] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Runtime v1.0 (x64) ENU was not attempted to be installed.
    [02/03/11,12:56:08] VS70pgui: [2] DepCheck indicates Microsoft Sync Services for ADO.NET v2.0 (x64) ENU was not attempted to be installed.
    [02/03/11,12:56:08] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Services v1.0 (x64) ENU was not attempted to be installed.
    [02/03/11,12:56:09] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework SDK v1.0 (x64) ENU was not attempted to be installed.
    [02/03/11,12:56:09] VS70pgui: [2] DepCheck indicates VC 10.0 Designtime (x64) was not attempted to be installed.
    [02/03/11,12:56:09] VS70pgui: [2] DepCheck indicates Microsoft SQL Publishing Wizard 1.4 was not attempted to be installed.
    [02/03/11,12:56:09] VS70pgui: [2] DepCheck indicates Microsoft SQL Server System CLR Types was not attempted to be installed.
    [02/03/11,12:56:09] VS70pgui: [2] DepCheck indicates Microsoft SQL Server System CLR Types (x64) was not attempted to be installed.
    [02/03/11,12:56:09] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Management Objects was not attempted to be installed.
    [02/03/11,12:56:10] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Management Objects (x64) was not attempted to be installed.
    [02/03/11,12:56:10] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 Express Service Pack 1 (x64) was not attempted to be installed.
    [02/03/11,12:56:10] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Framework was not attempted to be installed.
    [02/03/11,12:56:10] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Project was not attempted to be installed.
    [02/03/11,12:56:10] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Transact-SQL Language Service was not attempted to be installed.
    [02/03/11,12:56:10] VS70pgui: [2] DepCheck indicates Microsoft SharePoint Developer Tools was not attempted to be installed.
    [02/03/11,12:56:11] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 ADO.NET Entity Framework Tools was not attempted to be installed.
    [02/03/11,12:56:11] VS70pgui: [2] DepCheck indicates Microsoft Help Viewer 1.0 x64 was not attempted to be installed.
    [02/03/11,13:04:24] Microsoft Visual Studio 2010 Professional - ENU: [2] CRootComponent::Install(): Cannot install; setup files failed verification.
    [02/03/11,13:04:24] Microsoft Visual Studio 2010 Professional - ENU: [2] ERROR_INSTALL_PACKAGE_INVALID returned in CRootComponent::Install; the following file is invalid: f:\stuff\downloads\vs2010\vs_setup.msi
    [02/03/11,13:04:26] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Professional - ENU is not installed.
    [02/03/11,13:04:26] VS70pgui: [2] DepCheck indicates Microsoft Web Deployment Tool (x64) was not attempted to be installed.
    [02/03/11,13:04:27] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 - Visual Studio 2010 Tools was not attempted to be installed.
    [02/03/11,13:04:27] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 was not attempted to be installed.
    [02/03/11,13:04:27] VS70pgui: [2] DepCheck indicates Microsoft Silverlight 3 SDK was not attempted to be installed.
    [02/03/11,13:04:27] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Tools for Office Runtime (x64) was not attempted to be installed.
    [02/03/11,13:04:27] VS70pgui: [2] DepCheck indicates Microsoft Office Developer Tools (x64) was not attempted to be installed.
    [02/03/11,13:04:27] VS70pgui: [2] DepCheck indicates Dotfuscator Software Services - Community Edition was not attempted to be installed.
    [02/03/11,13:04:28] VS70pgui: [2] DepCheck indicates Crystal Reports templates for Visual Studio 2010 was not attempted to be installed.
    [02/03/11,13:04:28] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 SP2 (x86) ENU was not attempted to be installed.
    [02/03/11,13:04:28] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 SP2 (x64) ENU was not attempted to be installed.
    [02/03/11,13:04:28] VS70pgui: [2] DepCheck indicates Visual Studio 2010 Tools for SQL Server Compact 3.5 SP2 ENU was not attempted to be installed.
    [02/03/11,13:04:28] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Runtime v1.0 (x64) ENU was not attempted to be installed.
    [02/03/11,13:04:28] VS70pgui: [2] DepCheck indicates Microsoft Sync Services for ADO.NET v2.0 (x64) ENU was not attempted to be installed.
    [02/03/11,13:04:28] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Services v1.0 (x64) ENU was not attempted to be installed.
    [02/03/11,13:04:29] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework SDK v1.0 (x64) ENU was not attempted to be installed.
    [02/03/11,13:04:29] VS70pgui: [2] DepCheck indicates VC 10.0 Designtime (x64) was not attempted to be installed.
    [02/03/11,13:04:29] VS70pgui: [2] DepCheck indicates Microsoft SQL Publishing Wizard 1.4 was not attempted to be installed.
    [02/03/11,13:04:29] VS70pgui: [2] DepCheck indicates Microsoft SQL Server System CLR Types was not attempted to be installed.
    [02/03/11,13:04:29] VS70pgui: [2] DepCheck indicates Microsoft SQL Server System CLR Types (x64) was not attempted to be installed.
    [02/03/11,13:04:29] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Management Objects was not attempted to be installed.
    [02/03/11,13:04:29] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Management Objects (x64) was not attempted to be installed.
    [02/03/11,13:04:30] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 Express Service Pack 1 (x64) was not attempted to be installed.
    [02/03/11,13:04:30] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Framework was not attempted to be installed.
    [02/03/11,13:04:30] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Project was not attempted to be installed.
    [02/03/11,13:04:30] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Transact-SQL Language Service was not attempted to be installed.
    [02/03/11,13:04:30] VS70pgui: [2] DepCheck indicates Microsoft SharePoint Developer Tools was not attempted to be installed.
    [02/03/11,13:04:30] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 ADO.NET Entity Framework Tools was not attempted to be installed. 

    [02/03/11,13:04:30] VS70pgui: [2] DepCheck indicates Microsoft Help Viewer 1.0 x64 was not attempted to be installed.

    I run it as administrator but it gives me the same thing I have windows 7 Ultimate 64 bit.

    I downloaded the .Net 4   but nothing happens.

    I downloaded the Visual Studio 2010 Professional from Dreamspark

    many thanks


    Bye Faisal
    Thursday, February 03, 2011 11:10 AM
  • Also this error.

     

    win7 64 + SQL2008 + VS2010

    But I can't send email to you.

    the vslogs address:http://www.xuey.net/Docs/vslogs.cab

    please help me.

    Thanks.

    Monday, July 18, 2011 10:20 AM
  • To Yichun Chen

    I also have the same problem.  In my case I was trying to install Visual Web Developer 2010 Express from the ISO file that I downloaded from Microsoft.  I was attempting this on a Windows 2003 Standard Server that I have.  I only chose that platform because I did not want to put too much on my main workstation.

    Here are the first two lines from the error file dd_install_vns_xcor_100.txt

    [09/08/11,12:30:56] VC 10.0 Runtime (x86): [2] CMsiComponent::Install() expects the setup file for VC 10.0 Runtime (x86), but the file failed verification.
    [09/08/11,12:30:59] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467259.

    I have been reading the other posts, so I am going to attempt a web install to see if this works, but this is still strange.  May I send you the vslogs.cab file if it still bombs?

    Friday, September 09, 2011 12:15 PM