none
Get latest (even with force) won't remove deleted files from my source control explorer

    Question

  • I have a few files showing up in my source control explorer with a latest value of No.
    I can right click, select get specific version, check the overwrite and force get options, click get, and I get:
    Source Control Explorer
    All files are up to date
    etc .....

    View history shows the latest change was "delete".

    How can I get these files out of my source control explorer view?

    TIA

    VS 2005 8.0.50727.867
    Vista 64 Ultimate
    Friday, November 21, 2008 6:47 PM

Answers

  • The Problem got solved automatically, after a while i just removed the workspace , created a new workspace then tried to Download the source, and it was working,(which was not working earlier)... I think there is some bug here in VSTS 2008 
    The Chosen One
    • Proposed as answer by Manasvi Sareen Thursday, November 27, 2008 7:33 AM
    • Proposed as answer by Manasvi Sareen Thursday, November 27, 2008 7:33 AM
    • Marked as answer by Hua Chen Friday, November 28, 2008 8:02 AM
    Thursday, November 27, 2008 7:33 AM

All replies

  • I am facing the same problem, How to mark the files in TFS Client that files have been removed from the local machine

    The Chosen One
    Monday, November 24, 2008 7:17 AM
  • Hello
     

    In Source Control Explorer, the deleted items will be grayed. If you don't want to view it, you can open Visual Studio and go to Tools->Options->Source Control->Visual Studio Team Foundation and uncheck "Show deleted items in the Source Control Explorer".


    Please mark the replies as answers if they help and unmark them if they provide no help.
    Monday, November 24, 2008 8:06 AM
  • Well It is already unchecked,

    Let me go over my problem once again, I am using TFS 2008, connect to it using VSTS 2008,

    Now After giving proper permission to user,


    I went to TEAM EXPLORER > SELECTED THE PROJECT(Let Say name is test) > Source Control > In Left folder menu Selected the project Test and Right Clicked on it > get Latest version > It asked for folder where to download files > I gave E:\VSTSTest

    it got all the latest version.


    Now for the testing purpose, I deleted the project folder contents (E:\VSTSTest) from Windows Explorer (without using VSTS), now if I try to "Get Latest Version" it says

    -----
    All files are up to date
    No File is updated because requested version is previously downloaded.
    To force an update use "Get Specific Version" command with "Overwrite all..." option checked.
    -----


    I tried to "Get Specific Version" Command with Overwrite option checked (There are two check box option with every permutation and combination)


    I even tried the info provided at

    http://www.woodwardweb.com/tfs_top_tip/tfs_top_tip_11.html

    but it is not working also.



    I even tried AT COMMAND LINE

    C:\Documents and Settings\msareen>"E:\Microsoft Visual Studio 9.0\Common7\IDE\TF.exe" get /force /recursive  $/Test
    All files are up to date.


    It is not getting downloaded(even force command is doing nothing)



    So my question is If I deleted a project downloaded previously from TFS and then delete it from Local folder manually, HOW TO TELL VSTS/TFS THAT FILES ARE NO LONGER PRESENT ??



    ----
    Manasvi Sareen







    The Chosen One
    Monday, November 24, 2008 8:40 AM
  • The Problem got solved automatically, after a while i just removed the workspace , created a new workspace then tried to Download the source, and it was working,(which was not working earlier)... I think there is some bug here in VSTS 2008 
    The Chosen One
    • Proposed as answer by Manasvi Sareen Thursday, November 27, 2008 7:33 AM
    • Proposed as answer by Manasvi Sareen Thursday, November 27, 2008 7:33 AM
    • Marked as answer by Hua Chen Friday, November 28, 2008 8:02 AM
    Thursday, November 27, 2008 7:33 AM