none
Error Code 643 while trying to install NET Framework 4 on Windows 7 Ultimate

    Question

  • OK, it's time to call on the big guns. I've followed every blog and step by step instructions I've come across on the Internet and nothing and I mean nothing has helped resolve this issue. I am unable to install NET Framework in any flavor on my Windows 7 Ultimate machine. I always get the error code 643.
    Wednesday, September 21, 2011 7:03 PM

Answers

  • After months and months of trying to resolve this issue I was finally able to fix it by going back to basics and looking at permissions on certain keys in the registry.  I appreciate your help MS folks but truthfully you didn't offer one thing new that I hadn't already tried.  For anyone else who may be having the same issue try this:

    Steps to resolve the issue:

     i.Click Windows button and type 'regedit' in search bar.
     ii.Click 'regedit' in search results
     iii.Navigate to following registry hive:

    HKLM\Software\Microsoft\Windows\CurrentVersion\Installer

    Check if following registry keys have correct values:

     ■ MsiExecCA32 should end with \Windows\syswow64\msiexec.exe
     ■MsiExecCA64 should end with  \Windows\system32\msiexec.exe

     

    You may find that the entries are correct but now check the privilages on the key.  On mine they were set to read only even though I had admin privilages.  Once I changed ownership on the key and made sure the owner had full privilages I was able to install the file downloaded earlier, http://www.microsoft.com/download/en/details.aspx?id=17718  After months of trying to install it it finally worked.  As a matter of interest, I had run the various tools to clean up previous installations as well as make sure there were no fingerprints from their insalls as well.

    • Proposed as answer by pvdg42MVP Saturday, September 24, 2011 11:40 PM
    • Marked as answer by Alexander Sun Monday, September 26, 2011 5:15 AM
    Saturday, September 24, 2011 4:31 PM

All replies

  • I know you said you've "done everything", but I'm going to ask you to do the following:

    Download a fresh copy of .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    Remove ALL .NET 4.0 entries (if any) with Aaron Stebner's tool:

    http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    Create a new account on your system with FULL administrative priveleges.

    Disable all AV/anti-malware/firewall software.

    Log on with your new account and run the installer As Administrator.

    If it fails, please supply all logs as follows:

    Collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    • Proposed as answer by Alexander Sun Friday, September 23, 2011 7:59 AM
    Wednesday, September 21, 2011 10:16 PM
  • Creating a new profile with full administrative privilages then running the file as administrator failed as it has in the past.  Created the vslogs.cab file as per your instruction.  The link is here: https://skydrive.live.com/#!/?cid=d42162bd25a20cd1&sc=documents&id=D42162BD25A20CD1%21137
    Friday, September 23, 2011 3:16 PM
  • Looking through your install log for .NET Framework 4.0, I found this entry:

    "Launching CreateProcess with command line = wusa.exe "D:\54db8f8e24a0320ca38dc849c9\Windows6.1-KB958488-v6001-x64.msu" /quiet /norestart
     Exe (D:\54db8f8e24a0320ca38dc849c9\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null)."

    Unfortunately, the install log for .NET Framework 4.0 indicates a problem with your Windows Update (wusa.exe).

    Are there, by any chance, unfinished or failed Windows updates on your system?

    Regardless, for best help in correcting your Windows Update issue, I suggest you ask in the MS Answers forums for your Windows version:

    http://answers.microsoft.com/en-us/windows/forum/windows_7

     

    Friday, September 23, 2011 3:46 PM
  • After months and months of trying to resolve this issue I was finally able to fix it by going back to basics and looking at permissions on certain keys in the registry.  I appreciate your help MS folks but truthfully you didn't offer one thing new that I hadn't already tried.  For anyone else who may be having the same issue try this:

    Steps to resolve the issue:

     i.Click Windows button and type 'regedit' in search bar.
     ii.Click 'regedit' in search results
     iii.Navigate to following registry hive:

    HKLM\Software\Microsoft\Windows\CurrentVersion\Installer

    Check if following registry keys have correct values:

     ■ MsiExecCA32 should end with \Windows\syswow64\msiexec.exe
     ■MsiExecCA64 should end with  \Windows\system32\msiexec.exe

     

    You may find that the entries are correct but now check the privilages on the key.  On mine they were set to read only even though I had admin privilages.  Once I changed ownership on the key and made sure the owner had full privilages I was able to install the file downloaded earlier, http://www.microsoft.com/download/en/details.aspx?id=17718  After months of trying to install it it finally worked.  As a matter of interest, I had run the various tools to clean up previous installations as well as make sure there were no fingerprints from their insalls as well.

    • Proposed as answer by pvdg42MVP Saturday, September 24, 2011 11:40 PM
    • Marked as answer by Alexander Sun Monday, September 26, 2011 5:15 AM
    Saturday, September 24, 2011 4:31 PM
  • Thank you very much for sharing your solution, fulpock!
    Saturday, September 24, 2011 11:41 PM
  • Thank you so much. Followed your instructions and after many failures over the last month it finally installed.

    You are a star!


    Thursday, February 02, 2012 5:26 PM
  • fulpock, you are the freakin man! I tried all the long and trendy solutions, but to no avail.  With yours, check, check, done!
    Thursday, February 09, 2012 12:42 AM