none
A selected drive is no longer valid.

    Question

  • I have VS2008 + SP1 installed already. When I installed it I selected C# and VB.NET. When I installed the software I copied  entire DVD to my local hardrive (unfortunately I could not remember to which folder now).

    Now I need to add VC++ to my VS2008, I went to control panel --> Add and Remove, I selected VS2008 and clicked "Change/Remove" button. The setup/maintenance screen came up, I selected "Add or Remove Features" after I checked "VC++" and clicked "Update" button. I receive "A selected drive is no longer valid. Please review your installation path settings before continuing with setup." error message even though I have installation DVD in my DVDROM.

    How can I make setup to pickup files from other directories?

    Thanks
    Hardy
    • Changed type YiChun Chen Tuesday, February 17, 2009 2:23 AM Do not follow up
    • Changed type YiChun Chen Tuesday, February 17, 2009 2:36 AM Follow up
    Monday, February 09, 2009 8:51 PM

Answers

  • Hi Hardy,

    Could you please try to remove VS2008 SP1 under Visual Studio 2008 and then add VC++ package from Add or Remove Programs?

    Someone who had the similar problem used this method to solve it.

    If it doesn't work, please feel free to let me know.

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by YiChun Chen Tuesday, February 17, 2009 2:36 AM
    • Edited by YiChun Chen Thursday, April 23, 2009 8:40 AM
    Wednesday, February 11, 2009 3:25 AM

All replies

  • Hi Hardy,

    Could you please try to remove VS2008 SP1 under Visual Studio 2008 and then add VC++ package from Add or Remove Programs?

    Someone who had the similar problem used this method to solve it.

    If it doesn't work, please feel free to let me know.

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by YiChun Chen Tuesday, February 17, 2009 2:36 AM
    • Edited by YiChun Chen Thursday, April 23, 2009 8:40 AM
    Wednesday, February 11, 2009 3:25 AM
  • Hi Hardy,

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, February 17, 2009 2:23 AM
  • Sorry for the delay. I uninstalled SP1, added VC++ and reinstalled SP1, it worked form.
    Tuesday, February 17, 2009 2:34 AM
  • Hi Hardy,

    I'm so glad to hear that it works. Congratulations!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, February 17, 2009 2:38 AM
  • Sorry for the delay. I uninstalled SP1, added VC++ and reinstalled SP1, it worked form.

    How did you uninstalled SP1 only. I can't find anything under Control Panel\Programs\Programs and Features (in Windows Vista). If I start the SP1 installation package, it starts the installation process again (no uninstall option).

    Thanks
    Thursday, April 23, 2009 8:39 AM
  • Sorry for the delay. I uninstalled SP1, added VC++ and reinstalled SP1, it worked form.

    How did you uninstalled SP1 only. I can't find anything under Control Panel\Programs\Programs and Features (in Windows Vista). If I start the SP1 installation package, it starts the installation process again (no uninstall option).

    Thanks

    In you "Add and Remove Programs", please check "Show updates" checkbox on top.
    Scroll to your "Microsoft Visual Studio 2008 ... Edition", you can see ".... ENU Service Pack 1 (KB945140)".
    Thursday, April 23, 2009 1:05 PM
  • Sorry for the delay. I uninstalled SP1, added VC++ and reinstalled SP1, it worked form.

    How did you uninstalled SP1 only. I can't find anything under Control Panel\Programs\Programs and Features (in Windows Vista). If I start the SP1 installation package, it starts the installation process again (no uninstall option).

    Thanks

    In you "Add and Remove Programs", please check "Show updates" checkbox on top.
    Scroll to your "Microsoft Visual Studio 2008 ... Edition", you can see ".... ENU Service Pack 1 (KB945140)".
    There is no "Show Updates" in Windows Vista, thats Windows XP (see my post)
    Thursday, April 23, 2009 2:57 PM
  • Sorry for the delay. I uninstalled SP1, added VC++ and reinstalled SP1, it worked form.

    How did you uninstalled SP1 only. I can't find anything under Control Panel\Programs\Programs and Features (in Windows Vista). If I start the SP1 installation package, it starts the installation process again (no uninstall option).

    Thanks

    In you "Add and Remove Programs", please check "Show updates" checkbox on top.
    Scroll to your "Microsoft Visual Studio 2008 ... Edition", you can see ".... ENU Service Pack 1 (KB945140)".
    There is no "Show Updates" in Windows Vista, thats Windows XP (see my post)

    Oops, I have no clue of Vista. Sorry...
    Thursday, April 23, 2009 3:20 PM
  • Hi,
    is there another solution around?
    Uninstalling and reinstalling the SP1 is nothing you can do in a couple of minutes. In Vista is is not an option at all.

    René
    visit my blog: http://www.hezser.de/blog
    Tuesday, May 19, 2009 11:17 AM
  • Any answer?  Is the only solution in Vista to uninstall Visual Studio?  It shouldn't be this difficult to add a component to Visual Studio.
    Monday, June 01, 2009 8:54 PM
  • Still no answer i am also having the same problem i cant install C# now after i installed VC++ at the time of installation.
    Any solution .. dont want to reinstall everything .. :(
    • Proposed as answer by Pinata Sunday, June 14, 2009 9:37 AM
    Tuesday, June 09, 2009 6:57 AM
  • Can/has a defect be submitted for this issue?  This is a painful workaround.
    X
    Friday, June 19, 2009 4:26 PM
  • Hi,
    is there another solution around?
    Uninstalling and reinstalling the SP1 is nothing you can do in a couple of minutes. In Vista is is not an option at all.

    René
    visit my blog: http://www.hezser.de/blog

    SP 1 can be uninstalled under Vista. You have 'View installed updates' on left side in "Programs and features" applet of control panel. Right-click menu has uninstall.
    Ugly, anyway. It's no fix by any means.
    Thursday, June 25, 2009 10:53 AM
  • Hi YiChun,

    I have the exact same problem as Hardy did.  I need to install C++, but it's telling me that "A selected drive is no longer valid..." when I try to add C++ from Add/Remove Programs.

    Per your instructions, I tried to uninstall SP1, but I received the error "Error 1402 Could Not Open Key.  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\\SP1\KB945140.  Verify that you have sufficient access to that key, or contact your support personnel."

    I ran a repair on the VS2008 installation, hoping it would fix the problem.  The repair ran successfully, but when I tried uninstalling VS2008 again, I encountered the same KB945140 problem. 

    I'm running XP SP2 and I have VSTS 2008 installed.

    I am an admin on this box. 

    Any ideas?

    Thanks
    Doug Ferguson
    Tuesday, July 07, 2009 10:22 PM
  • I submitted this issue to MS as this is the only reference I could find to this issue. We will see what happens.
    Tuesday, September 01, 2009 8:07 PM
  • Thanks for taking the time to report this via the connect site.  If others feel this is important you should follow the link above and rate the issue.   When I was just there only 4 people have done this, which unfortunately is a recipe for MSFT blowing off this problem as not being important.
    Monday, September 14, 2009 8:13 PM
  • Add me to the list. I'm just trying to add the x64 c++ compiler and get the same error.
    Sunday, October 04, 2009 4:53 PM
  • I submitted this issue to MS as this is the only reference I could find to this issue. We will see what happens.

    I agree with the comments in that bug report. This workaround is annoying. They should have updated SP1 so that this doesn't happen.
    Friday, October 09, 2009 5:33 AM
  • I submitted this issue to MS as this is the only reference I could find to this issue. We will see what happens.

    I agree with the comments in that bug report. This workaround is annoying. They should have updated SP1 so that this doesn't happen.

    The bug is far more than annoying, between removing SP1, installing, and reinstalling SP1 + other updates that were blown away in the process, I spent about 3 hours.  I spent another two hours beyond this trying to figure out what was wrong with VS. 

    This is completely unacceptable!
    Wednesday, October 21, 2009 4:07 PM
  • I too am trying to install x64 C++ support and ran into the same problem. It seems ridiculous that nothing short of uninstalling the entire product is guaranteed to work. Hours of work for what should have taken 5-10 minutes tops.
    Sunday, October 25, 2009 7:57 PM
  • Uninstall SP1 is not working on a XP SP2 box. It shows following errors and rollback the uninstallation:

    Error 1402. Could not open key: HKEY_LOCAL_MACHINE\SOFTWARE\Midrosoft\Updates\\SP1\KB945140. Verify that you have sufficient access to that key, or contact your support personnel.

    I'm the admin on this box.

    I checked the registry, it seems missing "Microsoft Visual Studio 2008 Professional Edition - ENU" before SP1 in above path. There are two \ in the path.

    Any advice?

    Please don't tell me to uninstall all of VS2008 and reinstall it again with SP1...
    Monday, November 02, 2009 3:05 PM
  • Hi George,

    All I can say is that I completely removed VS 2008 from my machine and then reinstalled it with the extra 64-bit support I needed (applying the service packs as part of the installation process). This worked and was fairly simple but did take some time. And now I can get on with my life. But it is absurd to have to do this to add 64-bit support.

    Larry
    Monday, November 02, 2009 3:36 PM
  • how annoying...

    Removing Service Pack 1 was also the only solution for me..

    Thursday, November 12, 2009 5:16 PM
  • Tell me about it! I was trying to install SQL 2008 Express and then get the Management Studio to work so I could use it with Visual Studio 2008. I guess you have to use the SQL 2005 that comes with VS? We have been using SQL 2000 for years because it just works and every time I look at upgrading and install the newer versions there is so much BS to go through to make it work. Like when installing SQL Express edition, why was it easier for God to create the earth than to install the management studio so you can MANAGE the SQL instance.

     Why do all Microsoft products have so many features but so much sporadic documentation. If it's this hard to add features and developing applications...how the heck is it going to work for the end users. lol Really makes me wonder. This is just plain stupid, uninstall SP1 to add a feature then reapply SP1? I swear I have spent several years of my life trying to rig up Microsoft software to work like it's suppose to.
    Wednesday, November 18, 2009 3:04 PM
  • I have been trying to do this under Windows 7 Ultimate 64 bit.

    I uninstalled 3 SP1 updates (including KB945140), but to no avail.

    My only resort was to uninstall/reinstall Visual Studio 2008 with the x64/Itanium components selected. This of course worked but it took me several hours to do with the added reinstallation of SP1 and the subsequent Windows Updates.

    It is a pity that Microsoft did not reply when Rootberg referred the matter to them. I guess really that all they can do is to issue a new DVD to MSDN subscribers. It would be nice if this could happen before V S 2010 is released. Worst prospect of all is that the error will be perpetuated into V S 2010.
    Saturday, November 21, 2009 10:54 AM
  • I have Win 7 Enterprise with this problem.....unistalling sp1 of visual studio worked for me:

    1)Control Panel
    2)Unistall a program
    3)View installed updates
    4)Remove Visual Studio SP1
    5)Restart
    6)Control Panel
    7)Unistall Programs
    8)Select visua studio
    9)Select add/remove features
    10)Select the new features that you want to install....




    Thursday, December 10, 2009 6:22 PM
  • Hi,

    In WinXP, you can uninstall VS2008-SP1 using following steps:

    1. Go to Add/Remove programs
    2. Check "Show Updates" check box
    3. Select VSTS 2008 SP1 under VSTS main setup and click remove

    This will uninstall SP1 and you can continue updating VS2008 further.

    Thanks.
    Asim
    Tuesday, December 15, 2009 6:41 AM
  • Hi YiChun,

    I have the exact same problem as Hardy did.  I need to install C++, but it's telling me that "A selected drive is no longer valid..." when I try to add C++ from Add/Remove Programs.

    Per your instructions, I tried to uninstall SP1, but I received the error "Error 1402 Could Not Open Key.  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\\SP1\KB945140.  Verify that you have sufficient access to that key, or contact your support personnel."

    I ran a repair on the VS2008 installation, hoping it would fix the problem.  The repair ran successfully, but when I tried uninstalling VS2008 again, I encountered the same KB945140 problem. 

    I'm running XP SP2 and I have VSTS 2008 installed.

    I am an admin on this box. 

    Any ideas?

    Thanks
    Doug Ferguson

    I had the same issue.
    It looks like SP1 installer uses incorrect registry path during uninstallation.
    I resolved this issue by copying SP1 registry folder from "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft Visual Studio Team System 2008 Development Edition - ENU" to "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates".
    Thursday, December 17, 2009 11:21 AM
  • The path on Windows 7 x64 is at
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates

    I tried copying the SP1 folder from
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft Visual Studio 2008 Professional Edition - ENU

    to
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates

    But in vain :(

    Photography >> http://flickr.com/photos/korayem/
    Saturday, December 26, 2009 10:23 PM
  • Hi -

    I ran into the same problem trying to update my VS installation.  Using your advice, I was able to proceed with the update.

    Thanks very much!

    Robert Cohn
    Friday, February 05, 2010 6:00 PM
  • Hi All,
    Same issue here now uninstalling SP1, but this is aver anoying workaround... just to add X64 C++ compiler and Tools ...

    Grrr, please MS, provide us an hotfix for the next of us ranning to the same issue.

    Thnxs
    Wednesday, February 10, 2010 4:51 PM
  • Shows what a complete joke Windows Installer is at times.  I will never understand why things had to be made so difficult on Windows.  Especially when the Add Features is showing the correct install path for VB 2008.

    Anyways if you just need to install the X64 Compiler Tools you can also Install the Microsoft Windows SDK for Windows 7.0 and select the X64 Compiler Tools there.  At least that's what worked for me.

    At least I thought that would work. No such luck because you don't get the lib files.

    So an entire day wasted.  Uninstall SP1, Install x64 Feature of VS 2008, Reinstall SP1, then install KB971092 to fix the ATL error of SP1.

    Thank you so much Microsoft for wasting my entire day.
    Sunday, February 21, 2010 2:44 PM
  • Same problem here. I'm trying to add C++ to my Visual Studio 2008 SP1 installation on a Windows 2008 R2 image. No luck. I tried removing SP1. When running the setup after that (even after a reboot) I'm getting the warning "A problem has been encountered while loading the setup components. Canceling setup.". I'm getting this error both via the add/change programs option in Control Panel as well as via the setup on the installation CD. Before removing SP1, the first option did still work while the second didn't work already. Now both options don't work anymore so there's no way to add the C++ components. *Sigh* I hope I can manage to get SP1 back on the image without any problems. Same trouble on a Windows 2003 image. One big lesson learned here is always install with all the options in Visual Studio 2008. Don't be fooled to think you can easily add additional functionality later when needed. Guess there's no other way than to create a new image with VS2008.
    Thursday, March 11, 2010 3:11 PM
  • Complete lack of support for the MS dev community by MS itself.  It's been over a year since this was reported, and still no fix?  Entirely unacceptable that you have to uninstall an entire service pack just to update the core features of a product.
    Friday, March 19, 2010 10:00 PM
  • Windows 7 Home Premium x64. Uninstalled sp1 and all was well.
    Sunday, April 04, 2010 1:41 AM
  • I agree with the previous complaints.

    Expecting customers to spend several hours uninstalling and reinstalling SP1 just to add/remove options is not a solution at all. How can we be sure that uninstalling SP1 will not make things worse? I have no confidence in VS 2008, and can't believe Microsoft hasn't bothered to fix this problem by now.

    Microsoft has never been known for quality, but this reaches a new low. Does Microsoft have any regard for its customers at all? Why should anyone throw away good money on VS 2010, after seeing how bad VS 2008 is?

    Thursday, May 06, 2010 8:03 PM
  •  It's been over a year since this was reported, and still no fix?  Entirely unacceptable that you have to uninstall an entire service pack just to update the core features of a product.

    Same here - a whole morning lost to this fiasco, and not even a workaround such as SUBST or drive mapping?  And I had just installed the dev studio in March on a Win7 64-bit machine.   Everything installed EXCEPT for the C++ 64 components by default.    The workaround of uninstalling VS2008 SP1, install the x64 components, the Windows Update worked.

      Please don't let this bug ship in VS 2010 - even if you must delay the shipment.

     


    SteveB
    Thursday, May 13, 2010 3:18 PM
  • I too have this issue.  LOL! I was just going to go the usual route and uninstall/reinstall.  I had moved "My Documents" from one drive to another after my installation, and figured from looking at the setup error log that was the issue, and then I looked, and found this thread!  Thankfully, I should only have to uninstall / reinstall the SP1.  I can't believe they can't point us to a RegKey to edit or something. 

    Bruce

     


    Bruce
    Wednesday, July 28, 2010 5:07 PM
  • The fix was posted on the Connect. One needs to install KB979576 hotfix: https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=27638

     

    Friday, September 10, 2010 8:31 PM
  • I encountered this issue tonight and wanted to also post a comment. I had installed VS 2008 on W2K8 R1 (x64) initially w/o VC++ and then run VS 2008 SP1 and updated all the Windows Update patches. When I looked for VS 2008 SP1 in the add/remove programs it was missing. Then I ran the VS 2008 SP1 installer again. It copied some files to the c:\Program Files (x86)\Microsoft Visual Studio 2008\VC folder - I was watching this folder. Then I went back to the VS 2008 add/remove programs and it showed some of the VC++ options were checked but trying to add the other ones and I got the error in this thread again.

    I think the root problem must be that when you install things like the Windows SDK or Visual Studio SDK the VS 2008 installer gets confused who installed them.

    You may need to uninstall the Windows SDK or Visual Studio SDK in order to get the VC++ installer to work w/o uninstalling SP1.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Monday, October 11, 2010 11:25 PM
  • Hi There

     

    I too have the same issue, and fixed it from Microsoft Hotfix available at https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=27638

    Cool!

    Thanks

    Ravishankar


    ravishankarp
    • Proposed as answer by Skiddy79 Monday, February 21, 2011 7:08 PM
    Saturday, November 13, 2010 2:38 AM
  • this seems to be working for me at least, the install hasn't finished but it made it a heck of a lot further
    Tuesday, December 07, 2010 4:24 PM
  • Hello Ravishankar,

    I also had the same issue. I was trying to build C++ project for x64 and your link to hotfix worked just fine for me. I was able to add x64 compiler and tools for VC++ using add\remove features.

    Thanks a lot. Saved a lot of headache.

    Jayesh Modha


    Jayesh Modha
    Thursday, February 17, 2011 9:16 PM
  • Hotfix worked for me as well.
    Friday, March 04, 2011 6:05 PM
  • Hot fix worked, thanks Ravi
    Thursday, April 28, 2011 8:00 AM

  • The fix was posted on the Connect. One needs to install KB979576 hotfix: https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=27638

     

    This is THE answer which is way better than the one posted at the top

    Many thanks Walter

    • Proposed as answer by gdm_online Wednesday, March 05, 2014 2:35 PM
    • Unproposed as answer by gdm_online Wednesday, March 05, 2014 2:35 PM
    Friday, May 27, 2011 2:58 PM
  • Installing the mentioned KB fixed the issue for me.

     

    Torben

    Wednesday, August 17, 2011 11:47 AM