none
Database Installation Failed

    Question

  • I tried to install the .NET Stock Trader sample application. However, I received the following error message: "Error 1001: The installation failed, and the rollback has been performed. --> A failure has occurred during the database installation phase. The exception encountered was: Login failed for user 'configAdmin'. The user is not associated with a trusted SQL Server connection.". I had no clue what was wrong here. Any helps will be much appreciated!

     

    Thanks.

    John

    Sunday, July 29, 2007 4:34 PM

All replies

  • For now, try installing using SQL Server Authentication.  Its a requirement that SQL Server be installed in mixed mode authentication since the app itself uses SQL Auth; however, the installation itself should work with a trusted connection and has been tested using a trusted connection, so not sure what the error is here.  But again, utlimatelty to run the sample, you need to have SQL Auth enabled, so once you do this, re-try using the sa admin account as the login for the installation (install must run with admin privledges on the DB).

     

    Hope this helps,

     

    Greg

    Monday, July 30, 2007 4:12 PM
  •  

    Hey Greg,

     

    I have switched authentication mode to mix mode, enabled 'sa' account, and I was able to log in to database server from sql server management studio.  However, when I tried to install the stock trade applicaiton, my login failed with 'sa' at database setup page.

     

    Any help will be appreciated!

    zjin

    Wednesday, August 01, 2007 7:20 PM
  • You might want to check to make sure that SQL Server Surface Configuration - allows for remote connections.   By default, remote connections are disabled for TCP and Named Pipes. 

     

     

     

    Thursday, August 02, 2007 12:26 AM
  •  

    Thanks Jody.  I changed the configuration as you said, but it still give me 'the connection failed' error message.  Is there anything else I need to do.
    Thursday, August 02, 2007 2:26 PM
  •  

    After changing the connections did you stop and restart SQL Server (the connection changes only take place after a restart).

     

    If you still can not connect - it may be that a firewall is in place and blocking the requests - that would be commonly port 1433. You would need to check the machine your DB is installed on as well as the machine you are installing the application on.

     

    You can get a more specific error message from your machine you are installing the application...by running the install from the command prompt.  see: http://msdn2.microsoft.com/en-us/library/Aa367988.aspx

     

    One of the things I always do is use the ODBC manager in Administrative Tools.

     

    Create a User DSN. 

    Select SQL Server -> Finish

    This starts a Wizard....that is somewhat self explanatory.  And allows for testing easily of data connectivity from one machine to the SQL Server box...

     

    It should also give a more explicit error message.  Other than a firewall blocking 1433 (on one or both machines), or not restarting SQL Server after the surface area configuration...  I can not think of too much else that would prevent you from being able to connect from within the MSI...

     

     

     

    Thursday, August 02, 2007 2:48 PM
  •  

    Thans Jody.  I did everything you mentioned above.. restarted server, open port 1433 from window firewall...  DSN works fine and the connection to the SQL Server was successful.  Not sure what else I can do to make it work.

     

    One thing on the database setup page, it asks to input server name/ip address.  it may be the problem.  I noticed if I just input server name, 'the connection failed' error comes back right away.  If I intput <server name>\127.0.0.1, it takes while for the same error message back.  Why do I need ip address here? 

     

    Thanks,

    zjin

    Thursday, August 02, 2007 4:31 PM
  •  

    I am assuming that you are installing using a local copy of SQL Server - in which case this will (or should work)

     

    Use:  (local)

     

    As the ServerName/IP....  Parenthesis are required, instead of the 127.0.0.1.  Not sure why that would be an issue...

     

    If still having a issue can you let me know what OS version you are using...and confirm that the whole installation (Database and application) is being installed on your local machine.

     

     

    Thursday, August 02, 2007 4:53 PM
  • It does not work.  I have Window XP with SP2 and SQL Server 2005 developmer with (database engine, integration service, notification service, reporting service...)

     

    Thanks,

    zjin

    Thursday, August 02, 2007 5:44 PM
  •  

    OK - this is a long shot...  here is decent link for troubleshooting connectivity issues with SQL...

     

    http://blogs.msdn.com/sql_protocols/archive/2005/10/22/sql-server-2005-connectivity-issue-troubleshoot-part-i.aspx

     

    Here are two immediate things to check for using SQL Management Studio - Right Click on the Server (Top Level) and bring up properties...two screen shots indicate the typical settings. 

     

    (sorry for the links - the editor here will not allow embedding of images)

     

    http://tech-review.org/photos/sample/images/3960/original.aspx


    and check this:

     

     http://tech-review.org/photos/sample/images/3961/original.aspx

     



    Hopefully that helps. The link above is a huge blog entry where they address SQL 2005 connection issues quite extensively. The application does install on XP SP2. So this issue is probably more or less related to how your SQL Server is setup. I am hoping those two screenshots will assist in solving your particular issue...

    Thursday, August 02, 2007 6:35 PM
  •  

    Ok.  I will look into it and really appreciate your help!
    Thursday, August 02, 2007 6:44 PM
  • Refer below link, I hope it will sove your problem.

    http://support.microsoft.com/kb/889615

     

    nagesh

    Thursday, September 06, 2007 2:29 PM
  • use SQL Server 2008
    tfsm alex
    Friday, September 10, 2010 9:21 AM