none
Unable to start debugging on th web server

    Question

  • Hi there,

    I am trying to develop a DNN module using WAP method (Web Application). In WAP each module is it's own solution and it's simply references the DotNetNuke.dll file. When I try to debug the module I receive this error message:

    ======================================================

    Unable to start debugging on the web server. The web server is not configured correctly. see help for common configuration errors. Running the web page outside the debugger may provide further information. 

    ===================================================================

    I'm using Visual Studio 2010 and I configured the Web tab of its properties as follows:

    Start URL: http://dnndev 

    I selected 'Use local IIS Web Server' and provided the project URL:

    'http://dnndev/desktopmodules/MyModuleName

    and checked 'Override application root URL'

    http://tkddev

     

    I would appreciate any help.

    Thanks,

    David

    Tuesday, May 31, 2011 6:52 PM

Answers

  • If you are using Vista or later, did you run Visual Studio as administrator? As the error message indicates, could you please run the web page without VS Debugger to see whether it works?

    1. Open IIS Manager

    2. Open Sites -> Default Web Site, right-click your web application, and select Manage Application -> Browse to open the default page, did you encounter any error when open the page?

     

    I tried to debug an ASP.NET application with following options, and VS Debugger works well:

     

    1. "Use Local IIS Web server" enabled

    Project Url: http://localhost/MyWebApp

    2. Virtual Directory has been created by clicking the "Create Virtual Directory" button.

    3. "Override application root URL" checked.

    4. Start URL under Start Action is set to "http://localhost/MyWebApp"

     

     

    By the way, what if you choose "Use Visual Studio Development Server" option, and change Start Action to Current Page?


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by eryang Tuesday, June 14, 2011 3:11 AM
    Wednesday, June 01, 2011 3:59 AM
  • Actually it's all good. Like 99% of the problems in PC's world, I have solved this one with a healthy restart. So now I see the w3wp.exe process and I'm able to debug the project.

     

    Thank you so much for your dedicated help.

    David

     

    • Marked as answer by eryang Tuesday, June 14, 2011 3:11 AM
    Friday, June 03, 2011 8:39 PM

All replies

  • If you are using Vista or later, did you run Visual Studio as administrator? As the error message indicates, could you please run the web page without VS Debugger to see whether it works?

    1. Open IIS Manager

    2. Open Sites -> Default Web Site, right-click your web application, and select Manage Application -> Browse to open the default page, did you encounter any error when open the page?

     

    I tried to debug an ASP.NET application with following options, and VS Debugger works well:

     

    1. "Use Local IIS Web server" enabled

    Project Url: http://localhost/MyWebApp

    2. Virtual Directory has been created by clicking the "Create Virtual Directory" button.

    3. "Override application root URL" checked.

    4. Start URL under Start Action is set to "http://localhost/MyWebApp"

     

     

    By the way, what if you choose "Use Visual Studio Development Server" option, and change Start Action to Current Page?


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by eryang Tuesday, June 14, 2011 3:11 AM
    Wednesday, June 01, 2011 3:59 AM
  • Hy Eric,

    Thank you for you reply.

    Yes the website works without VS debugger, i defined it in the IIS and I can browse it freely whenever I wish (locally of course).

    As for the second part of your reply, the debugger works without those settings however it doesn't stop at breaking points. I think debugging a dnn sites requires a very specific settings in order for it to work. Also, this is a dnn module project that cannot function as a stand alone website and has to be part of the dnn network. Anyway as for now it is still not working. Any more suggestions?

     

    Best,

    David

    Wednesday, June 01, 2011 9:29 PM
  • Another workaround is host the website in IIS, and then attach VS Debugger to the W3Wp.exe process (using Tools menu-> Attach to process).

     

    Note: On the Attach to Process dialog, there is a Select button immediately beside the "Attach to:" textbox, you can click this button and choose "Managed (v4.0)" as Code Type.

     

    Another post discussed similar issue, you can go through suggestions in that post, hope any of them can help.


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, June 02, 2011 2:18 AM
  • Hi Eric,

    Thank again for your help.

    I tried to implement your first suggestion but the process W3Wp.exe was not listed in the processes list when I opened the attached to process window. 

    As far as the other suggestion, I don't know which one you were referring to, but when you convert a DNN module folder to virtual directory it crashes the module. I used a predefined template to create the project (http://christoctemplate.codeplex.com/). By default this template is configured to use .NET 3.5. The site is configured to use 4.0. I don't see any problem with that as the site should be able to manage a code of an older framework version.

    I'd love to hear more advises as this problem really holds my progress.

     

    Best Regards,

    David

    Thursday, June 02, 2011 7:18 PM
  • First, you may launch Visual Studio as administrator (right-click VS icon, and select "run as administrator"); On the Attach to Process dialog, please check both "Show processes from all users" and "Show processes in all sessions";


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, June 03, 2011 2:34 AM
  • I am running VS (2010) as administrator and I ticked both check boxes (and clicked refresh) but I still do not see any W3Wp.exe. I verified that IIS is running and it is. BTW, I'm running Windows 7 Ultimate.

     

    Thanks again,

    David

    Friday, June 03, 2011 5:58 PM
  • Actually it's all good. Like 99% of the problems in PC's world, I have solved this one with a healthy restart. So now I see the w3wp.exe process and I'm able to debug the project.

     

    Thank you so much for your dedicated help.

    David

     

    • Marked as answer by eryang Tuesday, June 14, 2011 3:11 AM
    Friday, June 03, 2011 8:39 PM