none
PresentationFontCache hogging CPU

    Question

  • Hi,

    I am developing an XAML and C# VS.Net 2008 windows application. Startup time is fine but my system slows down from the first time the application is run. Looking at Task Manager/procexp I noticed that the process PresentationFontCache.exe is hogging a nearly constant 50% of my machines CPU cycles.
    To check if my application was at fault I closed it, removed the
    PresentationFontCache.exe process from memory then restated the service from the command line using: 
       net start FontCache3.0.0.0

    PresentationFontCache.exe loads up again and immediately ramps up to 50% CPU use!

    Looking at the process in the services MMC application I notice the service status is permanently at "Starting". The Application Event log also notes that a start message was successfully sent to the service, but there is no follow-up event to indicate the service went into running mode.

    I'm figuring something may be stalling the font cache process and stopping it from starting up properly. Can anyone help me here please ?

    I'm running on Windows Server 2003 and AFAIK have a pretty standard .NET development environment setup (VS2008, 2005 & 2003).

    NB: for the time being I've disabled the service while I'm developing - I don't know how PresentationFontCache.exe will behave on the target installation systems though.

    Thursday, May 22, 2008 10:19 PM

All replies

  • The same situation is happening on my fathers system.

    He is not using Visual studio.

    My system which is using Visual Studio does not have the problem.

    I disabled the service and ended the program via the task manager.
    Friday, March 27, 2009 2:18 AM
  • It's hard to identify based on provided data what is the cause of high CPU usage.
    One of the reasons could a big number of fonts (expect the ones that originally shipped with OS).

    You could try stopping the service, deleting the file it creates: Windows\ServiceProfiles\LocalService\AppData\Local\FontCache4.0.0.0.dat and restarting the service to check if that helps.

    Friday, March 27, 2009 7:48 PM
  • The fix proposed by Hrach MSFT worked perfectly.  The CPU is now clocking normally (and the fan isn't on overdrive).  Thanks
    Wednesday, February 03, 2010 10:04 PM
  • This works for Windows 7 x64 as well. Just FYI. I was having the same issue.
    Saturday, September 11, 2010 2:07 AM
  • Does not show in service.msc BUT shows in Windows Task Manager. I am running Win XP pro.
    Thursday, September 16, 2010 9:06 PM
  • Thank you very much!

    Deleting the FontCache3.0.0.0.dat solved my problems...

    Wednesday, September 22, 2010 8:56 AM
  • Hi

    I tried that same and I fixed my problem. But does anyone know what to do at long term because I expect it can happens again?

    Is it fixed in .NET 3.5 SP1, NET 4 or what can we do so it wont happen.

    Thanks for "work around".

    Jerry Andersen

    Tuesday, October 05, 2010 11:50 AM
  • I just want to say I have Windows 7 x64 and deleting FontCache3.0.0.0.dat removed resource hogging file. Do a search in Computer to Find the file and delete.

    Thanks Dario MP.

    Saturday, October 09, 2010 5:40 PM
  • I have Window7 x64 and deleting FontCache3.0.0.0.dat solved resource hogging issue.  Find the file by doing a search in Computer and then deleting it.

    Thanks to Dario MP

    • Proposed as answer by jirojin Sunday, October 17, 2010 3:57 AM
    Saturday, October 09, 2010 5:43 PM
  • I encountered the same problem on my ThinkPad X100e running Windows 7 Professional. At first I couldn't locate the file FontCache3.0.0.0.dat as apparently no folder ..\AppData\Local exist under Windows\ServiceProfiles\LocalService\ on my system using Windows Explorer.

    I had to try clicking on Start\All Programs\Accessories\Command Prompt in order manually type in

    CD c:\Windows\ServiceProfiles\LocalService\AppData\Local

    which was found as expected. I then type command DIR and found that file, FontCache3.0.0.0.dat right there. Wow!

    However, instead of deleting it, I simply rename it to FontCache3.0.0.0.dat.bak just in case if anything wrong might happen I could rename it back.

    I restarted the system and my CPU problem was finally resolved!

    Thanks to everyone who shared your valuable experiences with us. Have a great day!

    • Proposed as answer by Stuart Aston Saturday, July 16, 2011 5:55 PM
    Sunday, October 17, 2010 4:25 AM
  • well i was having the same problem and if you dont need it do what i did. the lazy way to do it is hit the start button and search services in the search programs and files bar at the bottom.. and find the windows presentation foundation font cache 3.0.0.0 and right click hit properties and disable it....it worked for me so good luck.
    • Proposed as answer by brandonhunt15 Wednesday, October 27, 2010 9:54 PM
    Wednesday, October 27, 2010 9:53 PM
  • I encountered the same problem on my ThinkPad X100e running Windows 7 Professional. At first I couldn't locate the file FontCache3.0.0.0.dat as apparently no folder ..\AppData\Local exist under Windows\ServiceProfiles\LocalService\ on my system using Windows Explorer.

    I had to try clicking on Start\All Programs\Accessories\Command Prompt in order manually type in

    CD c:\Windows\ServiceProfiles\LocalService\AppData\Local

    which was found as expected. I then type command DIR and found that file, FontCache3.0.0.0.dat right there. Wow!

    However, instead of deleting it, I simply rename it to FontCache3.0.0.0.dat.bak just in case if anything wrong might happen I could rename it back.

    I restarted the system and my CPU problem was finally resolved!

    Thanks to everyone who shared your valuable experiences with us. Have a great day!


    That's weird.  I just came here to look for this problem and noticed you have the same model of laptop my user is experiencing this with...
    Friday, December 03, 2010 6:10 PM
  • Thanks for all the help!  I renamed the file and closed the process and it started back up but without hogging most of my cpu!

     

    My computer is a lenovo t500, maybe a thinkpad problem?

    Thursday, December 16, 2010 4:09 AM
  • Well, what is the fix for XP PRO systems?. I do not see any of the file and folder mentioned above.

     

    thxs

     

    Thursday, December 30, 2010 12:30 PM
  • After reading this thread, as well as another one about this process, it's my understanding that presentationfontcache.exe is associated with Microsoft's Visual Studio.  While I do not have Visual Studio installed, I do have Office 2007 and I've never noticed this process in my Task Manager before.  Suddenly, today, it pops up and it was taking a good bit of my resources - actually it was listed 2 times in processes - so I just ended both of them.  Like I said, I've never seen it before and I check my Task Manager often, so I know there's never been a problem with it before.  I was confused because the only thing I have changed in the last 24 hours was to install CorelDraw X5 and AVG Internet Security 2011 and neither of these should have called this issue.

    In any event, as ontap786 and several other users have asked...what is the fix for Windows XP Professional?  I haven't been able to find an answer for my operating system.  Please don't tell me that since we're using XP, instead of Windows 7, that we're going to be ignored because Microsoft isn't supporting our operating system any more!!!!  I'm sure I speak for the TENS OF MILLIONS of XP Professional users around the world when I scream:  WE DO NOT WANT TO CHANGE OUR OPERATING SYSTEM....WE DO NOT WANT WINDOWS 7.  WE LOVE WINDOWS XP.    Personally, if I'm forced to eventually change operating systems because Microsoft is no longer going to support it's LARGEST customer base, I WILL BE SWITCHING TO LINUX.  I'd buy a Mac -- and pigs will fly -- before I'll ever switch to Windows 7 - and I don't even like Mac computers.


    Soooo, please, someone/anyone let us know the fix for WINDOWS XP PROFESSIONAL. 


    Deborah *, President & CEO The Ray Media Group
    Wednesday, February 02, 2011 8:32 PM
  • I had the same issue on my WinXP laptop.  Fixed by using the following method:

    1. From Start Menu, go to Control Panel, then double click on Add/Remove Programs

    2. Look for anything that says 'Microsoft .NET Framework 3.0...' there may be a few of them depending on how many updates you have had.

    3. Click on one of them and you'll see a Change/Remove button appear.  Click on the Change/Remove button, and then select 'Repair'.

    4. Perform Repair for all the 'Microsoft .NET Framework 3.0...' instances.

    5.  Reboot system.

    6. Check wether the PresentationFontCache.exe stills appears on Task Manager after reboot.

    Hope this helps!  :) 

    • Proposed as answer by CK Shinde Tuesday, January 31, 2012 10:55 AM
    Monday, February 07, 2011 9:52 PM
  • Hi, ninjambush, that was a big help.

    Thanks a lot. My PresentationFontCache.exe CPU hog problem is solved now.

    Hope it can help others also.

    Saturday, February 26, 2011 11:29 PM
  • Wahhhhh, bboooohoooo...   Upgrade to Windows 7, its stronger, and a much better operating system than XP ever was (especially in 64bit mode).  The tens of millions of us who have windows xp still is only because we can not afford the upgrade.  Linux, still has much more bugs than I wan't to deal with...  and Mac's cost more than the average computer user has, because they ensure the absolutely bleeding edge (not worth the out the door price) tech is in their machines.  Oh, and pigs have flown several times, so get with the program...  (Pink Floyd, Age Of Empires, various cartoons, and regular meat packaging delivery).  I'll be sure to look up the Ray Media Group next time I need a good complaint broad casted.
    Jamie V Johnson CAD Manager/Database Developer
    Sunday, February 27, 2011 12:39 AM
  • im sorry im not good with computers and im haveing the same issue can someone walk me through the steps?
    Friday, March 11, 2011 7:09 PM
  • Thanks ninjambush, fixed my CPU hog problem. No to ssy it won't happen again if whatever caused it the first time strikes again.

    I like your solution as a fix rather than a work around. Ninja rules!

    Sunday, April 10, 2011 5:39 PM
  • I too have Windows 7 professional, but when I type in the c:\Windows\ServiceProfiles\LocalService\AppData\Local I get access denied.  Do you have any suggestions on that?

    Thanks!

    Friday, April 15, 2011 12:55 AM
  • Well, thought I would throw my 2 cents in and say thank you to Hrach as well.  Last night I was playing a new game on Steam named "Hydrophobia: Prophecy" and was about an hour into it and out of the blue my system shuts down.  I have a Toshiba X505-896 18.4" (or so) "gaming" laptop with Win 7 Home Premium 64 bit on it and when I started the system back up to see what was going on at first I thought perhaps it was shutdown due to heat so I opened up a program called "Core Temp 0.99.7" and saw that my CPU,  an Intel i7 Q740 2 1.73Ghz had been upwards of 80*C and was now around 70*C on some of the cores and threads and the CPU itself was running around 2.7Ghz (more than all out!) if not a bit more on the top end and only back down to2.2Ghz on the bottom end not ever going back to it's original frequency.  So, it was pretty late and so I just shut it down but this afternoon when I turned my machine back on it was still doing the same thing and just running all out.  When I opened up the Task Manager to see what might be making things go so hot and fast there was that same file that you all have been discussing (PresentationFontCache) and I right clicked on it to shut it down and it went away but a few seconds later it came back up again.  Ok, so I shut it down again and this time it stayed down but I would like like to understand how and why that program came up while playing this game and why my system shut down.  Actually I still think it may have been due to the heat what with that game running on just the recommended settings and then why the presentationfontcache would have came up.  Sorry about being so wordy.  I suppose I should have just said "Me too" and have done with it but I thought it was interesting that playing a game would have brought this all up... FYI, I did also go and rename the fontcache 3 as well just to be safe as there were other version of it there but no "4".
    Friday, May 13, 2011 4:34 AM
  • Thank you so much for that solution.  I have been plagued for the last couple of months by my system running at full pelt all the time (the BIOS is set to reduce the multiplier when not needed to operate at 21x) and as a result my system has been running too hot.  Deleting the FontCache3.0.0.0.dat file seems to have cured the problem - hopefully permanently.

    Carol
    Sunday, June 12, 2011 10:34 PM
  • A big Thanks ! It saved my day !

    Deleting FontCache3.0.0.0.dat on Win 7x64 resolved the problem.

    Sunday, September 18, 2011 11:51 AM
  • Contempt prior to investigation.

    Windows 7 is same as XP, only better.

    Its a sure bet that Deborah has not even investigated Windows 7.
    If she actually had a real look -without judging it before she looked, she would discover it is just like XP, only better.

    Typical, lazy comment from un-informed, un-conscious (probably fat and lazy) American.

    Tuesday, October 25, 2011 10:57 PM
  • I, TOO, have a Levono Windows-7 64-bit. However, when I tried this fix, I was DENIED ACCESS. Now what?
    Thursday, October 27, 2011 2:17 AM
  • I found it here for XP Pro SP3 and .Net 3.x:

    C:\Documents and Settings\LocalService\Local Settings\Application Data 


    Service name is:

    Windows Presentation Foundation Cache 3.0.0.0

    • Edited by linlu00 Thursday, October 27, 2011 6:05 PM
    • Proposed as answer by CK Shinde Tuesday, January 31, 2012 10:54 AM
    Thursday, October 27, 2011 6:00 PM
  • Where is it located for WIN 7? programs it says I have net 4 but no app files in appdata.
    I have an ASUS X5DIJ Series Laptop


    • Edited by Alex Asus Saturday, November 05, 2011 7:48 AM
    Friday, November 04, 2011 7:49 PM
  • Good ,quick Fix
    Tuesday, January 31, 2012 2:27 AM
  • Yes, renaming the FontCache3.0.0.0.dat is a good quick fix and thank you to the folks who have posted it.

    But can anyone explain why this problem should suddenly crop up on a perfectly stable system ... as it did in my Win 7 Pro system today ?

    Thursday, February 02, 2012 7:35 PM
  • Thanks, Worked very well with windows 7 :)
    Monday, March 05, 2012 11:27 PM
  • This is an old post, but could not help myself for replying to your comment about Win7 being superior to XP.

    Not sure why or where you got your opinion, but in my job role, we have done some extensive testing with Win7 and XP side by side.

    The test was to see how it performed when given the task of listening for specific heartbeats that would come from a serial connection thru a custom watchdog circuit that are sent every 5ms. This heartbeat is requested to ensure the program is up and ready to rec'v custom information.

    But...it is a very basic task.

    BOTH PC's were the same Make and Model, and were brand new when we did this Nov/2011

    Both PC's had any and all services NOT required turned off as not to add any other process interference.

    The Result........

    XP was able to monitor the heartbeats with minimal dropouts.

    Win7..was NOT able and had over 500 missed heartbeats in short order.  (making it useless)

    What does this tell me?? Microsoft has again added more complexity, perhaps even more calls to other processes or programs, which add's even more latency.

    Windows7....IMHO is not an option.  It's just another version of Microsoft BLOATWARE. If they threw in the towel and created a new OS from scratch, the right way, they would not be in the mess they are today. (loosing the desktop OS market)

    I went to MAC and in two years NOT ONE CRASH!! Kudos to them, even if the OS is not perfect, its very close.

    Windows.....no matter what version it is, desktop, server 32/64, 2003, 2008......they ALL freeze, crash, stall, have a kazillion errors in event logs, need constant babysitting and on and on.

    Do this simple test, load up XP, Win7 or any other MS O/S.

    Turn it on and let it run forever.....well not forever, because windows WILL blow up all on its own in due time. And that I have also proven.

    But I am with Deborah29033, XP is the better OS.

    MS should build one desktop OS, make it bullet proof, make it fast and incredibly stable, patch all the friggin security holes once and for all.

    Instead they choose to throw out crap like Millennium, and Vista. That alone should tell you something about MS.

    My trust in MS is in the Negative.

    My 2c!

    Wednesday, April 25, 2012 9:21 PM
  • Yes, this is an old thread, but the advice given above is solid.

    May I add to it a suggestion to clear the font cache files at system boot?

    Via Task Scheduler, my laptop now does a

    "del /q /f C:\Windows\ServiceProfiles\LocalService\AppData\Local\Font*"

    running under the Administrator account at system startup, so that this does not have to be researched and fixed again. As such, it's something of a permanent fix, though it is hard to tell whether this might interfere with something else later. 

    Sunday, April 21, 2013 6:37 PM
  • Thx dude, it rlly helped me. Everything runs normally again. Thanks a lot! ;)
    Friday, August 30, 2013 6:40 PM
  • Go on run type Services.msc press enter

    Check Windows Presentation Foundation Font Cache Service

    Services Status "Stop” & Start up type "Manual" bellow mention services

    i)Windows Presentation Foundation Font (3.0.0.0)

    ii)Windows Presentation Foundation Font (4.0.0.0)

     

    ð  next step

    del /q /s  "c:\winnt\temp\*.*"

    del /q /s  "%C:\WINDOWS\Prefetch\*.*"

    del /q /s  "%USERPROFILE%\Local Settings\Temp\*.*"

    del /q /s  "%USERPROFILE%\Local Settings\Temporary Internet Files\*.*"

    del /q /s  "%USERPROFILE%\Local Settings\Temporary Internet Files\*.*"

    del /q /s  "%USERPROFILE%\Oracle Jar Cache\*.*"

    del /q /s  "%USERPROFILE%\Cookies\*.*"

    Saturday, January 04, 2014 9:41 AM
  • Thanks for the work-thru - problem solved!!
    Wednesday, January 22, 2014 3:06 AM