none
Failed to connect to hosts in the cluster

    Question

  • Trying to provision a node with just the cache administration facility (PowerShell) - an existing, running cluster in production which works OK. I need to do this on a separate node to be able to rolling-upgrade to version 3.

    I am an admin, and running the PS cmdlet with admin privileges; I am kind of sure this is a firewall issue, but failed to put the proper

    corrections in no matter what I tried.  So far all articles I've steppe don seem to spin around the same routines: 'start Remote Registry', enable the 4 firewall rules , etc. (actually, when installing only the cache-admin feature, the rule group="Windows Server AppFabric: AppFabric
    Caching Service"  is not being created on the node)

    ======================================================================================

    Use-CacheCluster : ErrorCode<ERRCAdmin040>:SubStatus<ES0001>:Failed to connect to hosts in the cluster
    At line:1 char:62
    + Import-Module DistributedCacheAdministration;Use-CacheCluster <<<<
        + CategoryInfo          : NotSpecified: (:) [Use-CacheCluster], DataCacheException
        + FullyQualifiedErrorId : Microsoft.ApplicationServer.Caching.DataCacheException,Microsoft.ApplicationServer.Caching.Commands.UseCacheClusterCommand

    PS C:\Windows\system32> $StackTrace
       at Microsoft.ApplicationServer.Caching.AdminApi.CacheAdmin.GetAllowedServerVersionRange()
       at Microsoft.ApplicationServer.Caching.AdminApi.CacheAdmin.IsClusterUpgradeInProgress()
       at Microsoft.ApplicationServer.Caching.AdminApi.AdminUpgradeController.SetRollingUpgradeStatus()
       at Microsoft.ApplicationServer.Caching.Commands.UseCacheClusterCommand.BeginProcessing()
       at System.Management.Automation.Cmdlet.DoBeginProcessing()
       at System.Management.Automation.CommandProcessorBase.DoBegin()
    PS C:\Windows\system32>

    Monday, June 18, 2012 6:33 PM