none
UNABLE TO START DEBUGGING ON THE WEB SERVER. THE WEB SERVER IS NOT CONFIGURED CORRECTLY

    Question

  • i am using vb2005 to make asp .net pages but when i press F5 i get this error

    Unable to start debugging on the web server. The web server is not configured correctly

    BUT when i use vb2003 to make asp.net pages it works fine.

    please help me ASAP :(

     

     

    Monday, March 05, 2007 7:30 AM

Answers

  • You need to make sure your web.config file contains:
    <compilation debug="true" defaultLanguage="c#" />
    Depending on what your default language is of course.

    Wednesday, September 12, 2007 12:13 PM

All replies

  • I got same problem but I have just got th solution.

    I think this may be helpful to u too.

    This is usually caused because of one or both of the following problems:

    1. The directory the web app resides in has not been registered as a web application.
    2. The correct ASP.NET version has not been set for the web app (note that this cannot be set until 1. has been sorted out).

    To fix problem 1:

    1. Open the IIS admin app.
    2. Right click on your app's directory (/virtual dir) and select Properties.
    3. On the Directory tab, under Application Settings, next to Application Name there will be a 'Create' button - click it.  Once the dir has been registered as a web app then this button will say 'Remove'.
    4. Click Apply (or OK).

    To fix problem 2:

    1. Open the IIS admin app.
    2. Right click on your app's directory (/virtual dir) and select Properties.
    3. Select the ASP.NET tab.
    4. Select the correct ASP.NET version.  Note that this field is disabled if the dir has not been set as an application (see above).
    5. Click Apply (or OK).
    Tuesday, March 13, 2007 6:25 AM
  • hi pathan,

    I also got the same problem when i shifted to .net 2.0 iam tried to overcome this problem through several ways. Even I tried what you described even though i can't run my application it is again & again giving the same error.
    I tried in this manner by command prompt :
    C:/windows/microsoft.net/framework/v.2.0./aspnet_regiis -i
    after this its get installed and the page dislayed as:
    The page cannot be run in debug mode because debugging is not enabled in the web.config file.

    can u give an alternate solution for this .

    Monday, April 09, 2007 11:02 AM
  • You need to make sure your web.config file contains:
    <compilation debug="true" defaultLanguage="c#" />
    Depending on what your default language is of course.

    Wednesday, September 12, 2007 12:13 PM
  • correctly good post reckface

    Tuesday, December 11, 2007 9:06 AM
  • i am also having the same problem.. I couldnt find out any solutions for this problem. But now i got one solution for thias problem. goto inetmgr and right click the virtual directory u will get new task there is an option for permission do the wizard by clicking the next button. After doing this ur problem wiill get resolved. Hope this will help you to do this. if you got some another way pls let me know.

     

    sarithkappu@hotmail.com

    Tuesday, December 18, 2007 9:37 AM
  • I experienced this problem after upsizing a Visual Studio 2003 ASP.NET project to a Visual Studio 2005 project using the built in VS2005 wizard.  After upgrading, attempting to start the application in debug mode from VS2005 failed with the error "Unable to start debugging on the web server.  The web server is not configured correctly."

     

    I found the clue I needed when I chose "Debug, Start without debugging" from Visual Studio 2005.  IE started up and displayed a  "Page Not Found" error.  The URL was http://localhost/MyWebProject/default.aspx.

     

    Thinking about this for a moment...remember Visual Studio 2003 projects lived in the C:\Inetpub\wwwroot directory not in some arbitrary file system directory.  I had practically forgotten this as the project I was trying to work with was an old one that I had copied off of backup into my C:\dev\web directory to begin work on.

     

    So, something about my Solution (.sln) file was still looking for the default.aspx file in the InetPub directory.  Why wasn't it using the built in Visual Studio 2005 web server?

     

    To fix, I right clicked on the PROJECT (the .csproj) in the Solution Explorer in Visual Studio 2005 and chose Properties.  (This is the first icon beneath the Solution 'yourproject' (1 project) in the Solution Explorer pane).  Next, choose the WEB tab of the property display that you will see.  On this page, you will probably see that in the SERVERS section, the radio box "Use IIS Web server" is checked.  Change this to the radio selection "Use Visual Studio Development Server".  Since there is no SAVE button in this property panel for some reason, make sure to push the SAVE button (with the blue disk icon on the toolbar) or File, SAVE to make sure your changes get saved.

     

    After this was completed, the project started normally as expected.

     

     

    Sunday, February 10, 2008 4:35 PM
  •  

    "right clicked on the PROJECT (the .csproj) in the Solution Explorer in Visual Studio 2005 and chose Properties.  (This is the first icon beneath the Solution 'yourproject' (1 project) in the Solution Explorer pane).  Next, choose the WEB tab of the property display that you will see. "  here displays many properties to help me fix the same problem. Thank you.
    Wednesday, March 05, 2008 5:56 AM
  • I tried regitering the 2.0 Framework with IIS and it still didn't solve the Problem. I, later, found that the IIS TCP Port was 2004 instead of 80.  I was able to debug and run my application in VS 2005 by changing the TCP port to 80 by following the below steps.

    1) Click on Start
    2) In Run, type iismgr
    3) Expand the local computer . In most cases, you will only have your computer listed in the tree view.
    4) Expand "Web Sites"
    5) Right click on "Default Web Sites"
    6) Click on Properties
    7) Select "Web Sites" tab
    8) Click on "Advance" button
    9) Change the port number of "Default" to 80

    After this, I was able to run my application without any restart.

    Hope this helps.


    Thursday, November 19, 2009 4:35 PM
  • In my case I had installed IIS after VS.NET.

    It was resolved simply by running the aspnet_regiis -i command

    (I realize there are many circumstances and solutions, but this worked for me.)
    John Bailo
    Tuesday, December 01, 2009 7:34 PM
  • Thanks John. I had installed IIS after installing VS ... followed your procedure.It worded.

     

    Thanks,

    Manu Sharma

    Tuesday, March 30, 2010 6:16 AM
  • Hi

    Solution 1: If it is VS 2005, if you place your project foder under C:\Documents and Settings\USWNMN01\My Documents\Visual Studio 2005\Projects

    then we have to configure by

    Right clicked on the PROJECT (the .csproj) in the Solution Explorer in Visual Studio 2005 and chose Properties.  (This is the first icon beneath the Solution 'yourproject' (1 project) in the Solution Explorer pane).  Next, choose the WEB tab of the property display that you will see.  On this page, you will probably see that in the SERVERS section, the radio box "Use IIS Web server" is checked.  Change this to the radio selection "Use Visual Studio Development Server".  Since there is no SAVE button in this property panel for some reason, make sure to push the SAVE button (with the blue disk icon on the toolbar) or File, SAVE to make sure your changes get saved.

    Solution 2: If the project i under C:\Inetpub\wwwroot

    then Right clicked on the PROJECT (the .csproj) in the Solution Explorer in Visual Studio 2005 and chose Properties.  (This is the first icon beneath the Solution 'yourproject' (1 project) in the Solution Explorer pane).  Next, choose the WEB tab of the property display that you will see.  On this page, you will change the option to the radio box "Use IIS Web server" (in the SERVERS section) .  Since there is no SAVE button in this property panel for some reason, make sure to push the SAVE button (with the blue disk icon on the toolbar) or File, SAVE to make sure your changes get saved.

    Thanks

    Gnanam (agnanasambandham@hotmail.cm)

     


    Thanks Gnanasambandham "Tolerance is the Highest Result of Education".
    Monday, May 10, 2010 5:47 PM
  • Check the mappings in IIS whether it is pointing to correct asp.net version. I got the same problem uninstalled all the asp.net versions from iis and installed only required. it started working. I think the mappings will always point to lastest version of aspnet_isapi.
    Thursday, August 05, 2010 6:06 AM
  • solved my problem. Thumbs up  :)
    Wednesday, December 21, 2011 11:54 AM