none
Can't debug following module was built either with optimizations

    Question

  • Hi all,

    My collegue is getting this message with a project.

    The following module was built either with optimizations enabled or without debug information:

    c:\windows\assembly\GAC_64\DigitaleOpleidingsCatalogus\1.0.0.0_22d4d1e680\digitaleopleidingscatalogus.dll

    To debug this module, change its project build configuration to debug mode. to suppress this message, disable the warn if no user code on launch debugger option.

    We have the same project, the same visual studio debug settings, same web.config. I also deleted all his dll's, cleaned, rebuild copied and gacutilled the new ones still the same issue.

    Friday, June 08, 2012 9:34 AM

Answers

  • Hi Mouseke,

    Thank you for posting in the MSDN forum.

    The following module was built either with optimizations enabled or without debug information:

    c:\windows\assembly\GAC_64\DigitaleOpleidingsCatalogus\1.0.0.0_22d4d1e680\digitaleopleidingscatalogus.dll

    To debug this module, change its project build configuration to debug mode. to suppress this message, disable the warn if no user code on launch debugger option.

    Just to make this issue clearly. Which VS version are you using? Can you try to check it with the following options?

    1. Did you try to change the setting to the debug mode? See here. Then Clean and Rebuild it.
    2. Disable the Just My Code option under Tools -> Options -> Debugging -> Options.
    3. Set the Debug Info to Full, and check this blog.

    It seems that you are running a web app, and if possible, check the following threads with the similar issue.

    VS 2008 says the following module was built either with optimizations enabled or without debug information (but it ain't so).

    If still no help, could you share us this sample, please attach your Visual Studio project, you can upload it to the sky driver, and then share the download link in your post.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Monday, June 11, 2012 7:45 AM

All replies

  • Hi Mouseke,

    Thank you for posting in the MSDN forum.

    The following module was built either with optimizations enabled or without debug information:

    c:\windows\assembly\GAC_64\DigitaleOpleidingsCatalogus\1.0.0.0_22d4d1e680\digitaleopleidingscatalogus.dll

    To debug this module, change its project build configuration to debug mode. to suppress this message, disable the warn if no user code on launch debugger option.

    Just to make this issue clearly. Which VS version are you using? Can you try to check it with the following options?

    1. Did you try to change the setting to the debug mode? See here. Then Clean and Rebuild it.
    2. Disable the Just My Code option under Tools -> Options -> Debugging -> Options.
    3. Set the Debug Info to Full, and check this blog.

    It seems that you are running a web app, and if possible, check the following threads with the similar issue.

    VS 2008 says the following module was built either with optimizations enabled or without debug information (but it ain't so).

    If still no help, could you share us this sample, please attach your Visual Studio project, you can upload it to the sky driver, and then share the download link in your post.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Monday, June 11, 2012 7:45 AM
  • Hi Mouseke,

    I am writing to check the status of the issue on your side. 

    What about this problem now?

    Would you mind letting us know the result of the suggestion?

    Have a nice weekend,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Friday, June 15, 2012 2:39 AM
  • I discovered that this problem occurred after I had just published the web site. I simply rebuilt the entire solution and the problem went away.

    Bob Jones

    Thursday, January 10, 2013 8:45 PM