none
HTTP Error 404.3 - Error when try to browse a svc file

    Question

  •  

    Hi,

     

    I am running Vista 64 with Framework 3.5 SP1 and Visual Studio 2008 SP1 and IIS 7.0 installed and I am new in WCF.

     

    Everything seemed to work OK until I tried to browse http://assetkit/AkServices/Service1.svc.

     

    I have created in the host file an entry like this: 127.0.0.1 assetkit. Created a new website in IIS and published the service, using Visual Studio 2008 to this website.

     

    This is a very simple service, in fact the service is the initial template for a WCF Service Application created by Visual Studio. After creating the WCF Application I have published it the application to IIS 7.0 to test the deployment.

     

    When I try to browse the url above I receive the following error:

     

    Module StaticFileModule
    Notification ExecuteRequestHandler
    Handler StaticFile
    Error Code 0x80070032

    Requested URL http://assetkit:80/AkServices/Service1.svc
    Physical Path C:\inetpub\wwwroot\AssetKit\AkServices\Service1.svc
    Logon Method Anonymous
    Logon User Anonymous

     

    It seemed to me that WCF is not installed because when I looked in the Mime Types list I could not find the svc extension. Some blogs tells me that I must run then command C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation>ServiceModelReg.exe -i but I do not the 3.0 directory and in directory 3.5 the file does not exists.

     

    When I publish the service to a Virtual directory of the default sites I recei the error:

    The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

     

    Other Blogs tels me that the problem can be solved If a create the the mime type svc and add a handler, but I do not know the correct type string.

     

    I do not know if this is a problem of Vista 64 or if the problem is associated with 3.2 SP1 ot VS 2008 SP1. The fact is that I cannot run my service after it is deployed.

     

    Can you help me !!!

     

    Thanks in advance

     

     

    Tuesday, September 09, 2008 12:45 AM

Answers

  • It worked !!!

     

    Go to page http://msdn.microsoft.com/en-us/library/ms732012.aspx and activate the WCF. Look at the first Note:

     

    When the ServiceModel Registration Tool is run on Windows Vista, the Windows Features dialog may not reflect that the Windows Communication Foundation HTTP Activation option under Microsoft .NET Framework 3.0 is turned on. The Windows Features dialog can be accessed by clicking Start, then click Run and then typing OptionalFeatures.

     

    So go to the Windows Features and check in the Microsoft .NET Framework 3.0 the Windows Communication Foundation HTTP Activate and the Windows Communication Foundation non-HTTP Activate.

     

    Thanks anyway

    Tuesday, September 09, 2008 1:08 AM

All replies

  • It worked !!!

     

    Go to page http://msdn.microsoft.com/en-us/library/ms732012.aspx and activate the WCF. Look at the first Note:

     

    When the ServiceModel Registration Tool is run on Windows Vista, the Windows Features dialog may not reflect that the Windows Communication Foundation HTTP Activation option under Microsoft .NET Framework 3.0 is turned on. The Windows Features dialog can be accessed by clicking Start, then click Run and then typing OptionalFeatures.

     

    So go to the Windows Features and check in the Microsoft .NET Framework 3.0 the Windows Communication Foundation HTTP Activate and the Windows Communication Foundation non-HTTP Activate.

     

    Thanks anyway

    Tuesday, September 09, 2008 1:08 AM
  • It's really a great help, I also faced the same problem and ServiceModerlReg.exe was not working for me but when I followed these step....It worked.

    Thanks for such a helpful post.

    Cheers...
    Vinod K Gupta
    Wednesday, June 10, 2009 8:10 AM
  •  I also faced the same problem

    Thanks for the help :)

    • Proposed as answer by rdg4545 Wednesday, September 25, 2013 10:24 AM
    Thursday, October 21, 2010 7:55 AM
  • Thankz a Ton... It really worked... n Continue the good work... much appreciated : )
    Friday, November 19, 2010 7:51 PM