none
Urgent: VS2010 crashed when adding a Ribbon(Visiual Designer)

    Question

  • I created an Excel2010 add-in, but it will crash when i add a Ribbon.

     

    error1

    error2

     

    I repaired the VS2010, but it crashed still.

    My system: Win XP + VS2010 + Office2010

     

    Thanks


    Chinese P-Man
    • Edited by laoyebin Thursday, September 02, 2010 12:49 PM
    Tuesday, August 31, 2010 2:57 PM

All replies

  • VS2010 worked well yesterday, but i installed an add-in called Productivity Power Tools.

    Is it the cause of this error?


    Chinese P-Man
    Tuesday, August 31, 2010 3:29 PM
  • Hi laoyebin

    The best thing to do would be to remove the add-in then see whether that helps.


    Cindy Meister, VSTO/Word MVP
    Tuesday, August 31, 2010 3:39 PM
  • Thanks.

    Yes, i uninstalled it, but vs2010 crashed still.


    Chinese P-Man
    Tuesday, August 31, 2010 4:03 PM
  • Hi laoyebin,

    1.Before you install the "Productivity Power Tools", have you ever built an add-in with Ribbon? In that condition,
    will the VS2010 crashed?

    2. With "Productivity Power Tools", can you successfully build an Excel AddIn without Ribbon?


    Best Regards,
    Amy Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, September 01, 2010 6:44 AM
  • Hi laoyebin,

    1.Before you install the "Productivity Power Tools", have you ever built an add-in with Ribbon? In that condition,
    will the VS2010 crashed?

    2. With "Productivity Power Tools", can you successfully build an Excel AddIn without Ribbon?


    Best Regards,
    Amy Li



     

    I created an Excel AddIn with Ribbon successfully before, but I haven't  added others these days. 

    I found this problem yesterday, so I think if  the "Productivity Power Tools" caused it. But vs2010 still crashed after I uninstalled this addin. 

    So I don't know when this error happened.

     

    By the way, this error only happened when adding a Visiual-Designer Ribbon, XML Ribbon will not.


    Chinese P-Man
    Wednesday, September 01, 2010 7:33 AM
  • Hi laoyebin,

    Then I think the problem maybe is just caused by the "Productivity Power Tools".
    It seems that the product will cause VS crash according to different versions.
    Although you've uninstalled it,  since the tool provides operations with Ribbon Tabs. So maybe
    some settings of VS have been changed, I'm not sure however.
    Here is a link about the product. Maybe you can post your question here to get answers.
    http://blogs.msdn.com/b/visualstudio/archive/2010/07/28/fixes-for-solution-navigator-amp-quick-access-in-the-productivity-power-tools.aspx

    Hope it will be helpful. Thank you!

    Best Regards,
    Amy Li
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, September 01, 2010 9:34 AM
  • I posted there yesterday, but it seems nobody have saw it.

     

    I created a xlsm file, and added a Ribbon, it gave me an error information.

    error3

     


    Chinese P-Man
    Thursday, September 02, 2010 12:53 PM
  • Hi laoyebin,

    Then I think the problem maybe is just caused by the "Productivity Power Tools".
    It seems that the product will cause VS crash according to different versions.
    Although you've uninstalled it,  since the tool provides operations with Ribbon Tabs. So maybe
    some settings of VS have been changed, I'm not sure however.
    Here is a link about the product. Maybe you can post your question here to get answers.
    http://blogs.msdn.com/b/visualstudio/archive/2010/07/28/fixes-for-solution-navigator-amp-quick-access-in-the-productivity-power-tools.aspx

    Hope it will be helpful. Thank you!

    Best Regards,
    Amy Li
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Hi Amy:

           I posted my question there, but I haven't received any response, I think Sean Laberee haven't saw it yet. Could you help me contact him?



    Chinese P-Man
    Sunday, September 05, 2010 1:36 AM
  • I repaired VS2010 again, it show me an error with "object reference not set to an instance of an object" when adding a Ribbon.
    Chinese P-Man
    Sunday, September 05, 2010 11:43 AM
  • Hi laoyebin,

    Sorry, I don't know either since I'm not familiar with the "Productivity Power Tools". Maybe you should reinstall the VS
    to see if it will solve the problem. Hoping other people will have some ideas. Thank you!

    Best Regards,
    Amy Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, September 06, 2010 7:56 AM