none
Visual Studio 2012 RC has stopped wokring

    Question

  • I have installed the VS 2012 RC, 3 days before, it was working fine until yesterday. But from yesterday I am trying to open it and it gives me only one message that., "Microsoft Visual Studio 2012 RC has stopped working", and then it asks me to debug or close the program.

    I have checked the event logs and it logged 2 errors at the time of this event under Administrative Events.

    1.

    Application: devenv.exe

    Framework Version: v4.0.30319

    Description: The process was terminated due to an unhandled exception.

    Exception Info: System.InvalidCastException

    Stack:

       at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<ThrowAsync>b__1(System.Object)

       at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(System.Object)

       at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

       at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()

       at System.Threading.ThreadPoolWorkQueue.Dispatch()

       at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

    2.

    Faulting application name: devenv.exe, version: 11.0.50522.1, time stamp: 0x4fbb0839

    Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e211319

    Exception code: 0xe0434352

    Fault offset: 0x0000b9bc

    Faulting process id: 0x31c

    Faulting application start time: 0x01cd7620a5431947

    Faulting application path: C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\devenv.exe

    Faulting module path: C:\Windows\syswow64\KERNELBASE.dll

    Report Id: e4fad37b-e213-11e1-b459-402cf4da9d6e

    I tried repairing as well as reinstalling it but no luck.

    Could any one please help.

    Thanks


    Thursday, August 09, 2012 11:34 AM

Answers

  • Thanks for your help, Barry. I already tried repairing it. Even I tried removing it completely and re-installed it again from beginning. but nothing worked, it gave me same problem.

    I was frustrated till Friday, because it was not even opening after re-installing it completely. but then I tried uninstalling my Internet Explorer9 which I had installed after my VS 2012 RC installation, and it used to work before that. And I wondered, after removing IE9 it start working without any issue, like it used to work before. That means some problem might be with IE9 and VS 2012 RC compatibility.

    I dont know what exactly the problem with IE9 and VS 2012 RC, but I installed IE8 apart from other non-Microsoft browsers on my machine and it is working fine.

    I hope this issue will be resolved in future releases of VS 2012. 

    Anyway thanks a lot for your post Barry.

    My System Information(Just for information):

    OS: Windows 7 Enterprise Service Pack1

    Processor: Intel Core i7, 2.3 GHz

    RAM: 8GB

    Type: 64 Bit

    Monday, August 13, 2012 7:47 AM

All replies

  • Hi Rahul,

    Thanks for your post.

    Here are some workarounds for you, especially for the extensions:

    1. Try to open your Control panel -> Programs -> Programs and Features, right click Microsoft Visual Studio 2012-> Change -> Repair
    2. Startup failure always means package failed to load or file missed. You can try the following steps to reset Visual Studio:
      1) Win 7:Open Visual Studio Command Prompt (2012) under Start menu -> All Programs -> Microsoft Visual Studio 2012  -> Visual Studio Tools (run it with Administrator privilege: right-click the program -> Run as administrator);
           Win 8:Start>> All Apps>> VS2012 x64 Cross Tools Command Prompt
    2)  Try some devenv switches in command prompt:
          a. Run devenv /Resetsettings to eliminate the cause of corrupted settings.
          b. Run devenv /ResetSkipPkgs in Command Prompt.
          c. Run devenv /Safemode to see if you can apply it correctly. This can eliminate the possibility that third party Add-ins or packages are causing problems.                                                                                  
    3) Switch and try a new user account. This can rule out the possibility of corrupted user profile
    4) Switch your OS to safe mode. Try if you can open Visual Studio. If so, remove all extensions.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Friday, August 10, 2012 4:44 AM
  • Thanks for your help, Barry. I already tried repairing it. Even I tried removing it completely and re-installed it again from beginning. but nothing worked, it gave me same problem.

    I was frustrated till Friday, because it was not even opening after re-installing it completely. but then I tried uninstalling my Internet Explorer9 which I had installed after my VS 2012 RC installation, and it used to work before that. And I wondered, after removing IE9 it start working without any issue, like it used to work before. That means some problem might be with IE9 and VS 2012 RC compatibility.

    I dont know what exactly the problem with IE9 and VS 2012 RC, but I installed IE8 apart from other non-Microsoft browsers on my machine and it is working fine.

    I hope this issue will be resolved in future releases of VS 2012. 

    Anyway thanks a lot for your post Barry.

    My System Information(Just for information):

    OS: Windows 7 Enterprise Service Pack1

    Processor: Intel Core i7, 2.3 GHz

    RAM: 8GB

    Type: 64 Bit

    Monday, August 13, 2012 7:47 AM