none
Using Git - have 2 outgoing commits ready but Push is disabled

    Question

  • I have an active VSOnline repo that I've already pushed a couple commits to. I now have 2 unsynched commits ready to go up but can not get the Push link to activate. Where next?

    Monday, November 25, 2013 1:20 AM

Answers

  • Found the source of the problem but sure didn't see instructions on how to go about solving. Had to manually issue this from the CLI:

    git branch --set-upstream master origin/master

    • Marked as answer by am.steve Tuesday, November 26, 2013 6:48 AM
    Tuesday, November 26, 2013 6:48 AM

All replies

  • Hi Steve,

    I have tried to make changes to my local repo and then committed, the push link is available for me. Can you check if you  connect to team project? Also make sure you commited the changes. You can refer to this page for using git with Visual Studio Online.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, November 25, 2013 9:24 AM
    Moderator
  • Yes, I'm connected. TeamExplorer shows the same repository in bold for both mySite.visualstudio.com and my local  Git Repos.

    Clicking 'Home | Unsynced Commits' show 2 outgoing commits but Push is disabled.

    Monday, November 25, 2013 12:52 PM
  • Found the source of the problem but sure didn't see instructions on how to go about solving. Had to manually issue this from the CLI:

    git branch --set-upstream master origin/master

    • Marked as answer by am.steve Tuesday, November 26, 2013 6:48 AM
    Tuesday, November 26, 2013 6:48 AM
  • You can also use TeamExplorer for this.

    Go to the Branches Tab, either from the home tab or by clicking Manage branches from the branches list popup.

    You will see a list of published and unpublished branches. Right click your branch in that list and choose publish.

    Hope it helps.

    Thursday, December 12, 2013 1:36 AM