none
Why is Visual Studio 2010 so slow?

    Question

  • What is up with Visual Studio 2010.  It is soooo sloooow! (compared to VS 2008!)
    Takes a while to start up. (12 seconds just to start up---old VS 2008 was about 3 & excel 2007 is about 2)
    Intellisense is glacially slow.  (Sometimes I need to close and re-open files because it refreshes faster.)
    Compiling is only slightly slower than VS 2008.

    I am running VS2010 with Windows 7 x64 Ultimate on a Lenovo ThinkPad x61 (4GB ram/SSD)
    Windows experience scores:
    processor 4.9
    memory 4.9
    graphics 4.9
    gaming graphics 3.1
    primary HDD 7.0

    I am mainly using c# and c++.

    I am using a NON BETA version:
    Microsoft Visual Studio 2010
    Version 10.0.30319.1 RTMRel
    Microsoft .NET Framework
    Version 4.0.30319 RTMRel
    Installed Version: Professional
    Saturday, September 04, 2010 11:39 PM

Answers

  • It's Control Panel --> System --> Advanced system settings --> Advanced (tab) --> Performance (group) --> Settings (button) --> choose Adjust for best performance.


    I thought you were talking about a Visual Studio 2010 setting.

    Since VS2008, and all of the other software on the system works optimally, I must conclude that VS2010 is just slow.  The same is true of the Express version. 

    Oh, well.  The sluggish Intellisense is particularly sad.

    • Marked as answer by M-A-S Tuesday, September 14, 2010 2:19 AM
    Tuesday, September 14, 2010 2:19 AM

All replies

  • Hi M-A-S,

    Does devenv.exe /safemode take that long?

    You may use Process Explorer to check what component or resource the devenv.exe (VS IDE process) loads to take such a long time.

    Thanks.


    Figo Fei
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com 


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Proposed as answer by Figo Fei Monday, September 13, 2010 6:12 AM
    • Unproposed as answer by M-A-S Tuesday, September 14, 2010 12:10 AM
    Monday, September 06, 2010 8:49 AM
  • Hi M-A-S,

    I must admit that I also feel that VS2010 is slower than VS2008, but not so slow in my computer.

    You can try with using "optimized for performance" setting for your environment display.

    Hum... and try to compare the performance with and without Antivirus enabled.

     


    Best regards,
    Ferry Meidianto | My Blog

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Proposed as answer by Figo Fei Monday, September 13, 2010 6:12 AM
    • Unproposed as answer by M-A-S Tuesday, September 14, 2010 2:19 AM
    Tuesday, September 07, 2010 12:09 AM
  • Figo,

    Thanks for the suggestion.  Unfortunately, the safemode switch really doesn't decrease the time it takes to load Visual Studio.  The intellisense is also just as slow.

    -----MAS

    Tuesday, September 14, 2010 12:52 AM
  • Ferry,

    I am beginning to think that VS2010 is just slow.  I have another workstation where I just installed the c# version of VS2010 express.  It just takes a long time for this to load and intellisense is just as glacially slow as the regular VS2010.

    I tried it with and without the antivirus enabled.  It seems to have no effect on the execution or loading speed.

    I tried to tweak the optimized for performance" setting for the environment display, but I cannot seem to find it in VS2010.  Would you be able to show me where this is?

    Thanks!

    -----MAS

    • Proposed as answer by Dex Graham Thursday, October 03, 2013 12:08 AM
    Tuesday, September 14, 2010 12:59 AM
  • Ferry,

    I am beginning to think that VS2010 is just slow.  I have another workstation where I just installed the c# version of VS2010 express.  It just takes a long time for this to load and intellisense is just as glacially slow as the regular VS2010.

    I tried it with and without the antivirus enabled.  It seems to have no effect on the execution or loading speed.

    I tried to tweak the optimized for performance" setting for the environment display, but I cannot seem to find it in VS2010.  Would you be able to show me where this is?

    Thanks!

    -----MAS

    Hi MAS,

    It's Control Panel --> System --> Advanced system settings --> Advanced (tab) --> Performance (group) --> Settings (button) --> choose Adjust for best performance.


    Best regards,
    Ferry Meidianto | My Blog

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, September 14, 2010 1:44 AM
  • It's Control Panel --> System --> Advanced system settings --> Advanced (tab) --> Performance (group) --> Settings (button) --> choose Adjust for best performance.


    I thought you were talking about a Visual Studio 2010 setting.

    Since VS2008, and all of the other software on the system works optimally, I must conclude that VS2010 is just slow.  The same is true of the Express version. 

    Oh, well.  The sluggish Intellisense is particularly sad.

    • Marked as answer by M-A-S Tuesday, September 14, 2010 2:19 AM
    Tuesday, September 14, 2010 2:19 AM
  • Hi MAS,

    Have you tried the setting?
    Just FYI, VS2010 was built on top of WPF while the previous versions was on top of Windows Form. So some time lacks of Graphic processing capability can causes (or adds) some slowness.


    Best regards,
    Ferry Meidianto | My Blog

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, September 14, 2010 7:24 AM
  • Ferry,

    Yes, I did try the setting.  It did not change anything that I could notice.  VS2010 still loads slowly, and intellisense is still slow to notice things.

    I have sought out acquaintances of mine that have used both VS2008 and VS2010.  All of them have noticed similar slowness of VS2010 relative to VS2008.

    Regards,

    Mark

    Tuesday, September 21, 2010 11:52 PM
  • I have to agree with MAS.  Very slow compared to 2008.
    Tuesday, September 28, 2010 5:46 PM
  • Visual Studio 2010 runs faster when the Windows Automation API 3.0 is installed: http://support.microsoft.com/kb/981741

    HTH.


    Figo Fei
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com 


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Friday, October 08, 2010 3:34 AM
  • Visual Studio 2010 runs faster when the Windows Automation API 3.0 is installed: http://support.microsoft.com/kb/981741

    HTH.


    It seems M-A-S said M-A-S is using Windows 7 (x64) in the first post. I don't see how Windows Automation API 3.0 would be relevant to Windows 7. Isn't it already included in Windows 7 (http://support.microsoft.com/kb/976779)?

    CMIIW.


    Maximilian Haru Raditya
    Monday, October 11, 2010 12:57 PM
  • Correct, the Windows Automation API 3.0 is already included in Windows 7.  It might be worth checking out the video driver though, even some newer systems have problems.

     

     


    David Berg - MSFT
    Monday, October 11, 2010 8:11 PM
  • Same experience, try each "solution" given above, still so slow.
    I have just installed a  new SSD (OCZ vertex2), reinstall from scratch, 7, vs 2010 (not SP1),  then SDK, and the rockett comes back...

    :)

     

    Saturday, April 02, 2011 3:26 PM
  • Try disabling visual effects inside Visual Studio.

    1) Run Visual Studio 2010

    2) Go to Tools\Options\Environment\General

    3) Uncheck "Automatically adjust visual experience based on client performances" and "Enable rich client visual experience" boxes.

    This should speed up VS a little. I'm not sure if disabling "Use hardware graphics acceleration if available" option will also speed VS, try it.


    • Edited by jmfv Thursday, October 20, 2011 3:05 PM
    Thursday, October 20, 2011 9:35 AM
  • Changing the visual effects in the control panel to "Adjust for best performance" worked like a charm for me.  Additionally, disabling "Use hardware graphics acceleration if available" also gave me a little performance boost.  Probably because I don't have a very good video card.  
    Monday, October 21, 2013 12:53 PM
  • Oh, well.  The sluggish Intellisense is particularly sad.

    OMG (and that is the first time I have EVER used that acronym) is this the understatement of the year.  VS2005 and VS2008 did Intellisense so effortlessly that the only reason it didn't fully move out of my consciousness was that XCode did it so poorly. Who in the heck would EVER choose to make a new version that added functionality at the expense of making a FREQUENT, instant operation take upwards of 20 seconds and often several minutes each time. I can't even FATHOM what feature they felt could be worth that. 

    No. It's not my system. You have thousands of complaints about this on all sorts of systems. VS2008 ran this feature just fine. I have always and quite loudly trounced MS critics with "Well, they definitely go their development system right." and now they've ruined that. I hate having to work in it now, whereas it was a joy before. And that is not an exaggeration on either point. It WAS a joy. Intellisense was like hyperlinking, bouncing file-to-file, quickly absorbing how classes and software were put together. Now I feel like I'm doing the same thing but instead of hyperlinking, I'm looking things up in leather-bound volumes that I look up in a physical card catalog. 

    Tuesday, October 22, 2013 8:24 PM