none
WARNING: People who have BitDefender 2009

    General discussion

  • This is a general warning to anyone who runs BitDefender on the same computer that they run Visual Studio on: You must disable the BitDefender real time scanner for your program to debug correctly!

    I hope either Microsoft or BD can come up with a better fix for this, but for now, there's my warning.
    Thursday, June 11, 2009 5:31 PM

All replies

  • What exactly is the problem you are having? E.g. is debugging not working at all, or is BitDefender throwing a false positive etc.?
    Jonathan Boles - Visual Studio Debugger QA
    Thursday, June 11, 2009 11:14 PM
  • Well, I'm no longer having the problem, but VS would throw an error saying something to the extent of AccessViolation, or something like that, saying the memory may be corrupt. That led me to disabling the real time protection, so then it worked fine. I have now just dumped bit defender for ESET, which works fine.
    Thursday, June 11, 2009 11:34 PM
  • I am searching since around two days for a solution of this problem. I'm using BD 2009 and VS 2008 with the same Debug-Start-AccessViolation. But in my BD it was not necessary to disable the ESET.But the option "Intrusion detection system" (Firewall) must be disabled. So the start problem in VS-Debugging was killed!

    Friday, April 16, 2010 3:41 PM