none
Problem while having VS Ultimate 2010 Installation

    Question

  • My OS is Win7 x 64 Ultimate and i am trying to install VS Ultimate here.

    In the middle of installation , I got some error and the error log like this

    [03/28/12,02:37:24] Microsoft Visual Studio 2010 Ultimate - ENU: [2] ERROR:The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2203. 
    [03/28/12,02:37:24] Microsoft Visual Studio 2010 Ultimate - ENU: [2] ACTION FAILURE:Action ended 2:37:24: InstallInitialize. Return value 3.See MSI log for details.
    [03/28/12,02:37:24] Microsoft Visual Studio 2010 Ultimate - ENU: [2] ACTION FAILURE:Action ended 2:37:24: INSTALL. Return value 3.See MSI log for details.
    [03/28/12,02:37:33] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147023293.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Ultimate - ENU is not installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Web Deployment Tool (x64) was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 - Visual Studio 2010 Tools was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Silverlight was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Silverlight 3 SDK was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Tools for Office Runtime (x64) was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Office Developer Tools (x64) was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Dotfuscator Software Services - Community Edition was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Crystal Reports templates for Visual Studio 2010 was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 SP2 (x86) ENU was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 SP2 (x64) ENU was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Visual Studio 2010 Tools for SQL Server Compact 3.5 SP2 ENU was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Runtime v1.0 (x64) ENU was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Sync Services for ADO.NET v2.0 (x64) ENU was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Services v1.0 (x64) ENU was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework SDK v1.0 (x64) ENU was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates VC 10.0 Designtime (x64) was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Performance Collection Tools (x64) was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 IntelliTrace (x64) was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SQL Publishing Wizard 1.4 was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SQL Server System CLR Types was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SQL Server System CLR Types (x64) was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Management Objects was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Management Objects (x64) was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 Express Service Pack 1 (x64) was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Framework was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Project was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Transact-SQL Language Service was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft SharePoint Developer Tools was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 ADO.NET Entity Framework Tools was not attempted to be installed.
    [03/28/12,02:37:33] VS70pgui: [2] DepCheck indicates Microsoft Help Viewer 1.0 x64 was not attempted to be installed.
    

    could somebody give me a hint , please?

    Tuesday, March 27, 2012 8:20 PM

Answers

  • Hi Brown,

    Welcome to the MSDN forum.

    From your log, I think the problem is related to installation packages, so I recommend you try to redownload ISO file of Visual Studio 2010 Ultimate: http://download.microsoft.com/download/2/4/7/24733615-AA11-42E9-8883-E28CDCA88ED5/X16-42552VS2010UltimTrial1.iso

    The CRC and SHA1 hash values of your downloaded ISO image should match these:

    CRC: 0x8095c67f

    SHA-1: 0x8371f6a8d090063fcc320617e94854374633df3c

    Second, please extract ISO file to your hard disk.

    Third, complete or dismiss Windows Updates before installation (but turn on Windows Update service).

    Then, clean up your “%temp%” folder (Start>>Run>>%temp%).

    Next, check if there are any anti-virus or antispyware applications running. Make sure they are turned off during installation.

    Finally, run the setup file with Administrator privileges: Right-click the installer > Run as administrator.

    If the problem still exists after these steps, could you please collect the fresh logs for me?

    Note: Please attach the link of this post in the mail.

    If you have any other problems, please feel free to let me know.

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Alexander Sun Friday, April 06, 2012 5:58 AM
    Thursday, March 29, 2012 6:39 AM