none
SQL Server 2008 R2 installation error

    Question

  • Hi,

    I am installing Visual Web Developer Express 2010 but I am getting Sql Server 2008 R2 error each time.  This is the summary outlined below.  Anyone can advise please?  Thanks.

     

    Overall summary:
      Final result:                  SQL Server installation failed. To continue, investigate the reason for the failure, correct the problem, uninstall SQL Server, and then rerun SQL Server Setup.
      Exit code (Decimal):           -2068119551
      Exit facility code:            1211
      Exit error code:               1
      Exit message:                  The system cannot find the file specified.  
      Start time:                    2011-11-18 06:47:14
      End time:                      2011-11-18 06:48:06
      Requested action:              Install
      Log with failure:              C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20111118_064601\Detail.txt
      Exception help link:           http%3a%2f%2fgo.microsoft.com%2ffwlink%3fLinkId%3d20476%26ProdName%3dMicrosoft%2bSQL%2bServer%26EvtSrc%3dsetup.rll%26EvtID%3d50000%26ProdVer%3d10.50.1600.1%26EvtType%3d0x2C38BF1F%400xC24842DB
    
    Machine Properties:
      Machine name:                  KALEEM
      Machine processor count:       2
      OS version:                    Windows Vista
      OS service pack:               Service Pack 2
      OS region:                     United Kingdom
      OS language:                   English (United States)
      OS architecture:               x86
      Process architecture:          32 Bit
      OS clustered:                  No
    
    Product features discovered:
      Product              Instance             Instance ID                    Feature                                  Language             Edition              Version         Clustered 
    
    Package properties:
      Description:                   SQL Server Database Services 2008 R2
      ProductName:                   SQL Server 2008 R2
      Type:                          RTM
      Version:                       10
      SPLevel:                       0
      Installation location:         c:\dd20d79a1f6a87dde13fa3edb665\x86\setup\
      Installation edition:          EXPRESS
    
    User Input Settings:
      ACTION:                        Install
      ADDCURRENTUSERASSQLADMIN:      True
      AGTSVCACCOUNT:                 NT AUTHORITY\NETWORK SERVICE
      AGTSVCPASSWORD:                *****
      AGTSVCSTARTUPTYPE:             Disabled
      ASBACKUPDIR:                   Backup
      ASCOLLATION:                   Latin1_General_CI_AS
      ASCONFIGDIR:                   Config
      ASDATADIR:                     Data
      ASDOMAINGROUP:                 <empty>
      ASLOGDIR:                      Log
      ASPROVIDERMSOLAP:              1
      ASSVCACCOUNT:                  <empty>
      ASSVCPASSWORD:                 *****
      ASSVCSTARTUPTYPE:              Automatic
      ASSYSADMINACCOUNTS:            <empty>
      ASTEMPDIR:                     Temp
      BROWSERSVCSTARTUPTYPE:         Disabled
      CONFIGURATIONFILE:             
      CUSOURCE:                      
      ENABLERANU:                    True
      ENU:                           True
      ERRORREPORTING:                False
      FARMACCOUNT:                   <empty>
      FARMADMINPORT:                 0
      FARMPASSWORD:                  *****
      FEATURES:                      SQLENGINE,REPLICATION
      FILESTREAMLEVEL:               0
      FILESTREAMSHARENAME:           <empty>
      FTSVCACCOUNT:                  <empty>
      FTSVCPASSWORD:                 *****
      HELP:                          False
      IACCEPTSQLSERVERLICENSETERMS:  True
      INDICATEPROGRESS:              False
      INSTALLSHAREDDIR:              c:\Program Files\Microsoft SQL Server\
      INSTALLSHAREDWOWDIR:           C:\Program Files\Microsoft SQL Server\
      INSTALLSQLDATADIR:             <empty>
      INSTANCEDIR:                   C:\Program Files\Microsoft SQL Server\
      INSTANCEID:                    SQLEXPRESS
      INSTANCENAME:                  SQLEXPRESS
      ISSVCACCOUNT:                  NT AUTHORITY\NetworkService
      ISSVCPASSWORD:                 *****
      ISSVCSTARTUPTYPE:              Automatic
      NPENABLED:                     0
      PASSPHRASE:                    *****
      PCUSOURCE:                     
      PID:                           *****
      QUIET:                         True
      QUIETSIMPLE:                   False
      ROLE:                          AllFeatures_WithDefaults
      RSINSTALLMODE:                 FilesOnlyMode
      RSSVCACCOUNT:                  NT AUTHORITY\NETWORK SERVICE
      RSSVCPASSWORD:                 *****
      RSSVCSTARTUPTYPE:              Automatic
      SAPWD:                         *****
      SECURITYMODE:                  SQL
      SQLBACKUPDIR:                  <empty>
      SQLCOLLATION:                  Latin1_General_CI_AS
      SQLSVCACCOUNT:                 NT AUTHORITY\Network Service
      SQLSVCPASSWORD:                *****
      SQLSVCSTARTUPTYPE:             Automatic
      SQLSYSADMINACCOUNTS:           <empty>
      SQLTEMPDBDIR:                  <empty>
      SQLTEMPDBLOGDIR:               <empty>
      SQLUSERDBDIR:                  <empty>
      SQLUSERDBLOGDIR:               <empty>
      SQMREPORTING:                  False
      TCPENABLED:                    0
      UIMODE:                        AutoAdvance
      X86:                           False
    
      Configuration file:            C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20111118_064601\ConfigurationFile.ini
    
    Detailed results:
      Feature:                       Database Engine Services
      Status:                        Failed: see logs for details
      MSI status:                    Passed
      Configuration status:          Passed
    
      Feature:                       SQL Server Replication
      Status:                        Failed: see logs for details
      MSI status:                    Passed
      Configuration status:          Passed
    
    Rules with failures:
    
    Global rules:
    
    Scenario specific rules:
    
    Rules report file:               C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20111118_064601\SystemConfigurationCheck_Report.htm
    
    Exception summary:
    The following is an exception stack listing the exceptions in outermost to innermost order
    Inner exceptions are being indented
    
    Exception type: Microsoft.SqlServer.Configuration.Sco.ScoException
        Message: 
            The system cannot find the file specified.
            
        Data: 
          WatsonData = SQLBrowser
          DisableRetry = true
          DisableWatson = true
        Stack: 
            at Microsoft.SqlServer.Configuration.Sco.Service.GetStartAccount()
            at Microsoft.SqlServer.Configuration.SqlBrowser.SqlBrowserPublicConfig.CalculateUserNamePassword()
            at Microsoft.SqlServer.Configuration.SqlBrowser.SqlBrowserPublicConfig.Calculate()
            at Microsoft.SqlServer.Configuration.SetupExtension.FinalCalculateSettingsAction.ExecuteAction(String actionId)
            at Microsoft.SqlServer.Chainer.Infrastructure.Action.Execute(String actionId, TextWriter errorStream)
            at Microsoft.SqlServer.Setup.Chainer.Workflow.ActionInvocation.ExecuteActionHelper(TextWriter statusStream, ISequencedAction actionToRun)
        Inner exception type: System.ComponentModel.Win32Exception
            Message: 
                    The system cannot find the file specified.
                    
            Stack: 
                    at Microsoft.SqlServer.Configuration.Sco.Service.QueryServiceConfig()
                    at Microsoft.SqlServer.Configuration.Sco.Service.GetStartAccount()
    

     

    Friday, November 18, 2011 1:25 PM

Answers

All replies

  • Hi Rainbow_man,

     

    Welcome to the MSDN forum.

     

    First, the Visual Web Developer 2010 just install SQL Server 2008 Express SP1. If you have encountered some problem during the Visual Web Developer 2010 installation, please collect the logs via this tool: http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=12493

    Please run this tool as this order:

    1.      If you install Visual Web Developer 2010 via a web installer, I recommend you download ISO file of Visual Studio Express from: http://www.microsoft.com/visualstudio/en-us/products/2010-editions/express-iso

    2.      Extract the ISO file to your local hard disk.

    3.      Clean up %temp% folder. To do so: Start>>Run>>%temp%.

    4.      Run Setup.exe as administrator. To do so: Right click>>Run as administrator.

    5.      If the installation fails again, please run this tool. The vslogs.cab will be created in %temp% folder.

    6.      Upload vslogs.cab to a public web site like Windows Live SkyDrive or send it to me(v-alsun_at_microsoft_dot_com).

     

    If you want to install SQL Server 2008 R2, I recommend you go to the SQL Server forum for better support.

    SQL Server Setup forum: http://social.msdn.microsoft.com/Forums/en/sqlsetupandupgrade/threads

     

    If you have any other concern, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Monday, November 21, 2011 7:05 AM
  • Hi Alexander,
    Many thanks for your help and advice.  I tried what you outlined but over the weekend, I tried some other stuff and now I am encountering other installation errors.  I uninstalled everything I could relating to .NET, SQL and VS in the Add/Remove Programs.  When I am running the setup from extracted .iso file now, the installer is giving me .NET Framework 4 could not be installed.  Any advice please?  Thanks.
    Monday, November 21, 2011 8:31 AM
  • Hi Rainbow_man,

     

    Could you please collect the log for me via these steps?

    ·         Clean up %temp% folder. To do so: Start>>Run>>Type “%temp%”.

    ·         Run Setup.exe as administrator. To do so: Right click>>Run as administrator.

    ·         Download and run the Log Collection Tool: http://www.microsoft.com/downloads/details.aspx?FamilyID=e0da314f-6216-4a18-bc6b-7d29cf83af20&displaylang=en

    ·         Upload the vslogs.cab file located in %temp% folder to an open website like Windows Live SkyDrive or send it to me (E-mail: v-alsun_at_microsoft_dot_com).

    Note: Please attach the link of this post in the mail.

     

    If you have any other concerns, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Tuesday, November 22, 2011 9:08 AM
  • Hi Alexander,

    Just tried what you mentioned and emailed you the vslogs file via email.  Hope this helps.  Thanks for your concern.

    Tuesday, November 22, 2011 9:57 AM
  • Hi Kaleem,

     

    From your logs:

    [11/22/2011, 13:17:12] Returning IDOK. INSTALLMESSAGE_ERROR [Service '@C:\Windows\Microsoft.NET\Framework\v4.0.30319\WPF\WPFFontCache_v0400.exe,-100' (WPFFontCache_v0400) could not be installed. Verify that you have sufficient privileges to install system services.]

    MSI (s) (C4:BC) [13:17:12:773]: Product: Microsoft .NET Framework 4 Client Profile -- Error 1923. Service '@C:\Windows\Microsoft.NET\Framework\v4.0.30319\WPF\WPFFontCache_v0400.exe,-100' (WPFFontCache_v0400) could not be installed.  Verify that you have sufficient privileges to install system services.

    Error 1923. Service '@C:\Windows\Microsoft.NET\Framework\v4.0.30319\WPF\WPFFontCache_v0400.exe,-100' (WPFFontCache_v0400) could not be installed.  Verify that you have sufficient privileges to install system services.

    MSI (s) (C4:10) [13:15:28:784]: Invoking remote custom action. DLL: C:\Windows\Installer\MSIEA2F.tmp, Entrypoint: SchedSecureObjectsRollback

    Action start 13:15:28: SchedSecureObjectsRollback.

    SchedSecureObjectsRollback:  Failed to store ACL rollback information with error 0x80070424 - continuing

    SchedSecureObjectsRollback:  Failed to store ACL rollback information with error 0x80070424 - continuing

    For the error code 1923, it means “Not all object UUIDs could be exported to the specified entry.”.

    For the error code 0x80070424, it means “The specified service does not exist as an installed service.”.

     

    Based on your logs, you have some problem in installing .NET Framework 4.

     

    I recommend you:

    1.      Start > Control Panel > Administrative Tools > Services

    2.      Scroll down to 'Windows Presentation Foundation Font Cache 4.0.0.0' and then right click and select properties

    3.      In the window then select 'disabled' in the startup type combo

     

    I strongly recommend you create a new account with administrator privileges. Then download .NET Framework 4 from: http://www.microsoft.com/download/en/details.aspx?id=17718

    Next, clean up %temp% folder. Finally, run dotNetFx40_Full_x86_x64.exe as administrator. To do so: Right click>>Run as administrator. Please ensure all the antivirus and antispyware are disabled during the installation.

     

    You can take a look at this page: http://social.msdn.microsoft.com/Forums/en-UK/netfxsetup/thread/8f732849-3923-4e6c-b878-fc3ae8964d2f  

     

    If you have any other concerns, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Wednesday, November 23, 2011 10:23 AM
  • Hi Alexander,

    Many thanks for your reply and help.  I tried what you outlined but it did not work, then I disabled UAC in Vista and the .NET 4 managed to install properly.  I could not disable the 'Windows Presentation Foundation Font Cache 4.0.0.0'  as it gave me the error that some files were missing.  I tried to disable the 3.0.0.0 however but did not make much difference until I disabled the UAC.  

    I ran the setup as Administrator, for the .iso file, although the account am using gets Administrator privileges but now the SQL Server Express R2 SP1 failed to install.  I tried to install the sql server separately but it failed once again and I sent you the log files on email.  Hope you can advise on that?  Thanks so much once again for your help.

    Thursday, November 24, 2011 1:35 AM
  • Hi Kaleem,

     

    Welcome to the MSDN forum.

     

    Which thing did you try to install? SQL Server Express R2 SP1? Or Visual Web Developer 2010 Express?

     

    If you have some trouble in installing SQL Server 2008 Express R2 SP1 or SQL Server 2008 Express R2, I recommend you consult with SQL Server gurus: http://social.msdn.microsoft.com/Forums/en/sqlsetupandupgrade/threads

    NOTE: Visual Web Developer 2010 install SQL Server 2008 Express instead of SQL Server 2008 R2 Express.

     

    From your description, the .NET Framework 4 on your side did not rollback successfully. I recommend you try to uninstall it via command line first: http://blogs.msdn.com/b/astebner/archive/2009/04/16/9553804.aspx

    If you still can find Windows Presentation Foundation Font Cache 4.0.0.0 on Services of Administrative Tools, I recommend you try to uninstall .NET Framework 4 via MsiInv Tool: http://blogs.msdn.com/b/astebner/archive/2005/07/01/using-msiinv-to-gather-information-about-what-is-installed-on-a-computer.aspx

    After that, you can use this to uninstall Windows Presentation Foundation Font Cache 4.0.0.0 Service:

    ·         Open a command window in Administrator mode.

    ·         Type 'sc delete WPFFontCache_v0400'

    "[SC] DeleteService SUCCESS" should be displayed.

     When you refresh the services console, the Font Cache should not appear. If this refresh does not fix the issue, restart the computer.

     

    Then try install .NET Framework again. If the installation fails again, please collect logs via this tool: http://www.microsoft.com/downloads/details.aspx?FamilyID=e0da314f-6216-4a18-bc6b-7d29cf83af20&displaylang=en

     

    If you have any other concerns, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    • Marked as answer by Alexander Sun Tuesday, November 29, 2011 3:17 AM
    Friday, November 25, 2011 10:08 AM
  • Hi Alexander,

    Sorry for not getting back to you sooner but i have not tried the steps you mentioned yet.  Will do it and get back to you asap.  Basically you are saying to un-install .NET and re-install.  So you are suggesting that it's the Font Cache that is causing the error after you went through the log files.  Let me get back to you on this asap.  Thanks for your patience and help.

    Tuesday, November 29, 2011 11:35 PM