none
TF204017: The operation cannot be completed because the user does not have one or more required permissions

    Question

  • Hi

    we have vs 2008 sp1 which connect to tfs 2010.

    today, for m ore security i've created some users which connect to their team projects.

    with new user, i can connect to tfs but my problem is that when i open team project from my local workspace, i'm facing this problem :

    TF204017: The operation cannot be completed because the user (HSERVER\h.vaziri) does not have one or more required permissions (Use) for workspace MYLAPTOP;HSERVER\Administrator.

    The user HSERVER\h.vaziri is member of Project Collection Administrators group, but i don't know why facing this problem. can anybody help me ?

    thanks in advance


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx

    Monday, January 14, 2013 7:39 PM

All replies

  • Hi Hamed,

    What you are trying to do is to try and administer some one elses workspace. i.e. User A trying to access User B's workspace. 

    To Access the workspace of MYLAPTOP;HSERVER\Administrator you must be the owner of the specified or implied workspace or have the global Administer workspaces permission set to Allow.

    Details on how this permission can be set up here http://msdn.microsoft.com/en-us/library/ms252587(VS.100).aspx 

    HTH
    Cheers,

    Tarun


    Please remember to mark the replies as answers if they help.

    Tarun Arora

    Blog: http://geekswithblogs.net/TarunArora  Subscribe in a reader


    Facebook: Visual Studio Bytes

    Videos: ALM Videos

    Monday, January 14, 2013 8:07 PM
  • Thanks Tarun

    but i don't have custom tfs group (in your case, server\tfs users). in my server, i've created new user which member of my server administrators and also is member of tfs project collection administrators.

    do i must create new tfs group and assign it to my user ?

    can u provide some steps which accomplish this task ?

    thanks in advance


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx

    Monday, January 14, 2013 8:57 PM
  • Thanks for getting back on this Hamed. I still suspect this is a permission issue. You do not need to create a new TFS group, but you need to make sure that the user in question has the global workspace permission set to allow. 

    Can I ask you to download http://www.attrice.info/cm/tfs/ Permission Sidekick. 

    This will let u see the exact permission that the new user has 

    Once you have checked the permissions please get back to us. If you have any questions or run into any problems please feel free to reach out to us.


    Please remember to mark the replies as answers if they help.

    Tarun Arora

    Blog: http://geekswithblogs.net/TarunArora  Subscribe in a reader


    Facebook: Visual Studio Bytes

    Videos: ALM Videos

    Monday, January 14, 2013 10:20 PM
  • Thanks for your help.

    i have installed tfs side kicks, in side kicks, my user > source control permissons have all permissons, because as i told in my first post, my user is member of project collection administrators group.

    but in server permissons page, the administer workspaces does not checked. another problem is that when i check this permisson and refresh my user, it beck to unchecked state! how to save changes in side kicks ?


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx

    Tuesday, January 15, 2013 7:36 AM
  • Hi,

    Thanks for your post!

    Can you make the workspace MYLAPTOP;HSERVER\Administrator public so other users can access it?

    Please take a look at the following similar issue:

    http://social.msdn.microsoft.com/Forums/en-US/tfsgeneral/thread/21440b8d-67c4-4aa5-8a1b-3c747ebbb440/

    Hope it helps!

    Best Regards,


    Cathy Kong
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, January 15, 2013 8:43 AM
    Moderator
  • Thanks for reply

    how can i make workspace MyLaptop to public ? (i saw your link before this, but i can't find Permissons in edit workspace dialog because i'm using vs 2008, not vs 2010).

    can u provide me steps to accomplish this task ?

    thanks in advance


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx

    Tuesday, January 15, 2013 9:28 AM
  • Hi Hamed,

    Thanks for your feedback!

    Visual Studio 2008 does not support Public workspaces.

    You need use VS 2010 to connect TFS 2010, you can use the public workspace feature, please refer to:

    http://blogs.msdn.com/b/granth/archive/2009/11/08/tfs2010-public-workspaces.aspx.

    In addition, if you want to connect to TFS 2010 from VS 2008, you need install the following software in the following order:

    1. Team Explorer 2008
    2. VS2008 SP1
    3. Visual Studio Team System 2008 Service Pack 1 Forward Compatibility Update for Team Foundation Server 2010

    Hope it helps!

    Best Regards,


    Cathy Kong
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Thursday, January 17, 2013 6:00 AM
    Moderator
  • Hi Cathy

    i'm already connected to tfs 2010 from vs 2008, but my problem is that in my vs 2008 i can not set my workspace to public!!!!!

    Any help ?


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx

    Friday, January 18, 2013 4:44 PM
  • Hi Hamed,

    Thanks for your feedback!

    Visual Studio 2008 does not support Public workspaces, as I said in my last reply. If you want to use public workspace, you need to use Visual Studio 2010 to connect TFS 2010.

    Best Regards,


    Cathy Kong
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, January 21, 2013 2:23 AM
    Moderator
  • Thanks Cathy

    it's not important to use vs2010 to use public workspace feature, i want just user access to the team project from new userName which assign to he/she. how can i do this in vs2008 (for example, if i need to execute tfs command on the client machine to grant access to workspace to new userName which created in the server, what's that command and steps)?

    Note : we have workgroup computers, not domain!

    Thanks in advance


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx

    Monday, January 21, 2013 4:03 PM
  • Hi Hamed,

    Thanks for your post!

    Based on my understanding, there is no such command line for Visual Studio 2008, you cannot grant another user to access to a workspace, there is no "public workspace" feature in VS 2008. In Visual Studio 2010 or 2012, you can use the following command line:

     tf workspace /collection:http://yourserver:8080/tfs/yourCollection WorkspaceName;domain\CurrentWorkspaceOwner /newowner:domain\NewWorkspaceOwner

    For more information, please refer to

    http://msdn.microsoft.com/en-us/library/y901w7se(v=vs.100).aspx (For Visual Studio 2010)

    http://msdn.microsoft.com/en-us/library/y901w7se(v=vs.90).aspx (For Visual Studio 2008)

    Hope it helps!

    Best Regards,


    Cathy Kong
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, January 22, 2013 6:45 AM
    Moderator
  • Thanks Cathy

    based on your advise, i've used this command in my vs2008 command line :

    tf workspace /collection:http://192.168.2.10:8080/tfs/houshmand mylaptop;hserver\administrator /newowner:hserver\h.vaziri

    but i'm facing this error :

    Unrecognized command option 'collection'.

    what's the problem ?


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx

    Tuesday, January 22, 2013 6:54 PM
  • Hi Hamed,

    Thanks for your feedback!

    This command line is not supported in VS 2008. You can just run this command in VS 2010 or VS 2012.

    In the following blog, there were are few different workarounds that people were using.

    Please refer to the section :Workarounds for TFS2008 in the following link:

    http://blogs.msdn.com/b/granth/archive/2009/11/08/tfs2010-public-workspaces.aspx

    Hope it helps!

    Best Regards,


    Cathy Kong
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, January 23, 2013 1:27 AM
    Moderator
  • Sorry

    but i don't understand what i should to do!!!!!

    can u provide me some steps to accomplish this task ?

    plz give me full steps, it's very emergency!!!

    thanks in advance


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx

    Thursday, January 24, 2013 8:34 AM
  • Hi Hamed, 

    Thanks for your feedback!

    Since this is an emergency issue, I would suggest you to report this issue on our Portal:
      
    http://support.microsoft.com/common/international.aspx?RDPATH=gp;en-us;offerprophone&id=fh%3ben-us%3bofferprophone

    Every feedback submitted will be evaluated carefully by our engineers. If they have some feedback on it, they will let us know their comments further through that portal. This would be helpful to improve Visual Studio products.

    Hope it helps!

    Best Regards,


    Cathy Kong
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, January 24, 2013 9:07 AM
    Moderator
  • Can anybody help me ?

    thanks in advance


    http://www.codeproject.com/KB/codegen/DatabaseHelper.aspx

    Friday, January 25, 2013 7:37 AM