none
TFS Logs

    Question

  • We use TFS 2010. As I see it there is no log files I can go through to troubleshoot issues/problems. I think the logs can be configured. Can you let me know to to set the TFS log up?

    Thanks.

    Friday, December 07, 2012 5:29 PM

All replies

  • Hi itreyger,

    Thank you for your post.

    If some issues happen while using TFS, there are generally three ways to find logs to troubleshoot.

    You can find configuration log in team foundation server administration console.

    You can search more information from internet according to the error code.

    You also can find some information in client machine event viewer.

    Also, you can post your question in forum for help.

    If anything is unclear, please free feel to let me know.

    Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Proposed as answer by outdoorsman711 Wednesday, December 12, 2012 4:19 PM
    Monday, December 10, 2012 1:33 AM
    Moderator
  • Thanks Lily

    I am trying to find out why one of our users can't connect to TFS Production ( he can connect to QA environment with no issues) when using either VS or Browser. He is getting 403 (Forbidden) when tries to connect through IE browser. I have checked user's AD credentials and everything looks the way it should be. BTW, his co-worker with the same AD credentials can log in with no issues. We tried WireShark from his PC to the TFS ul and saw that he is getting unauthorized so is getting through IIS fine but something within application would let him to log in.

    I am out of options now. Oh yes, I've asked him to login to his co-worker's PC and try to connect to TFS. I haven't heard from him yet

    Monday, December 10, 2012 3:07 PM
  • Hi itreyger,

    Can you post a screenshot of the issue that the user cannot connect to TFS?

    What's the version of VS?

    Is there any detail event log relate this issue? Or, can you post the whole log when the user try to connect with TFS?

    Please let us know the result when you get that whether the user can connect with TFS on another's worker's PC.

    Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, December 11, 2012 7:26 AM
    Moderator
  • The problem is that there is no log and that is what I need help with. I need to enable the TFS tracing. I read that it is possible by enabing the TWA switches (TSWA.General, TSWA.UserControl +++ ) in the diagnostics block. The bottom line Lily I need to enable Team Web Access trace. here is what I found and reffering t. But this is for TFS 2011

    http://larzjoakimnilzzon.blogspot.com/2012/04/tracelogging-configuration-in-team.html

    Tuesday, December 11, 2012 3:29 PM
  • Hi itreyger,

    Thank you for your post.

    I am trying to involve someone to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, December 12, 2012 8:26 AM
    Moderator
  • Thanks Lily
    Wednesday, December 12, 2012 3:58 PM
  • Hello,

    There are several articles discuss how to enable TFS tracing at server side or client side:

    http://blogs.msdn.com/b/bryang/archive/2011/11/14/tracing-in-team-foundation-server-2010.aspx

    http://blogs.msdn.com/b/edhintz/archive/2007/03/30/tfs-client-tracing.aspx

    http://blogs.msdn.com/b/roberthorvick/archive/2009/10/27/enabling-tracing-during-tfs-2010-configuration.aspx

    Thanks & Regards,

    Jian-Wei Yu [MSFT]

    Microsoft Online Community Support

    --------------------------------------------------------------------------------

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, December 16, 2012 6:55 AM