none
Lost Keys (Problem deleting chars)

    Question

  • I'm not sure using the right section. If there is a better one, feel free to move this topic.

    Now my Problem:

    I can't delete any chars from my Source using Visual Studio 2006 Professional. I can insert code but i can't delete it. I can't insert a line using ENTER. BSP and DEL doesn't work. Coding without this keys is very... complicated.

    Is there anybody who knows to fix this problem?

    Thanks

    Tuesday, September 05, 2006 2:14 PM

Answers

  • Hello-

    Try this:

    1. Delete the contents of C:\Documents and Settings\<user>\Application Data\Microsoft\VisualStudio\8.0

    2. In VS2005, go to the Tools -> Import and Export settings... menu and Reset all settings.

    Let us know how this works.

    -Luke

    Thursday, September 14, 2006 5:25 PM

All replies

  • There is an other problem.

    I tried to fix the key problem resetting to default settings. While resetting there was an error message: Error importing settings for keyboard.

    I think it is linked with my first problem.

    Wednesday, September 06, 2006 7:19 AM
  • Hello CK - hopefully someone here will be better able to answer your question. Thanks -
    Friday, September 08, 2006 6:58 PM
  • Hello-

    This is an interesting problem.  Could you answer a few questions for me?

    1. What type(s) of files are you editing when you see this behavior? (xml, cpp, cs, etc.)

    2. Do the arrow keys still work when this happens

    3. What is the Visual Studio install root on your machine? (e.g. D:\Program Files\Microsoft Visual Studio 8)

    Thanks,

    Luke

    Monday, September 11, 2006 8:57 PM
  • I have this problem too.
    The type of file doesn't seem to matter. The keys don't work in txt, xml, cs, cpp, h files.
    All keys work except ctrl, arrow, backspace, delete, home insert page up, page down, end, tab. Aren't these are all keys that send an 'extended' key code?

    The install root is E:\Microsoft Visual Studio 8

    greetings
    dalek9
    Wednesday, September 13, 2006 12:34 PM
  • A few people on GameDev.net have had the same problem, as detailed at:

    http://www.gamedev.net/community/forums/topic.asp?topic_id=412033

    The solution they found (with a now-broken link to an MSDN post) was to delete all VS setting files:

    C:\Documents and Settings\<username>\Application Data\Microsoft\VisualStudio\8.0
    C:\Documents and Settings\<username>\Local Settings\Application Data\Microsoft\VisualStudio
    C:\Documents and Settings\<username>\My Documents\Visual Studio 2005\settings

    Wednesday, September 13, 2006 5:04 PM
  • Here the answerto your questions:

     

    1. all files... cs, cpp and also txt files

    2. the arow keys won't work

    3. "C:\Programme\Microsoft Visual Studio 8"

     

    Hope you could help me.

    Thursday, September 14, 2006 2:28 PM
  • If i want to reset all options to defaults these error is displayed:

    Die Einstellungen wurden mit einigen Fehlern zurückgesetzt.

    Fehler 1: Fehler beim Importieren der Einstellungen für "Tastatur".

     

    Thursday, September 14, 2006 2:31 PM
  • Hello-

    Try this:

    1. Delete the contents of C:\Documents and Settings\<user>\Application Data\Microsoft\VisualStudio\8.0

    2. In VS2005, go to the Tools -> Import and Export settings... menu and Reset all settings.

    Let us know how this works.

    -Luke

    Thursday, September 14, 2006 5:25 PM
  • That's the solution!!!

    I'm happy, anything works fine.

    Friday, September 15, 2006 7:04 AM
  • I was turning blue of the effort of getting vs to work: Slightly different problem but one of the solutions here fixed it, but the standard fix did not help.

    problem: Server explorer does not respond to commands to display pages making it impossible to open webpages. And does not respond to backspace ctrl-z and so forth.

    Reson:*blush* Working in a remote environment by file. Internet connection went down at the exact moment as I was opening a page- VS crashes the server explorer plugin and asks if I want to disable the plugin and I stupit as I was said sure-whatever. Let me work... The rest is history.

    FIX:

    It does not help for more than a few seconds to use the fix detailed here BUT removing

    C:\Documents and Settings\<username>\Application Data\Microsoft\VisualStudio\8.0
    C:\Documents and Settings\<username>\Local Settings\Application Data\Microsoft\VisualStudio
    C:\Documents and Settings\<username>\My Documents\Visual Studio 2005\settings

    Helped.

    Friday, October 13, 2006 12:30 PM
  • That solution didn't work for me...

    I had to delete these files AND the registry key HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\8.0

    Thursday, October 19, 2006 7:07 PM
  • I'm having the same problem with Visual Studio 2003.  I'm unable to use the backspace or delete keys in the HTML view of any pages.  I've tried deleting files out of the directories listed in the above post with no success.
    Monday, November 20, 2006 12:40 AM
  • Thanks Luke!

    Deleting the files worked for me.

    I've spent 14 hours today reinstalling VS.NET, XP SP2, keyboard drivers, changed physical keyboard, running in safe mode, exept reinstalling Windows XP to get my arrow keys working...

    Chers! 

    Staffan, Sweden

    Monday, November 20, 2006 9:26 PM