none
The content type text/html of the response message does not match the content type of the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly.

    Question

  • Hi,

    I am getting below error message some times when accessing my wcf service. I am using "streamed mode" with "binaryMessageEncoding".

     

    The content type text/html of the response message does not match the content type of the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. Plz help.

     

    Thanks,

    Siva

    Wednesday, June 01, 2011 7:23 AM

Answers

All replies

  • turn on wcf trace on the server and see the error.

    also turn on wcf logging on the client and see what the content of the html response is - maybe it contains more details.


    http://webservices20.blogspot.com/
    WCF Security, Interoperability And Performance Blog
    Wednesday, June 01, 2011 4:49 PM
  • I enabled tracing and logging but nothing helps. I am getting the issue only when memory usage is very high in my system. After memory usage goes down by little bit I am not getting issue. But as I am using streamed mode it should not result into high memory usage as the data will be transferred as small streams. When I used buffered mode memory is not increasing that muach as it is increasing in streamed mode. Actually streamed mode should take less memory than buffered mode. But in my case its happening reversely. Any idea..

     

    Thanks,

    Siva

    Thursday, June 02, 2011 1:46 PM
  • maybe you handle the stream in an expensive way.

    this sounds like an optimization issue.


    http://webservices20.blogspot.com/
    WCF Security, Interoperability And Performance Blog
    • Marked as answer by Yi-Lun Luo Tuesday, June 07, 2011 9:26 AM
    Friday, June 03, 2011 8:17 PM
  • I am just transferring around 500KB size stream from server to client. So there should be no optimization issue here. The same is working fine if I use bufered mode.

     

    Regards,

    Siva

    Tuesday, June 07, 2011 4:21 PM