none
VS 2008-deployment-launch conditions-link to framework 3.5

    Question

  • Hi,

    I need an advice with the link to framework 3.5 in launch conditions during creating the MSI instalation file.

    There is the link I have there now:

    http://go.microsoft.com/fwlink/?LinkId=76617

    but of course this one leads to the latest version which is currently 4.0

    my application needs version 3.5 in order to run. I thought the versions are compatible and the last one can do what the previous can do but I have information from my customers that it's not true. It doesn't work after instalation the 4.0 version but after they install the 3.5 version it works!

    If I click the link for 3.5 version ont the site it looks like this (I am in Czech republic):

    http://msdn.microsoft.com/cs-cz/netframework/cc378097%28en-us%29.aspx

    but of course I cannot put this link into the aplication, there is the nation code and my application is sold mainly in the States.

    I would like similar link to the previous one which leads to .NET Framework 3.5.

    I hope I described correctly what I need :-)

    Thanks for any answer

    Petr

    • Moved by Roahn Luo Wednesday, June 02, 2010 2:10 AM a more proper forum. (From:Visual Studio Debugger)
    Tuesday, June 01, 2010 8:42 AM

Answers

  • Hi,

    From my experience, the launch condition has a InstallUrl property which can be directly set to the the downloaded URL.

    Let me know if this does not help.
    Aland Li


    Please mark the replies as answers if they help and unmark if they don't. This can be beneficial to other community members reading the thread.
    Monday, June 07, 2010 4:57 PM