none
TFS tries to ignore workspace mapping...

    Question

  • All my projects, instead of being saved to "C:\Users\Administrator\Visual Studio 2010\Projects", are in "E:\Work", which seems to work fine at first, but then TFS, after choosing to ignore my attempt to check some work in, now tries to check work in from "C:\Users\Administrator\Visual Studio 2010\Projects\Project Name..." which doesn't even exist! Why on Earth would it do that and how can I overcome this?
    Monday, June 18, 2012 7:16 AM

Answers

  • Hi John 

    Thanks again for responding so swiftly. Here's a screenshot of the dialog you requested:

    I've since removed the project from source control, and deleted it from TFS, started fresh, and all seems well with the project now... Just a few more to re-bind...

    Thursday, June 28, 2012 2:30 AM

All replies

  • Hi,

    Did you check what settings do you have in File, Source Control, Workspaces ?


    Daniel

    Monday, June 18, 2012 10:23 AM
  • Hi Tristan, 

    Thanks for your post.

    In Source Control Explorer, click File>>Source Control>>Workspace…, in the Manage Workspace dialog, selected your workspace and click Edit…, check your Working folders in the Edit Workspace dialog.

    We can add, remove or change working folder mappings, please refer to this MSDN document: http://msdn.microsoft.com/en-us/library/gg490753.aspx.   


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, June 19, 2012 2:25 AM
    Moderator
  • Hi John,

    Thanks for the reply. I have however, already checked in  File>>Source Control>>Workspace…  and the mappings are correct. I have even tried to re-instate the mappings, using the link you provided. Never-the-less, when I use the drop-down menu in the Solution Explorer for (some) correctly mapped source-controlled solutions, none of the TFS options are available. Also, the change status icons that appear beside each file in the Solution Explorer are not present. Is there perhaps something fundamentally wrong with our TFS installation, or a missing hotfix for Visual Studio?

    Friday, June 22, 2012 2:30 AM
  • I certainly have, and all is well and correct there. It is indeed a quandary. 
    Friday, June 22, 2012 2:31 AM
  • Hi Tristan,

    Thanks for your reply.

    Which TFS options are not available in Manage Workspace dialog?  Could you share some screenshots here, it may help us to provide the better response.  


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us


    Friday, June 22, 2012 7:05 AM
    Moderator
  • Hi John 

    Thanks again for responding so swiftly. Here's a screenshot of the dialog you requested:

    I've since removed the project from source control, and deleted it from TFS, started fresh, and all seems well with the project now... Just a few more to re-bind...

    Thursday, June 28, 2012 2:30 AM