none
Application Download Error(An exception occurred while downloading the manifest.) in XBAP application

    Question

  • Hi

    My Name is Lakshmi,

    I have Xbap Application and it is running fine in local system,and i published it and placed build files(setup files) in one of the folders on server system.

    The application is also running fine from the specified folder,but it is not running from the IIS server when it is hosted in IIS.

    The following error log file is displayed when the url accessed from the IIS:-
    ======================================================

    PLATFORM VERSION INFO
     Windows    : 5.1.2600.196608 (Win32NT)
     Common Language Runtime  : 2.0.50727.832
     System.Deployment.dll   : 2.0.50727.832 (QFE.050727-8300)
     mscorwks.dll    : 2.0.50727.832 (QFE.050727-8300)
     dfshim.dll    : 2.0.50727.42 (RTM.050727-4200)

    SOURCES
     Deployment url   : http://nonidet/timetracker/timetracker.xbap

    ERROR SUMMARY
     Below is a summary of the errors, details of these errors are listed later in the log.
     * An exception occurred while downloading the manifest. Following failure messages were detected:
      + Downloading http://cosmid/TimeTracker/TimeTracker.application did not succeed.
      + The remote server returned an error: (404) Not Found.

    COMPONENT STORE TRANSACTION FAILURE SUMMARY
     No transaction error was detected.

    WARNINGS
     There were no warnings during this operation.

    OPERATION PROGRESS STATUS
     No phase information is available.

    ERROR DETAILS
     Following errors were detected during this operation.
     * [10/3/2008 6:50:12 PM] System.Deployment.Application.DeploymentDownloadException (Unknown subtype)
      - Downloading http://cosmid/TimeTracker/TimeTracker.application did not succeed.
      - Source: System.Deployment
      - Stack trace:
       at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
       at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
       at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState)
       at System.Deployment.Application.DownloadManager.DownloadManifestAsRawFile(Uri& sourceUri, String targetPath, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
       at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestDirect(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
       at System.Deployment.Application.DownloadManager.FollowDeploymentProviderUri(SubscriptionStore subStore, AssemblyManifest& deployment, Uri& sourceUri, TempFile& tempFile, IDownloadNotification notification, DownloadOptions options)
       at System.Deployment.Application.DownloadManager.DownloadDeploymentManifest(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, IDownloadNotification notification, DownloadOptions options)
       at System.Deployment.Application.DeploymentManager.BindCore(Boolean blocking, TempFile& tempDeploy, TempDirectory& tempAppDir, FileStream& refTransaction, String& productName)
       at System.Deployment.Application.DeploymentManager.BindAsyncWorker()
      --- Inner Exception ---
      System.Net.WebException
      - The remote server returned an error: (404) Not Found.
      - Source: System
      - Stack trace:
       at System.Net.HttpWebRequest.GetResponse()
       at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)

    COMPONENT STORE TRANSACTION DETAILS
     No transaction information is available.


    Cosmid is my local system.
    Nonidet is the server system.

    I dont Know how to solve the problem,i m not able to solve it,any suggestions would be of great help to me.

    Thank you
    SriLakshmi.

    Friday, October 03, 2008 1:28 PM

Answers

  • May not be a solution or I might be missing something, but here is my 1 cent.

    Try setting the mime types on IIS.

    The error says 404 Not Found. So IIS as such is not able to locate your XBAP. Trying using Publish wizard in VS or an installer to deploy the app.
    • Marked as answer by Marco Zhou Friday, October 10, 2008 10:36 AM
    • Marked as answer by Marco Zhou Friday, October 10, 2008 10:36 AM
    Friday, October 03, 2008 2:47 PM