none
Lightswitch 2012 doesn't support .NET Framework 4.5

    General discussion

  • Unfortunately the latest version of Lightswitch (2012) doesn't support .NET Framework 4.5. That's why it's impossible to add a WCF RIA Service data source that uses Entity Framework 5 to Lightswitch application.
    Saturday, August 25, 2012 9:50 PM

All replies

  • It is actually a good thing that LightSwitch only requires ASP.NET 4.0 and not ASP.NET 4.5 because you would have to have to install ASP.NET 4.5 on the server to make it work. A lot of businesses are always one version behind so this would be a show stopper.

    For now we have to use WCF RIA Services that use ASP.NET 4.0.


    The Visual Studio LightSwitch Marketplace

    http://LightSwitchHelpWebsite.com

    Saturday, August 25, 2012 10:05 PM
  • Thank you Michael for your opinion. But I think it's difficult to predict when the potential customers will migrate to 4.5 and even more whether they all will migrate to the new version. That's why I think it would be much better if Lightswitch (like other Visual Studio projects) supports more than one target version of .NET Framework for it's server code.
    Monday, August 27, 2012 6:31 AM
  • Agree 100% with mitkodi.  I have a great portable lib running on .NET 4.5 that I now cannot use in LS!


    DGL

    Thursday, August 30, 2012 11:41 AM
  • Hi all,

    This issue has been logged as a request on the Visual Studio User Voice website here. Go vote to get this escalated.

    Cheers!

    Thursday, October 25, 2012 12:28 AM
  • Voted +3

    Yann - LightSwitch Central - Click here for FREE Themes, Controls, Types and Commands
     
    If you find a reply helpful, please click "Vote as Helpful", if a reply answers your question, please click "Mark as Answer"
     
    By doing this you'll help people find answers faster.

    Thursday, October 25, 2012 1:02 AM
    Moderator