none
A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider.

    Question

  • Got this error while installing Visual Studio 2012 Ultimate on Win7.  The message and the log indicate the problem occurred installing WebDeploy 3.0.

      A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider.

    [1250:0FF4][2012-08-16T11:39:54]: Acquiring package: webdeploy_x64_en_usmsi_902, payload: webdeploy_x64_en_usmsi_902, copy from: E:\packages\WebDeploy\WebDeploy_x64.msi
    [0898:211C][2012-08-16T11:39:54]: Error 0x800b0109: Failed to verify certificate chain policy status.
    [0898:211C][2012-08-16T11:39:54]: Error 0x800b0109: Failed to get certificate chain for authenticode certificate.
    [0898:211C][2012-08-16T11:39:54]: Error 0x800b0109: Failed to verify signature of payload: webdeploy_x64_en_usmsi_902
    [0898:211C][2012-08-16T11:39:54]: Failed to verify payload: webdeploy_x64_en_usmsi_902 at path: C:\ProgramData\Package Cache\.unverified\webdeploy_x64_en_usmsi_902, error: 0x800b0109. Deleting file.
    [0898:211C][2012-08-16T11:39:54]: Error 0x800b0109: Failed to cache payload: webdeploy_x64_en_usmsi_902

    Any suggestions?


    • Edited by Dale2K9 Thursday, August 16, 2012 5:29 PM
    Thursday, August 16, 2012 5:28 PM

Answers

All replies

  • I got the same error.

    All I did was go to the setup media, packages folder, WebDeploy folder, and installed the x64 version by hand.

    Works fine.

    • Marked as answer by Dale2K9 Friday, August 17, 2012 5:12 PM
    Thursday, August 16, 2012 9:21 PM
  • hmmm..thnx..i hav got it already....i hav another pro....how can i call parent form function in child form in mdi environment?
    Thursday, August 16, 2012 9:40 PM
  • I'm in the process of getting a KB article up about this. The resolution is to install the root certificate update from http://support.microsoft.com/kb/931125 and repair the installation.

    - Heath @ http://blogs.msdn.com/heaths; Visual Studio Professional Deployment

    Thursday, August 16, 2012 11:07 PM
  • I've posted more information in a preview KB article at http://bit.ly/P48jDF.

    - Heath @ http://blogs.msdn.com/heaths; Visual Studio Professional Deployment

    • Marked as answer by Dale2K9 Friday, October 26, 2012 4:32 PM
    Saturday, August 18, 2012 1:43 AM
  • I had to use "Modify" not "Repair" because the failed web development feature and many others (originally queued for install after it) were not installed in the first place.

    Here is a direct download link to the root update tool from MS:

    http://download.microsoft.com/download/3/A/4/3A423151-FEAB-43FB-902D-679023BF159F/rootsupd.exe

    It doesn't show any dialogs or success message. Just run it then wait 30 seconds.


    Key Artefacts

    • Marked as answer by Dale2K9 Thursday, September 13, 2012 7:14 PM
    Wednesday, September 12, 2012 12:28 PM
  • My fix was to download the complete ISO installation rather than the web installer (web installer gave me errors).  Once I did that, I unzipped the ISO to a folder (rather than running the setup from the zip directly - which will still get this error) and then I was able to install with no errors.  Hope this helps someone out there!  Download, unzip, install.
    • Edited by dehlers Tuesday, October 15, 2013 6:46 PM typo
    Tuesday, October 15, 2013 6:45 PM