none
Getting a TF14098 error (user needs read permissions) when my user is an administrator and the owner of the TFS project

    Question

  • Getting TF14098 error (user needs read permissions) when trying to move a branch/folder. My user is an administrator and the owner of the TFS project.

    The folder is actually a branch that I am attempting to move to a sub folder called archivedBranches at the same level e.g. Move Dev\BranchA to Dev\ArchivedBranches\BranchA. I have done this successfully for four other branches but this one gives the above error. I am able to do a get latest (overwite all files) on the folder without any issues.

    Using TFS 2008 SP1 with Visual Studio 2008 SP1.

    Does anybody have any ideas what might be going wrong?
    • Moved by Bill.Wang Monday, April 27, 2009 5:38 AM Move to the correct forum. (From:Team Foundation Server - Administration)
    Sunday, April 26, 2009 11:25 PM

All replies

  • I'm moving this thread to the Version Control forum.


    To narrow down the cause of this issue, I got a few questions:

    1. Did you branch via VS IDE or “tf branch” command.
    2. Did you get the TF14098 for items under the node Dev\BranchA or Dev\ArchivedBranches\BranchA?
    3. Do you mean your user account belongs to the Project Administrators group in the team project?
    4. Is the any recent error message logged in the Windows Event log of the TFS server?

    Here are 2 possible cause of this issue I currently can think of:

    • There’s a stored credential on your computer. When Team Explorer connects to TFS, it uses the stored credential rather than your current windows account.
    • If your account belongs to the Project Administrators group, permission settings for source control items for Project Administrators override other groups. When Read permission for Project Administrators group is set to Denied, then you will experience this issue. Please refer to Team Foundation Server Permissions for more information .

    We can check the following things:

    1. Clear the stored credential for TFS server on your local computer. You can do this via Control Panel->User Accounts->Manage your network passwords.
    2. Ask a TFS server administrator to run tf permission command for the folder that the error message indicates you don’t have read permission. For example: tf permission /server:http://TFS:8080 “$/TeamProject/Node”. Does any group your account belongs to are denied the Read permission?

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.
    Monday, April 27, 2009 5:38 AM
  • Hi Bill, thanks for your response and sorry for posting in the wrong forum.


    First an answer to your questions:

    1. Did you branch via VS IDE or “tf branch” command.  Via the IDE
    2. Did you get the TF14098 for items under the node Dev\BranchA or Dev\ArchivedBranches\BranchA? Says it needs read permissions for Dev\BranchA /*
    3. Do you mean your user account belongs to the Project Administrators group in the team project? Yes.
    4. Is the any recent error message logged in the Windows Event log of the TFS server? No


    As far as I can tell I don't have any stored credentials for TFS on my local machine so I don't think it is this. Also remember that I can actually read the files in the folder and sub folders it only complains when I try to do the move command (doing this in the IDE). I have run the tf permission command and it confirms that all of the groups have at least read access and none of them have Deny set for any privilege.

    Thanks for your help

    Monday, April 27, 2009 8:42 PM
  • Hi Andrew

    If that is the case, I think we can turn on the verbose tracing for version control to get more information. For how to turn on TFS tracing, please refer to Enabling Trace for Team Foundation Server Components. You may follow the below steps:

    1. Configure the TFS trace output folder as described in How to: Change the Trace Output Directory for Team Foundation Server Components.
    2. Open the Source Control Explorer in Visual Studio.
    3. Query http://TfsServer:8080/VersionControl/tftrace.aspx?traceWriter=true&All=4 in IE to turn on tracing.
    4. Try a Get latestet on Dev\BranchA
    5. Try creating a branch of Dev\BranchA
    6. Query http://TfsServer:8080/VersionControl/tftrace.aspx?traceWriter=false&All=4 in IE to turn off tracing.
    7. Find the trace file.

    After the trace file is generated, you can either analysis it yourself or mail it to me. My email is v-bilw@online.microsoft.com (remove "online."). I will let you know what I can find in the trace file.

     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.
    Tuesday, April 28, 2009 6:36 AM
  • Thanks Bill,

    The lines in the log which seems most likely to indicate the root of the problem are:

    [VC] [Verbose, PID 46920, TID 49488, 20:44:40.226] HasItemPermission(GALLAGHER1\AndrewS, PendChange, $/CardaxFT/FTDev/Controller6000) returns True

    [VC] [Verbose, PID 46920, TID 49488, 20:44:40.226] HasItemPermission(GALLAGHER1\AndrewS, PendChange, $/CardaxFT/FTDev/ArchivedBranches/Controller6000) returns True

    [VC] [Verbose, PID 46920, TID 49488, 20:44:40.226] HasItemPermissionForAllChildren(GALLAGHER1\AndrewS, Read, $/CardaxFT/FTDev/Controller6000) returns False

    Is there an easy way to find which sub directory is causing this problem? I'm still confused because I seem to be able to do a get latest version and retrieve everything but the move gives this error. There are hundreds of sub-directories so any easy way to check would be appreciated.

    Thanks again.

    Tuesday, April 28, 2009 8:53 PM
  • The trace log indicates your account actually don't have read permission at $/CardaxFT/FTDev/Controller6000.

    In your previous reply, you mentioned all the groups your account belongs to don't deny the read permission explicitly. Could you try add the Read permission for your account explicitly? I think this issue is related to permission settings.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.
    Wednesday, April 29, 2009 5:07 AM
  • I definitely have read permissions at $/CardaxFT/FTDev/Controller6000 according to TFS. I am a member of the Project Administrators group which has Allow ticked for all the source control permissions. Also, as stated before if I wipe out my local folder structure I am able to do a getLatest (overwrite) on the entire folder structure with no problems. Surely if I didn't have read permissions I wouldn't be able to do this?

    Wednesday, April 29, 2009 8:13 PM
  • The documentation at the link you provided have versions for only 2005 and 2008.

    Will those steps work with TFS 2010?

    If not, how can a accomplish the task of troubleshooting version control permission issues?


    Alfred Myers | MVP Visual Developer - Visual C# | http://alfredmyers.spaces.live.com | http://twitter.com/AlfredMyers
    Monday, July 18, 2011 6:53 PM