none
Cannot install .Net Framework 3.5 SP1 on Server 2008 x64

    Question

  • HI, all

    when I tried to install 3.5 sp1, I was told that the installation failed. following is the log

    Could any one help me out?

    Thanks,
    Terry T. Wang
    -------------------------------------------------------------------------------------------------------------------------
    [09/18/08,05:16:16] Microsoft .NET Framework 3.5 (x64) 'package': [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [09/18/08,05:16:16] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [09/18/08,05:16:16] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [09/18/08,05:16:16] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [09/18/08,05:16:16] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [09/18/08,05:16:16] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [09/18/08,05:16:16] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [09/18/08,05:16:16] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [09/18/08,05:16:17] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 (x64) 'package' is not installed.
    [09/18/08,05:21:10] Microsoft .NET Framework 2.0SP1 (x64) (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (x64) (CBS). MSI returned error code -2146762496
    [09/18/08,05:21:32] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (x64) (CBS) is not installed.
    [09/18/08,05:39:38] Microsoft .NET Framework 2.0SP1 (x64) (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (x64) (CBS). MSI returned error code -2146762496
    [09/18/08,05:39:56] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (x64) (CBS) is not installed.


    IIS Configuration
    • Moved by nobugzMVP, Moderator Thursday, September 18, 2008 9:28 PM Setup issue (Moved from 64-Bit .NET Framework Development. to .NET Framework Setup)
    Thursday, September 18, 2008 1:54 PM

Answers

  •  

    Hi, Terry,

           In the log information you offered, I found some valuable message here:

    [09/18/08,05:21:10] Microsoft .NET Framework 2.0SP1 (x64) (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (x64) (CBS). MSI returned error code -2146762496

           You know, error code -214676246, 0x800b0100 in hex, actually means “No signature was present in the subject.”   My suggestion: Please check your Windows Installer version, and update to the latest version if necessary, then have another try.   You could easily get Windows Installer 4.5 (Latest Version) here.

           Or, if the problem still exists, would you please use this collection utility to get the whole setup and error log to us?  Upload the file %TEMP%\vslogs.cab to some server and offer us the URL.   You could easily sign up for 5GB free space at http://skydrive.live.com only with your Live Passport.

     

            Any other questions, just let me know please.

     

            Thanks,

     

    Best Regards,

    Lingzhi


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/csharpide/thread/8e9ed0d7-11ff-402a-8489-9b5f05eeb706 http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    Monday, September 22, 2008 2:32 AM

All replies

  •  

    Hi, Terry,

           In the log information you offered, I found some valuable message here:

    [09/18/08,05:21:10] Microsoft .NET Framework 2.0SP1 (x64) (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (x64) (CBS). MSI returned error code -2146762496

           You know, error code -214676246, 0x800b0100 in hex, actually means “No signature was present in the subject.”   My suggestion: Please check your Windows Installer version, and update to the latest version if necessary, then have another try.   You could easily get Windows Installer 4.5 (Latest Version) here.

           Or, if the problem still exists, would you please use this collection utility to get the whole setup and error log to us?  Upload the file %TEMP%\vslogs.cab to some server and offer us the URL.   You could easily sign up for 5GB free space at http://skydrive.live.com only with your Live Passport.

     

            Any other questions, just let me know please.

     

            Thanks,

     

    Best Regards,

    Lingzhi


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/csharpide/thread/8e9ed0d7-11ff-402a-8489-9b5f05eeb706 http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    Monday, September 22, 2008 2:32 AM
  • I have the same problem, unable to install .NET 3.5 SP1.

    FRom dd?dotnetfx35error.txt
    [01/19/09,14:05:17] Microsoft .NET Framework 2.0SP1 (x64) (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (x64) (CBS). MSI returned error code -2146762496
    [01/19/09,14:05:19] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (x64) (CBS) is not installed.
    [01/19/09,22:51:10] Microsoft .NET Framework 2.0SP1 (x64) (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (x64) (CBS). MSI returned error code -2146762496
    [01/19/09,22:51:13] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (x64) (CBS) is not installed.

    vslog.cab can be downloaded from http://kark.hin.no/~kc/vslog.zip

    Could you have a look ?

    Regards,
    Knut

    Wednesday, January 21, 2009 3:04 PM
  • Hello,

    Same problem.. very frustrating!

    -Trying to install 3.5 SP1 on a Windows Server 2008 machine build. I've tried this from the SQL 2008 installer and the standalone re-distribution. (dotnetfx35setup.exe)
    I get this error from the log: 

        [03/19/09,13:42:00] Microsoft .NET Framework 3.0SP1 (x64) (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 3.0SP1 (x64) (CBS). MSI returned
        error code -2146762496
        [03/19/09,13:42:01] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0SP1 (x64) (CBS) is not installed.

        Here's the problm signature:
         Problem signature:
          
    Problem Event Name: VisualStudio8Setup
         Problem Signature 01: 35101
         Problem Signature 02: 3.5.30729.01_ORCAS_X86_NET
         Problem Signature 03: CBS
         Problem Signature 04: INST
         Problem Signature 05: F
         Problem Signature 06: gencomp753,{61040379-156d-4ece-b126-ea395a3b2
         Problem Signature 07: BASERET_UNKNOWN
         Probm Signature 08: -
         Problem Signature 09: -2146762496
         Problem Signature 10: WUSA
         OS Version: 6.0.6001.2.1.0.274.38
         Locale ID: 1033


    -I have the updated Windows Installer 4.5

    Here's a link to my collection utility file:
    http://www.hotbottleamps.com/net/vslogs.cab

    thanks for your help!!!
    Jeff
    Thursday, March 19, 2009 6:13 PM
  •  

    Hello,

    If you have new question to ask in MSDN Forums, please create a new thread to describe the issue, so that your will receive more help.  Meanwhile, it is also MSDN Forum’s policy.

     

    Best Regards,
    LIngzhi


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, March 20, 2009 7:55 AM