none
MVC4 deployment on IIS 7

    Question

  • Hello All, 

    We are facing problem while trying to deploy MVC 4 application on IIS 7 , if anyone has experienced the same, would you please share the solution with me?

    Thanks a lot in advance.


     


    Thanks Arindam Chakraborty .Net Designer & Developer. Mumbai, India. http://etgconsultancy.com

    Friday, May 17, 2013 9:07 AM

Answers

  • add <modules runAllManagedModulesForAllRequests="true" /> in web.config.

    Wow! that is so annoying, are you retarded? you really think that this will solve the OP problem? he wrote that he has problems deploying the application on IIS and this has nothing to do with it! you can't just post something and write nothing at all.

    No one should ever turn this to true unless he's debugging and I suspect that the problem is actually the application pool.

    @OP, you should post IIS issues at forums.iis.net and if you want to be taken seriously elaborate on your environment and configuration as well as the things you already tried to do, you can't expect people to guess everything.


    Regards,

    Eyal Shilony

    Friday, May 17, 2013 9:49 AM
    Moderator

All replies

  • add <modules runAllManagedModulesForAllRequests="true" /> in web.config.
    Friday, May 17, 2013 9:27 AM
  • add <modules runAllManagedModulesForAllRequests="true" /> in web.config.

    Wow! that is so annoying, are you retarded? you really think that this will solve the OP problem? he wrote that he has problems deploying the application on IIS and this has nothing to do with it! you can't just post something and write nothing at all.

    No one should ever turn this to true unless he's debugging and I suspect that the problem is actually the application pool.

    @OP, you should post IIS issues at forums.iis.net and if you want to be taken seriously elaborate on your environment and configuration as well as the things you already tried to do, you can't expect people to guess everything.


    Regards,

    Eyal Shilony

    Friday, May 17, 2013 9:49 AM
    Moderator
  • first check the configured .net framework, I think MVC 4 works with .net 4.5.

    Faisal Ahmed Farooqui —————————— If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".

    Friday, May 17, 2013 10:33 AM