none
VS 2010 Premium Setup fails - "CMsiComponent::Install() expects the setup file for Microsoft Application Error Reporting, but the file failed verification"

    Question

  • Attempting to install VS 2010 Premium on Windows XP 64-bit.  Setup fails on the first step, "Microsoft Application Error Reporting".  I've downloaded once via Akamai and once via Chrome to rule out download corruption - no luck.  ISO is mounted with Elaborate Bytes Virtual CloneDrive.

    Install log:

    [04/13/10,19:17:11] Setup.exe: CSetupManager::AutomaticUpdatePause() Pausing Automatic Updates...
    
    [04/13/10,19:17:11] Setup.exe: CSetupManager::AutomaticUpdatePause() succeeded.
    
    [04/13/10,19:17:11] Microsoft Application Error Reporting: ISetupManager::GetGlobalCustomProperty() failed to find global prop in CBaseComponent::GetGlobalCustomProperty()
    
    [04/13/10,19:17:11] Setup.exe: GetGlobalCustomProperty - Property: {BBE1827C-F2FD-4FDA-A6D6-C83B62FFFDCA} - PropertyName: compfailed - Value: 0
    
    [04/13/10,19:17:11] Microsoft Application Error Reporting: CMsiComponent::Install(): Validating files.
    
    [04/13/10,19:17:11] Setup.exe: GetGlobalCustomProperty - Property: {E0875D42-A33D-4C64-81C9-167795F29CA4} - PropertyName: PathFromCartmanToRoot - Value: ..
    
    [04/13/10,19:17:11] Microsoft Application Error Reporting: File failed validation: e:\setup\..\wcu\watson\dw20shared.msi; error = 0x80091007
    
    [04/13/10,19:17:11] Microsoft Application Error Reporting: CMsiComponent::Install(): Sleeping before reattempting validation.
    
    [04/13/10,19:17:16] Microsoft Application Error Reporting: CMsiComponent::Install(): Reattempting to validate files.
    
    [04/13/10,19:17:16] Setup.exe: GetGlobalCustomProperty - Property: {E0875D42-A33D-4C64-81C9-167795F29CA4} - PropertyName: PathFromCartmanToRoot - Value: ..
    
    [04/13/10,19:17:16] Microsoft Application Error Reporting: File failed validation: e:\setup\..\wcu\watson\dw20shared.msi; error = 0x80091007
    
    [04/13/10,19:17:16] Microsoft Application Error Reporting: CMsiComponent::Install(): Sleeping before reattempting validation.
    
    [04/13/10,19:17:21] Microsoft Application Error Reporting: CMsiComponent::Install(): Reattempting to validate files.
    
    [04/13/10,19:17:21] Setup.exe: GetGlobalCustomProperty - Property: {E0875D42-A33D-4C64-81C9-167795F29CA4} - PropertyName: PathFromCartmanToRoot - Value: ..
    
    [04/13/10,19:17:21] Microsoft Application Error Reporting: File failed validation: e:\setup\..\wcu\watson\dw20shared.msi; error = 0x80091007
    
    [04/13/10,19:17:21] Setup.exe: AddGlobalCustomProperty
    
    [04/13/10,19:17:21] Microsoft Application Error Reporting: ***ERRORLOG EVENT*** : CMsiComponent::Install() expects the setup file for Microsoft Application Error Reporting, but the file failed verification.
    
    [04/13/10,19:17:21] Setup.exe: GetGlobalCustomProperty - Property: {BBE1827C-F2FD-4FDA-A6D6-C83B62FFFDCA} - PropertyName: compfailed - Value: 0
    
    [04/13/10,19:17:21] Microsoft Application Error Reporting: CBaseComponent::LaunchWatson() - Obtained CSetupWatson instance
    
    [04/13/10,19:17:21] Microsoft Application Error Reporting: ISetupManager::GetGlobalCustomProperty() failed to find global prop in CBaseComponent::GetGlobalCustomProperty()
    
    [04/13/10,19:17:21] Microsoft Application Error Reporting: ISetupManager::GetGlobalCustomProperty() failed to find global prop in CBaseComponent::GetGlobalCustomProperty()
    
    [04/13/10,19:17:21] Microsoft Application Error Reporting: CBaseComponent::LaunchWatson() - Creating a PreReq Watson report with manifest: C:\DOCUME~1\davidne\LOCALS~1\Temp\MANF5.tmp
    
    [04/13/10,19:17:21] Microsoft Application Error Reporting: CBaseComponent::LaunchWatson() - Using manifest: C:\DOCUME~1\davidne\LOCALS~1\Temp\MANF5.tmp
    
    [04/13/10,19:17:21] Microsoft Application Error Reporting: ISetupManager::GetGlobalCustomProperty() failed to find global prop in CBaseComponent::GetGlobalCustomProperty()
    
    [04/13/10,19:17:21] Microsoft Application Error Reporting: CBaseComponent::LaunchWatson() - Setting the property CustomCoreProp_WatsonManifestReady to use the GenComp Manifest.
    
    [04/13/10,19:17:21] Setup.exe: AddGlobalCustomProperty
    
    [04/13/10,19:17:21] Microsoft Application Error Reporting: CBaseComponent::LaunchWatson() - Completed
    
    [04/13/10,19:17:21] Setup.exe: AddGlobalCustomProperty
    
    [04/13/10,19:17:21] setup.exe: ***ERRORLOG EVENT*** : ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467259.
    
    
    • Edited by davidne Tuesday, April 13, 2010 11:49 PM Added excerpts from error logs
    Tuesday, April 13, 2010 11:43 PM

Answers

  • Hi David,

    Microsoft Application Error Reporting: File failed validation: e:\setup\..\wcu\watson\dw20shared.msi; error = 0x80091007

    The issue is caused by the hashcode verification fails on the installer wcu\watson\dw20shared.msi.

    I understand that you've downloaded twice but the same problem still happen. Please try to use some download manager and empty the %temp% folder before downloading, I'm not sure where you download from, please use official download website, or you can get the dw20shared.msi from somewhere else and copy it to the location.

    Thanks.


    Figo Fei
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com 


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Figo Fei Wednesday, April 21, 2010 8:39 AM
    Wednesday, April 14, 2010 7:11 AM
  • We ended up downloading the ISO file again and it finally worked.

     

    I did notice that the timestamp on the ISO file was not the same as the one I downloaded Wednesday. ???

    Friday, April 16, 2010 2:29 PM

All replies

  • Hi David,

    Microsoft Application Error Reporting: File failed validation: e:\setup\..\wcu\watson\dw20shared.msi; error = 0x80091007

    The issue is caused by the hashcode verification fails on the installer wcu\watson\dw20shared.msi.

    I understand that you've downloaded twice but the same problem still happen. Please try to use some download manager and empty the %temp% folder before downloading, I'm not sure where you download from, please use official download website, or you can get the dw20shared.msi from somewhere else and copy it to the location.

    Thanks.


    Figo Fei
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com 


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Figo Fei Wednesday, April 21, 2010 8:39 AM
    Wednesday, April 14, 2010 7:11 AM
  • I have the same problem and I downloaded image from MSDN site (I have MSDN subscription). How can we install VS2010 premium???
    Wednesday, April 14, 2010 1:33 PM
  • Check the SHA1 result with this tool:
    http://support.microsoft.com/kb/841290
    And match with the one specified in the download site (MSDN or wherever you got the file)
    Thursday, April 15, 2010 1:00 PM
  • I would recommend trying downloading the ISO using Free Download Manager(http://www.freedownloadmanager.org).... When the download starts, just stop it for a while, press ALT + ENTER, go to Integrity tab and specify the valid checksum of your choice(MD5, SHA1 ect) for the file!

    Thursday, April 15, 2010 2:25 PM
  • We downloaded the iso file from our MSDN subscription and made some dvd's. They fail with the same error.

     

    Thursday, April 15, 2010 5:38 PM
  • We ended up downloading the ISO file again and it finally worked.

     

    I did notice that the timestamp on the ISO file was not the same as the one I downloaded Wednesday. ???

    Friday, April 16, 2010 2:29 PM
  • We ended up downloading the ISO file again and it finally worked.

     

    I did notice that the timestamp on the ISO file was not the same as the one I downloaded Wednesday. ???


    Hi Michael,

    Thanks for your feedback.

    As for timestamp, the download should be the same, just could be download server transfer.

    Thanks.


    Figo Fei
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com 


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, April 19, 2010 2:20 AM
  • Our Group download has worked for others but not me.  Is there a way to change/update Dr Watson instead of getting a new ISO download?  I don't understand why it worked for others in the group, but it failed on my machine.  (XP SP3)
    Wednesday, September 08, 2010 3:06 PM