locked
Why can't I see a preview of the environment desktops in Lab Manager nor Environment Viewer?

    Soru

  • When I select on an environment in Lab Manager, on the right it just shows a computer clip art for each VM. I've seen in demonstrations that I should be able to see a live preview of the desktop.

    Its the same result when using the environment viewer. Each VM is just a little computer clip art instead of a small preview window. 

    Is there something that needs to be enabled for this to show a live desktop?

    Brandon

    22 Şubat 2012 Çarşamba 22:38

Tüm Yanıtlar

  • Hello Barndon,

    Based on this MSDN artile,

    You can interact with the virtual environments you create by using Microsoft Test Manager and Microsoft Environment Viewer, an additional tool that is included in Visual Studio Test Professional. You can connect only to deployed environments. Whether you can open a remote connection to each virtual machine in the environment depends on the state of that virtual machine.

    Please take a look at the article I offered above for further information about How to: Connect to a Virtual Environment: http://msdn.microsoft.com/en-us/library/ee518907.aspx

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    24 Şubat 2012 Cuma 07:06
  • Hello Barndon,

    Based on this MSDN artile,

    You can interact with the virtual environments you create by using Microsoft Test Manager and Microsoft Environment Viewer, an additional tool that is included in Visual Studio Test Professional. You can connect only to deployed environments. Whether you can open a remote connection to each virtual machine in the environment depends on the state of that virtual machine.

    Please take a look at the article I offered above for further information about How to: Connect to a Virtual Environment: http://msdn.microsoft.com/en-us/library/ee518907.aspx

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Vicky,

    That answer has nothing to do with my question. I'm not asking how to connect to the environment, I'm asking how to get the small live preview window for each VM in the environment. 

    24 Şubat 2012 Cuma 17:23
  • Hello Barndon,

    Yes, I understand that you would like to get the live preview window for the VM in the Environment. And in order to achieve that you need to connect to that VM machine first. Do you mean even though you have connect to the VM machines, you still can't get the live preview window? In the right pane, are you able to right-click the VM machines and select the Connect option?

    Thanks. 


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    28 Şubat 2012 Salı 08:26
  • Hello Barndon,

    Yes, I understand that you would like to get the live preview window for the VM in the Environment. And in order to achieve that you need to connect to that VM machine first. Do you mean even though you have connect to the VM machines, you still can't get the live preview window? In the right pane, are you able to right-click the VM machines and select the Connect option?

    Thanks. 

    Vicky,

    I shouldn't have to connect to a VM first in order to get the live preview of ALL the VMs in the environment. With the Lab Manager window opened to the Environments section, if you click on an environment on the left side, you should see the set of VMs on the right side. There should be a small live preview window of each desktop where you can see what each VM is doing.

    For example, here's a snapshot of what I'm referring to:

    Now if I connect to the environment it brings up the Environment Viewer. Here, I should get a preview window as well for all the VMs in the environment like this:

    But in my Lab Manager and Environment Viewer, I only get little computer icons like this:


    28 Şubat 2012 Salı 23:10
  • Are you able to connect to these VM's with your credential. If you use some other credential, try to lauch MTM with those credentials.

    The other thing you can try is to add yourself as an admin on the VM Host where the VM is hosted.

    Thanks,

    Anuj


    http://www.anujchaudhary.com

    29 Şubat 2012 Çarşamba 06:45
  • Are you able to connect to these VM's with your credential. If you use some other credential, try to lauch MTM with those credentials.

    The other thing you can try is to add yourself as an admin on the VM Host where the VM is hosted.

    Thanks,

    Anuj


    http://www.anujchaudhary.com

    Anuj,

    Yes, I can connect to the VMs with my credentials just fine. Even connected I don't get the preview. See here:

    Being an admin on the host won't be possible because we have many users and a host farm and we can't allow users to be admins on the VM hosts. There has to be another way. I'm allowed to connect to the VM so why can't the little preview work?

    Brandon


    29 Şubat 2012 Çarşamba 16:28
  • Any more thoughts on this issue?
    27 Mart 2012 Salı 06:54
  • Hello Brandon,

    I am very sorry for the late response as I did not receive the email alert.

    As far as I know that the preview window in MTM is somewhat the same as that in the Hyper-V manager, that is you can't preview one machine when another user is working on it. Please take a look at both the Hyper-V manager and the MTM to make sure that there are no other team members already connected to them.

    Thanks. 


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    27 Mart 2012 Salı 07:12
  • Hello Brandon,

    I am very sorry for the late response as I did not receive the email alert.

    As far as I know that the preview window in MTM is somewhat the same as that in the Hyper-V manager, that is you can't preview one machine when another user is working on it. Please take a look at both the Hyper-V manager and the MTM to make sure that there are no other team members already connected to them.

    Thanks. 


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    No one is connected to the machines.
    27 Mart 2012 Salı 14:51
  • Hi,

    The only user who gets previews is the "Owner" (which is the user who deployed that environment from MTM)

    Refer to this post:

    http://social.msdn.microsoft.com/Forums/en-US/vslab/thread/932ea60e-821c-4aed-9417-9b18d3e62d60

    and this:

    http://social.msdn.microsoft.com/Forums/en-US/vslab/thread/3cd06a5d-202c-4358-80f9-a44f999ef8fd

    Apparently this is a quite common problem, 3 threads on front page.

    Greetings

    Johannes

    29 Mart 2012 Perşembe 15:50
  • Hi,

    The only user who gets previews is the "Owner" (which is the user who deployed that environment from MTM)

    I don't get a preview of environments I own.
    29 Mart 2012 Perşembe 19:50