locked
Dashboards Error - Data Refresh Failed

    คำถาม

  • Hi, I installed TFS2010 & SQL Server on one system and Sharepoint 2007 on other server. I completed all the steps during configuration. But my dashboards are not refreshing. I am getting the following error

    "Data Refresh Failed

    Unable to retrieve external data for the following connections:

    TfsOlapReport

    The data sources may be unreachable, may not be responding, or may have denied you access.

    Verify that data refresh is enabled for the trusted file location and that the workbook data authentication is correctly set."

    I configured single sign on MOss2007 server. In Data connection properties -> authentication settings, by default Windows authentication was selected.

    In some other post i read that it has to point to SSS ID. how do i configure this. http://social.msdn.microsoft.com/Forums/en-US/tfsreporting/thread/7f352cba-b243-41af-9137-3f58de519a87

    In logs i did n't found any error messages related to credentials.

     please go through the following link.

    Thanks & Regards,

    Sekhar

    10 กรกฎาคม 2553 9:29

คำตอบ

  • Hi chanduvsc,

    Have you already reviewed the "How to: Configure Settings for Dashboard Compatibility" in TFSInstall.chm guide for TFS 2010 ?

    At the last part of this guide about using the stsadm  ecssecurity command:

    Set the access model

    After you configure all the settings and services that Team Foundation Server requires, you must configure the access model for the Web application for single sign-on for delegation. If you do not configure the access model, Team Foundation Server and the Web application cannot interoperate.

    To set the access model

    1. On the server that is running SharePoint Central Administration, open a command prompt.

    2. Change directories to %programfiles%\Common Files\Microsoft Shared\Web Server Extensions\12\bin and type the following command:

      stsadm -o set-ecssecurity -ssp SharedServiceProviderName -accessmodel delegation

      SharedServiceWebApplicationName is the name of the shared service provider that you created. If you followed the suggested naming convention, this name is SharedServices1.

    3. At the command prompt, type iisreset to restart IIS.

    Please perform the above steps strictly?

    Hope it helps!

    If you have any concern, please feel free to let me know!

    Best Regards,

    Cathy Kong

     

    13 กรกฎาคม 2553 3:28
    ผู้ดูแล

ตอบทั้งหมด

  • Hi chanduvsc,

    Have you already reviewed the "How to: Configure Settings for Dashboard Compatibility" in TFSInstall.chm guide for TFS 2010 ?

    At the last part of this guide about using the stsadm  ecssecurity command:

    Set the access model

    After you configure all the settings and services that Team Foundation Server requires, you must configure the access model for the Web application for single sign-on for delegation. If you do not configure the access model, Team Foundation Server and the Web application cannot interoperate.

    To set the access model

    1. On the server that is running SharePoint Central Administration, open a command prompt.

    2. Change directories to %programfiles%\Common Files\Microsoft Shared\Web Server Extensions\12\bin and type the following command:

      stsadm -o set-ecssecurity -ssp SharedServiceProviderName -accessmodel delegation

      SharedServiceWebApplicationName is the name of the shared service provider that you created. If you followed the suggested naming convention, this name is SharedServices1.

    3. At the command prompt, type iisreset to restart IIS.

    Please perform the above steps strictly?

    Hope it helps!

    If you have any concern, please feel free to let me know!

    Best Regards,

    Cathy Kong

     

    13 กรกฎาคม 2553 3:28
    ผู้ดูแล
  • Hi chanduvsc,

    Is your issue solved?

    I am marking the reply as answer, if you have any concern, please feel free to unmark the reply and let me know!

    Best Regards,

    Cathy Kong

    15 กรกฎาคม 2553 7:34
    ผู้ดูแล
  • I had the same issue.

    There's no easy solution to fix all your excel reports, you have to go into all your excel spreadsheets in your TFS Team Project.

    1. Expand Documents -> Excel Reports

    2. Right-click and edit the excel spreadsheet

    3. Click on Data -> Properties (For Connections)

    4. Click on the Definitions Tab -> Authentication Settings

    5. Here's the bug.  It's on Windows Authentication.  Should work, right?  Wrong.

    6. Click OK and OK again.  Now it will work.

    7. Save the spreadsheet and now access the dashboard through MOSS 2010.

    8. Voila!  It now works.

     

    Note: To get rid of the security pop-up, just enable all external connections via the Trust Manager in your Office product.

    • เสนอเป็นคำตอบโดย El_Capitan 21 กรกฎาคม 2553 15:30
    21 กรกฎาคม 2553 15:30
  • I had the same issue.

    There's no easy solution to fix all your excel reports, you have to go into all your excel spreadsheets in your TFS Team Project.

    1. Expand Documents -> Excel Reports

    2. Right-click and edit the excel spreadsheet

    3. Click on Data -> Properties (For Connections)

    4. Click on the Definitions Tab -> Authentication Settings

    5. Here's the bug.  It's on Windows Authentication.  Should work, right?  Wrong.

    6. Click OK and OK again.  Now it will work.

    7. Save the spreadsheet and now access the dashboard through MOSS 2010.

    8. Voila!  It now works.

     

    Note: To get rid of the security pop-up, just enable all external connections via the Trust Manager in your Office product.

    I'm having this same issue..

     

    I tried enabling all external connections in excel and the steps above in checking things (its set to windows authentication in each excel sheet on the tfs web page)..

     

    I have a similar setup, except Sharepoint 2010.. (sharepoint on vsintranet02;  sql 2008 on vssqlprod01; vstfs02-the tfs app tier).

     

    I even installed the dashboard update software on vsintranet02 to try to rule that out.

     

    Any thoughts?

    19 ตุลาคม 2553 16:42
  • This is a BUG pure plain and simple. I have seen numerous threads on this and I have yet to see anyone solve it.
    14 มิถุนายน 2554 14:45
  • I have changed Authentication settings from windows to None and It Works...

    24 กุมภาพันธ์ 2555 6:59