none
"go to report" action does not work correctly

    คำถาม

  • Hello,

    I have developed an ASP.NET MVC 3 website to display SSRS reports via Microsoft Report Viewer Control 2010.

    The page of the report is a classic ASP.NET page. Here is the link to access to a specific report: 

    http://localhost/Report.aspx?id=xxxx

    The id url param allow me to identify the report to request the server.

    On a report, I have an action "go to report" on a textbox.

    It works well on the website for all the users/environments except for one. He has a windows xp operating system with IE 8. When he clicks on the link, he is redirected to http://localhost/.

    When we look at the link displayed in the browser, we also see the same url: http://localhost/ but it works correctly on all computers excepted for this particular user. I have installed a virtual machine with the same operating system and ie browser version to be able to reproduce the problem, but there is no problem on my virtual machine.

    Here is the html code generated by the report viewer for this link within the report:

    <a tabindex="2" onclick="var rp=$get('ReportViewerActive_ctl10_ReportControl');if(rp&amp;&amp;rp.control)rp.control.InvokeReportAction('Drillthrough','513:0');return false;" onkeypress="if(event.keyCode == 13 || event.which == 13){var rp=$get('ReportViewerActive_ctl10_ReportControl');if(rp&amp;&amp;rp.control)rp.control.InvokeReportAction('Drillthrough','513:0');}return false;" href="" style="cursor: pointer;" class="A0f26fe100d2645b793c94e3a31c0c800292a" target="_top">View Activity Extract</a>

    Have you any idea?

    13 เมษายน 2555 16:59

ตอบทั้งหมด