locked
VS2010 Help toc good in H3 Viewer, bad in VS

    คำถาม

  • I'm a tech writer, using mshcMigrate to create the mshc/helpcontentssetup.msha for our application, which integrates into VS2010 as local Help. The toc displays perfectly in the H3 viewer, but incorrectly in VS. Below are snippets from the H3 viewer display, VS display, msha text, and toc text.  Thanks for your thoughts.

    Linda

    -------------------------------

    H3 Viewer:

    Help title
       Topic 1
       Topic 2
       Topic 3, etc.

    VS:

    HelpTitle_filename (notice "_filename" - this is the name of the robohelp project, and is not in the hxt)
    Topic 2
    Topic 5
    Topic 1 and so forth, mostly at random

    ----------------------------------

    msha :

    (<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
      <title>Manifest created 2/29/2012 3:47:50 PM by www.helpware.net help tools.</title>
    </head>
    <body class="vendor-book">
      <div class="details">
        <span class="vendor">AMD</span>
        <span class="locale">en-us</span>
        <span class="product">AMD CodeAnalyst Help</span>
        <span class="name">AMD CodeAnalyst Help</span>
      </div>
      <div class="package-list">
        <div class="package">
          <span class="name">codeanalyst_vs</span>
          <a class="current-link" href="codeanalyst_vs.mshc">codeanalyst_vs.mshc</a>
        </div>
      </div>
    </body>
    </html>

    ------------------------------

    hxt (in the toc below, I don't know how or why <ToolData Name="HWFAR_Frame" Value=""/> is added by mshcMigrate)

       <HelpTOCNode Title="AMD CodeAnalyst Help" Url="004_intro_to_ca.htm">
          <HelpTOCNode Title="Workflow and Key Concepts" Url="001_wkflow_key.htm"/>
          <HelpTOCNode Title="Exploring the Workspace" Url="explore_gui.htm"/>
          <HelpTOCNode Title="Preparing an Application for Profiling" Url="preparing_the_app.htm"/>
          <HelpTOCNode Title="Creating a New Project" Url="create_project.htm">
             <ToolData Name="HWFAR_Frame" Value=""/>
          </HelpTOCNode>
          <HelpTOCNode Title="Collect, Analyze, View" Url="collect_intro.htm">
             <ToolData Name="HWFAR_Frame" Value=""/>
          </HelpTOCNode>
    ...
     <ToolData Name="MSTOCEXPST" Value="Expanded"/>
       </HelpTOCNode>
       <ToolData Name="MSTOCEXPST" Value="Expanded"/>
       <ToolData Name="MSTOCMRUDIR" Value="C:\Documents and Settings\lcast\Desktop\AllProjects\24317 CodeAnalyst Win\Help\source_VS2010\2005_hxs\"/>
    </HelpTOC>

    2 มีนาคม 2555 21:22

ตอบทั้งหมด

  • Hi Linda

    TOC text will come from the document <title> tags so check that they are defined in your HTML files.
    The HxT will migrates to the topic TOC Parent meta data.

    If you are still stuck create a small demo of the problem and email me. (see contacts page http://www.helpware.net)

    Rob

    PS. Sorry for the delay. Been travelling this week.


    Rob Chandler Help MVP http://Helpware.net/ http://mshcmigrate.helpmvp.com/

    5 มีนาคม 2555 10:21
    ผู้ดูแล
  • Hi Rob,

    It works! The problem was this:

    • In mshcMigrate, on the Migrate Help tab, I had specified the paths for input/output.
    • On the Update mshc tab, when fixing tags and updating the mshc, I moved my source files to a new location.
    • Using the new file location, my toc displayed correctly View in H3 Viewer.
    • However, when posting the msha/mshc to our server, the hxt in VS was being called from the path in the Migrate Help tab.
    • The fix was using the same path.

    I'm documenting as I go, and will have to revisit this to be sure I understand how it happened. But glory be, it works for the release, and on my birthday too.

    Cheers,

    Linda


    Linda Cast

    7 มีนาคม 2555 18:37
  • Many happy returns Linda :-)

    Rob Chandler Help MVP http://Helpware.net/ http://mshcmigrate.helpmvp.com/

    7 มีนาคม 2555 23:43
    ผู้ดูแล