none
PowerPivot Datamarket Place and Proxy Authentication

    Pergunta

  • How do you get PowerPivot to use the default proxy settings in IE when connecting to external data sources, for example the Azure Data MarketPlace?  I have tried adding an EXCEL.EXE.config file with the following but it has had no effect

    <?xml version="1.0"?>
    <configuration>
     <startup>
      <system.net>
       <defaultProxy enabled="true" useDefaultCredentials="true" >
        <proxy autoDetect="true" usesystemdefault="true"/>

       </defaultProxy>
      </system.net>
     </startup>
    </configuration>

    Whenever I try to connect to an external source I get a proxy authentication error.  I am using the latest 2012 RC0 version on PowerPivot.

    sexta-feira, 10 de fevereiro de 2012 10:32

Respostas

  • Hi again,

    For me the issue was resolved adding the following to an "Excel.exe.config" file:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
      <system.net>
        <defaultProxy useDefaultCredentials="true">
          <proxy usesystemdefault="true"/>
        </defaultProxy>
      </system.net>
    </configuration>

    Using Office 2010, hope this helps someone!

    quinta-feira, 31 de janeiro de 2013 11:09

Todas as Respostas

  • Hi,

    In order to further troubleshot your issue, could you please supply more information? such as:

    1. What's your Data Feed URL?

    2. In which steps you have the error? What't the whole Error message?

    Besides, I would recommend open this link to get some reference about how import Azure Marketplace Data into PowerPivot http://jamiemaclennan.blogspot.com/2011/01/cleaning-azure-marketplace-data-with.html 

    Thanks,


    Challen Fu

    TechNet Community Support

    segunda-feira, 13 de fevereiro de 2012 06:50
    Moderador
  • Was there any updates for this issue as I get the same problem when trying to connect to any data feeds from the Data Market.
    sexta-feira, 13 de abril de 2012 01:43
  • I too get a "(407) Proxy Authentication Required" attempting co connect to http://services.odata.org/Northwind/Northwind.svc/Customers With PowerPivot 2012 for Excel on my corporate PC at work, while it works fine from home on the same software and connection.  I see that Brynn has discovered what I have through my recent searches; we were told these elements are required:

       <defaultProxy enabled="true" useDefaultCredentials="true" >
        <proxy autoDetect="true" usesystemdefault="true"/>

       </defaultProxy>

    Please help us resolve these issues in this forum so that others may also find the solution.

    Cheers,

    Scott


    I suppot PASS - www.SQLPASS.org

    terça-feira, 17 de abril de 2012 23:24
  • Do you get any solution for the above query.?

    quarta-feira, 2 de maio de 2012 10:16
  • Any updates?
    terça-feira, 28 de agosto de 2012 10:03
  • I'm unable to add the proxy information anywhere in the PowerPivot UI. Need to address this quickly.
    terça-feira, 28 de agosto de 2012 10:08
  • Hi,

    Sorry to bring up this old thread again but this is quite a big hindrance for me at the moment.

    I have exactly the same issue as Scott described using PowerPivot 11.0.3000.0 behind a corporate proxy. Opening the data feed in question (json fromat) in a browser window is not an issue at all, neither is connecting to the data feed from home (no proxy).

    Thanks,
    AC

    terça-feira, 29 de janeiro de 2013 17:36
  • Hi again,

    For me the issue was resolved adding the following to an "Excel.exe.config" file:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
      <system.net>
        <defaultProxy useDefaultCredentials="true">
          <proxy usesystemdefault="true"/>
        </defaultProxy>
      </system.net>
    </configuration>

    Using Office 2010, hope this helps someone!

    quinta-feira, 31 de janeiro de 2013 11:09
  • Hi again,

    For me the issue was resolved adding the following to an "Excel.exe.config" file:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
      <system.net>
        <defaultProxy useDefaultCredentials="true">
          <proxy usesystemdefault="true"/>
        </defaultProxy>
      </system.net>
    </configuration>

    Using Office 2010, hope this helps someone!

    This fixed my "Proxy Authentication Required" error with  PowerPivot , Thanks for posting 

    quarta-feira, 26 de junho de 2013 15:41
  • I am behind a proxy using PowerPivot for Excel 2010 and I have done this but still I cannot connect.

    Beofre I was receiving the error message:

    "(407) Proxy Authentication Required"

    I have created the excel.exe.config file and Now I am receiving this one:

    "Cannot connect to the specified feed. Verify the connection and try again. Reason: Unable to connect to the remote server"

    In my case the proxy requires username and password, and this info is not in the browser, I have to type it at the beginning of every session in any browser. I guess i have to specified extra info in this config file

    quinta-feira, 27 de junho de 2013 12:15
  • Where in the file system did you store this Excel.exe.confg file ?
    • Editado Bda75 terça-feira, 13 de agosto de 2013 08:40
    terça-feira, 13 de agosto de 2013 08:20
  • Same folder as your Excel.exe file - in my case this was "C:\Program Files (x86)\Microsoft Office\Office14"...
    terça-feira, 13 de agosto de 2013 08:57
  • I have saved the file there, but now the error message has changed, exactly like described by DavidAarranz above. Yet, when opening the Azure URL with IE, the xml file shows up. No proxy authentication is required.
    Any idea ?
    terça-feira, 13 de agosto de 2013 09:18